3.0 OS upgrade and your data plan

Proto732

Member
Jun 17, 2009
5
0
0
Visit site
I am the BES Admin at work, the ActiveSync admin, the AT&T Corp. Account Admin ... and I swap SIMs in and out of a variety of devices almost daily, to test different options/features we implement at work. I've never had a problem moving a SIM from iphone, to WinMo, to BB and back ... Until today.

I updated my work iPhone 3G to 3.0 OS ... and whamo ... no data service.

I tried a few tricks I saw online (resetting network settings, doing a restore back to default ...) but it seems the ultimate fix is that the SIM has to be provisioned with an iPhone dataplan in order to work at all with the 3.0 OS. After 45 minutes on the phone with AT&T they changed the data plan over, and boom ... everything works fine.

The SIM I initially tried had a full unlimited "PDA dataplan on" it (the same cost for the iphone unlimited data plan). I knew AT&T was being specific about having the right data plan going forward, but I didn't realize it HAD to be an "iPhone" data plan for 3.0.

Now I wonder what will happen if I try to put this SIM back into a WinMo or BB device?? AT&T told me I need to have a separate line and SIM for every device I have ... which frankly is ridiculous. As we speak I have atleast 10 different devices at my desk, and 3 SIMs I swap around for testing.

Anyone else run into this?
 

Captain Chunk#IM

Active member
Jul 17, 2008
33
0
0
Visit site
I wonder what will happen if I try to put this SIM back into a WinMo or BB device??

I put my iPhone SIM in my WM based HTC Diamond regularly and while the phone functions, there is no data.

Some chick at ATT said I'd need to convert the data plan to the PDA plan in order for data to work on the HTC.

Try yours and find out.
 

Proto732

Member
Jun 17, 2009
5
0
0
Visit site
I tried my newly converted SIM (iphone data plan) on my WinMo FUZE. Data works fine. Calls work fine. ActiveSync to an Exchange 2007 server works fine.

If you don't feel like spending 45 minutes on the phone with AT&T trying to get your data plan converted, I found this other article with a do it yourself fix link at the end.

blogs.zdnet.com/cell-phones/?p=1442
 

mg48

Well-known member
Jun 18, 2009
124
2
0
Visit site
sim swapping

I have the exact same probelm. My sim is in my BB most of the time. I did the upgrade and put the BB sim in the iphone to activate. bam no more data. Only the message telling me I dont have an iphone plan. I put the sim back into the BB and its been working all day. So the question is what do I need to do to get my iphone working again. Its obviosly not an data block on my sim card account. I think I just need to activate the phone with a frineds sim that has a data plan and then I can go back to swapping again. How do I "re-upgrade" so I can activate again?


I am the BES Admin at work, the ActiveSync admin, the AT&T Corp. Account Admin ... and I swap SIMs in and out of a variety of devices almost daily, to test different options/features we implement at work. I've never had a problem moving a SIM from iphone, to WinMo, to BB and back ... Until today.

I updated my work iPhone 3G to 3.0 OS ... and whamo ... no data service.

I tried a few tricks I saw online (resetting network settings, doing a restore back to default ...) but it seems the ultimate fix is that the SIM has to be provisioned with an iPhone dataplan in order to work at all with the 3.0 OS. After 45 minutes on the phone with AT&T they changed the data plan over, and boom ... everything works fine.

The SIM I initially tried had a full unlimited "PDA dataplan on" it (the same cost for the iphone unlimited data plan). I knew AT&T was being specific about having the right data plan going forward, but I didn't realize it HAD to be an "iPhone" data plan for 3.0.

Now I wonder what will happen if I try to put this SIM back into a WinMo or BB device?? AT&T told me I need to have a separate line and SIM for every device I have ... which frankly is ridiculous. As we speak I have atleast 10 different devices at my desk, and 3 SIMs I swap around for testing.

Anyone else run into this?
 

Trending Posts

Members online

Forum statistics

Threads
260,228
Messages
1,765,973
Members
441,230
Latest member
lookie