1604 error, anybody know of a fix?


New member
Jun 19, 2009
Visit site
Friend pointed me to this board after I mentioned the disaster that resulted from my attempt to update my iPhone 3G to 3.0 yesterday.

The phone is now a non-functional brick. Phone was working fine under version 2.something (2.1?) and Thursday morning I decided to ignore reason and go for the 3.0 update the day after it was released.

Bad idea. After downloading and installing the latest version of iTunes (8.0), I proceeded to check for latest version. It detected new version 3.0 available, launched the update process, backed up phone settings, downloaded update (all 200 something MB) then started the update (re-flash) of the phone.

Here is where I entered into the depths of Hell.

ITunes stays stuck on the ?preparing for restore? progress bar for about 8 minutes then generates a ?1604? error.

Subsequent attempts to restore the phone now fail as well. Blank screen on phone, although I can put it in recovery mode (USB cable pointing to iTunes logo). After several attempts, the phone stopped being recognized in iTunes.

Opened a ticket with Apple. Was on the phone (land line) with them for 3 hours. We tried:

1.) Using a different computer (Windows XP SP3 desktop)
2.) Disconnecting all other USB devices from the other computer
3.) Disabling all anti-virus
4.) Turning off everything but the Apple update service in services.msc
5.) Trying different USB cables
6.) Removing and re-installing the Apple mobile device driver in Device Manager
7.) Some other stuff I can?t remember

Finally they advised I take the phone into the nearest Apple store (28 miles away) on Saturday, see if they can recover it or give me a new phone. Massive PITA to do that. At least I was able to take the SIM out and put it in my old reliable Motorola L7 so I have cell functionality in the meantime (no texting though, which sucks).

Maybe I can talk them into a new 3G s in exchange for the 5 hours of my life I will never get back???

FYI, I am NOT using a jail broken phone. Just a garden variety iPhone 3G 8GB model. Again, working fine for almost a year until I tried the 3.0 update process.

Any information on if, or how, this error can be resolved would be much appreciated.

Trending Posts

Members online

Forum statistics

Latest member