1. Jeroen7's Avatar
    When i'm using my ipad air, and scroll down the article list on the main page, it just freezes quite often because of all te pictures, ads and other stuff that has to load. I dont know how many scripts are running but it's really annoying at times. I also have this on the contest pages with the widget. And it doesn't seem to be my internet connection because other sites work just fine.

    Is there any way to improve the speed of the website by lessening on the graphics or reducing them in size? Or maybe not show e erything on one page make it paged?
    03-23-2016 05:08 PM
  2. John Yester's Avatar
    Reset cookies and cache?

    I was having issues as well when using the site and I reset my router and it's worked wonders.
    03-24-2016 10:20 AM
  3. anon(153966)'s Avatar
    It used to the same issue for me. But, curious, are you using Google Chrome? If not, try it, that seems to help...

    When i'm using my ipad air, and scroll down the article list on the main page, it just freezes quite often because of all te pictures, ads and other stuff that has to load. I dont know how many scripts are running but it's really annoying at times. I also have this on the contest pages with the widget. And it doesn't seem to be my internet connection because other sites work just fine.

    Is there any way to improve the speed of the website by lessening on the graphics or reducing them in size? Or maybe not show e erything on one page make it paged?
    03-28-2016 06:24 AM
  4. James Falconer's Avatar
    Like John said, sometimes the best place to start is 'resetting all the things'... clear your cache, cookies, etc and give it a spin.

    We do run into issues with ads from time to time, so please do report them here as it'll help us fix any issues ASAP.

    Thanks for posting!!
    03-28-2016 09:31 AM
  5. Jeroen7's Avatar
    Clearing the cache and cookies helped, mostly. It's a lot more responsive now.
    At start it's works pretty fast but after a few days I notice scrolling just shows a grey background and when you let go it'll load the page where you stopped. But if you go up again it seems to have forgotten what has been loaded so you see the grey area again. That's not very convenient.

    I'm using safari btw. I tried it in chrome and that works a lot quicker, loads the page faster and hardly get grey areas. So I guess the site has something that safari can't handle well?
    04-06-2016 01:08 PM
  6. Jeroen7's Avatar
    So, since my last post the site is sluggish again. I haven't visited much since the last time because most news I get via RSS. Even the forums are quite slow to scroll down and kindof builds per page you scroll, so you have to wait a few secs to continue. Even this topic with a few posts, scrolling back up results in a grey page which takes a sec or two to show again
    05-23-2016 12:44 PM
  7. James Falconer's Avatar
    Hmmm out of curiosity are you on mobile or desktop? Newer or older machine?
    05-27-2016 10:22 AM
  8. Wotchered's Avatar
    I am surprised that an ipad air is slow to scroll, My gen three is not. In fact the only time I have seen this at all was on one particular website ( now fixed)Why not try force closing all apps and webpages and see if it still does it ? I have noticed that these devices get a bit sluggish if too much is left open.
    05-27-2016 03:51 PM
  9. Jeroen7's Avatar
    I'm using an ipad air (1) and safari. Latest ios version.

    Ok, this gets weird now. The site is pretty snappy atm. The only thing thats different is that I've got my ipad charging atm.
    So I pulled my cable out, still seems about fine.
    Then went to homescreen and tapped safari again to get it to the front again, and the lag was back.
    So I put my cable in again and... tadaa... it loads a lot faster.
    Now I'm confused...
    05-27-2016 04:58 PM
  10. James Falconer's Avatar
    I am too. Have tried on laptop, iPhone and iPad over here and all seems snappy. If you can nail it down to something we can reproduce, I'll make sure we fix!!!
    05-30-2016 02:04 PM
  11. Jeroen7's Avatar
    I'll keep looking!
    robertk328 likes this.
    05-30-2016 03:05 PM
  12. robertk328's Avatar
    How are you on memory in your iPad? Plenty of free space?
    05-30-2016 04:02 PM
  13. James Falconer's Avatar
    ^ Was wondering that as well.
    robertk328 likes this.
    06-01-2016 09:58 AM
  14. Jeroen7's Avatar
    I've got about 30% of free space, 18GB free and 37GB in use.
    Lately I've checked the site more often and it looks okish, it's not very fast but not always that laggy that you get grey blocks which take a few secs to load.
    06-07-2016 04:15 PM
  15. Jeroen7's Avatar
    Just an update, havent had any cases of lag since weeks.

    So things might have improved forumside, I can't recall doing anything significant on my side.

    it's working fine now
    08-21-2016 03:47 PM
  16. James Falconer's Avatar
    Good stuff - be sure to reach out if you experience similar in the future! Appreciate the feedback!
    08-22-2016 10:41 AM

Similar Threads

  1. iOS 9.3 on my iPhone 6 is very slow..
    By calibru in forum iOS 9
    Replies: 12
    Last Post: 03-28-2016, 02:52 PM
  2. Replies: 1
    Last Post: 03-23-2016, 01:15 PM
  3. Replies: 1
    Last Post: 03-23-2016, 12:50 PM
  4. Replies: 0
    Last Post: 03-23-2016, 09:17 AM
  5. Replies: 0
    Last Post: 03-22-2016, 10:01 AM
LINK TO POST COPIED TO CLIPBOARD