1. donawalt's Avatar
    I decided to come here and post again, as I saw iMore had an article today"come post in our forums!" Has the author used these forums? What is exasperating is that some obvious things have not been fixed since the new site was created. I used the forums on a Mac in Safari browser, but I saw the same thing in Chrome.

    BTW, I am sure you know this - forums that should be very popular, like MacBook Pro, Mac OS, iPhone 7, etc. have very few messages in a week. There used to be a lot. I come here less because the experience is not good, I really think this needs some attention or else everyone will leave.

    Three issues that continue to drive me crazy:
    1. I cannot see if I am logged in or not without clicking on the menu. It matters because 'unread' will not be correct if I am not logged in, of course. I have never seen a forum where I do not get some acknowledgment that I am logged in, visually, on the list of threads page.
    2. Clicking on a thread title to go to the posts ALWAYS displays half of the post, and I have to scroll up to begin reading! I have posted this before. Do you not see this, do you need a video of it or something?
    3. Tools/Mark this forum read does not refresh the screen and show all threads as read - also posted before.

    These seem so trivial to fix. I am sure others have a similar small list of usability issues that keep them away. When you get aggravated using a site you visit less. Please fix these, they have been reported before!
    David Lundblad likes this.
    08-29-2017 07:44 AM
  2. metllicamilitia's Avatar
    I decided to come here and post again, as I saw iMore had an article today"come post in our forums!" Has the author used these forums? What is exasperating is that some obvious things have not been fixed since the new site was created. I used the forums on a Mac in Safari browser, but I saw the same thing in Chrome.

    BTW, I am sure you know this - forums that should be very popular, like MacBook Pro, Mac OS, iPhone 7, etc. have very few messages in a week. There used to be a lot. I come here less because the experience is not good, I really think this needs some attention or else everyone will leave.

    Three issues that continue to drive me crazy:
    1. I cannot see if I am logged in or not without clicking on the menu. It matters because 'unread' will not be correct if I am not logged in, of course. I have never seen a forum where I do not get some acknowledgment that I am logged in, visually, on the list of threads page.
    2. Clicking on a thread title to go to the posts ALWAYS displays half of the post, and I have to scroll up to begin reading! I have posted this before. Do you not see this, do you need a video of it or something?
    3. Tools/Mark this forum read does not refresh the screen and show all threads as read - also posted before.

    These seem so trivial to fix. I am sure others have a similar small list of usability issues that keep them away. When you get aggravated using a site you visit less. Please fix these, they have been reported before!
    I hear you, the MoNa dev’s are always busy fixing issues and making tweaks to create the best experience and unfortunately that’s still going to take some time. They’ve been revamping sites like crazy lately which brings its own host of issues as well. As far as slow sub forums, I agree, I am guilty of not posting enough myself, it just seems the things most people want to talk about are in other sub forums. I’ll do what I can myself to help stir up conversation. Thank you for your feedback and hopefully as more changes get made iMore gets back to being a place you enjoy visiting.
    08-29-2017 10:14 AM
  3. David Lundblad's Avatar
    I decided to come here and post again, as I saw iMore had an article today"come post in our forums!" Has the author used these forums? What is exasperating is that some obvious things have not been fixed since the new site was created. I used the forums on a Mac in Safari browser, but I saw the same thing in Chrome.

    BTW, I am sure you know this - forums that should be very popular, like MacBook Pro, Mac OS, iPhone 7, etc. have very few messages in a week. There used to be a lot. I come here less because the experience is not good, I really think this needs some attention or else everyone will leave.

    Three issues that continue to drive me crazy:
    1. I cannot see if I am logged in or not without clicking on the menu. It matters because 'unread' will not be correct if I am not logged in, of course. I have never seen a forum where I do not get some acknowledgment that I am logged in, visually, on the list of threads page.
    2. Clicking on a thread title to go to the posts ALWAYS displays half of the post, and I have to scroll up to begin reading! I have posted this before. Do you not see this, do you need a video of it or something?
    3. Tools/Mark this forum read does not refresh the screen and show all threads as read - also posted before.

    These seem so trivial to fix. I am sure others have a similar small list of usability issues that keep them away. When you get aggravated using a site you visit less. Please fix these, they have been reported before!
    Thanks for the feedback! I have added this to our forum bug list. We are doing a lot of development across all our sites so that does impact the forums too.
    Spencerdl likes this.
    08-29-2017 02:09 PM
  4. Ledsteplin's Avatar
    Thanks for the feedback! I have added this to our forum bug list. We are doing a lot of development across all our sites so that does impact the forums too.
    When will some of the forum apps issues be addressed? "Likes" still do not show. Many images posted appear broken. TapaTalk says it's an iMore issue. Yet months go by with no fix. Reporting issues in Trello does nothing. I follow many other forums in TapaTalk, but they don't have these problems. Both these issues occur in TapaTalk as well as the iMore forums app. Broken images seem to happen when one posts from a computer with thumbnails or they're posted using attachments. The "likes" are a big part of forum activity. Yet they haven't worked on the apps for 6 months or more.
    David Lundblad and Spencerdl like this.
    08-30-2017 06:41 AM
  5. Spencerdl's Avatar
    Thanks for the feedback! I have added this to our forum bug list. We are doing a lot of development across all our sites so that does impact the forums too.
    Thanks David.
    08-30-2017 06:43 AM
  6. David Lundblad's Avatar
    When will some of the forum apps issues be addressed? "Likes" still do not show. Many images posted appear broken. TapaTalk says it's an iMore issue. Yet months go by with no fix. Reporting issues in Trello does nothing. I follow many other forums in TapaTalk, but they don't have these problems. Both these issues occur in TapaTalk as well as the iMore forums app. Broken images seem to happen when one posts from a computer with thumbnails or they're posted using attachments. The "likes" are a big part of forum activity. Yet they haven't worked on the apps for 6 months or more.
    I was not aware of these issues. We've been focusing on the new iMore app but I will add these issues to our dev board. thanks!
    Spencerdl likes this.
    08-30-2017 06:46 AM
  7. Ledsteplin's Avatar
    I was not aware of these issues. We've been focusing on the new iMore app but I will add these issues to our dev board. thanks!
    Thanks!
    08-30-2017 08:30 AM
  8. Ledsteplin's Avatar
    I was not aware of these issues. We've been focusing on the new iMore app but I will add these issues to our dev board. thanks!
    Have the team check out why when Push Notifications are selected in the iMore forums app settings, it crashes the app.
    08-30-2017 01:49 PM
  9. GioLogist's Avatar
    @donawalt

    1. I cannot see if I am logged in or not without clicking on the menu. It matters because 'unread' will not be correct if I am not logged in, of course. I have never seen a forum where I do not get some acknowledgment that I am logged in, visually, on the list of threads page.
    2. Clicking on a thread title to go to the posts ALWAYS displays half of the post, and I have to scroll up to begin reading! I have posted this before. Do you not see this, do you need a video of it or something?
    3. Tools/Mark this forum read does not refresh the screen and show all threads as read - also posted before.
    1) If not logged in, you should see "create your account" instead of "unread", etc.
    2) Remedied that Previously, it would attempt to go to the new post. We've altered it so that it no longer does this by default.
    3) When marking a forum as read, the page will now mark it and reload

    Enjoy!
    09-21-2017 08:52 AM
  10. donawalt's Avatar
    Thanks! Have you noticed that "Mark forum as read" does not always mark all posts? I just had it happen today, not 20 minutes I marked iPhone 8 as read, I just went back to it, and one thread had '29 unread', from days ago.
    09-21-2017 09:03 AM
  11. James Falconer's Avatar
    Thought I'd step in here real quick...

    To all (and especially @donawalt), thanks for the feedback here. As @metllicamilitia rightly noted, we've been making a lot of changes around here lately. Tech and design are doing a great job keeping things moving, but of course we can't do this without your feedback.

    We appreciate it - really - keep it coming!
    09-21-2017 10:04 AM
  12. Ledsteplin's Avatar
    It appears all images posted on iMore using the TapaTalk app and the iMore forums app show as broken. Those using attachments have been broken for a long time, but now those posted using the TapaTalk image method also now use attachments. So all images, wallpapers, screenshots, etc show as broken in the apps. I think this is also true in Android Central. None of the other forums I frequent have this issue in TapaTalk. Only MobileNations. This should be a high priority fix, as many users/members enjoy posting and saving wallpapers and showing their screenshots. It seems to affect those threads with many images the most. It worked ok on this thread, but not on others.
    Still no improvement in obvious issues-img_9929.jpg
    Tartarus likes this.
    12-31-2017 09:50 AM

Similar Threads

  1. Have you joined the discussion in the iMore forums yet?
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 08-29-2017, 07:10 AM
  2. How to use Siri to learn a new language in iOS 11
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 08-28-2017, 07:10 AM
  3. Replies: 3
    Last Post: 08-26-2017, 04:05 PM
  4. No refund received yet
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 08-26-2017, 02:06 PM
  5. Pokémon Go servers down again: Here's why you're getting 'Failed to Log In' right now!
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 08-26-2017, 12:00 PM
LINK TO POST COPIED TO CLIPBOARD