1. anon(5719825)'s Avatar
    Using these three browsers, the site just loads a blank page full the sage repeating ad.
    03-24-2017 03:37 PM
  2. Ledsteplin's Avatar
    Just that one site? If so, the site is probably corrupted. Possibly from too many ads. You might try a good ad blocker for Safari. Or one that covers everywhere.
    03-24-2017 06:11 PM
  3. anon(5719825)'s Avatar
    Imore is the only site broken. With my adblocker, I get a blank site and with it off, all I get are ads and no forums. They broke something today.
    03-24-2017 06:26 PM
  4. Ledsteplin's Avatar
    So it had been working up to today?
    03-24-2017 06:52 PM
  5. anon(5719825)'s Avatar
    Yes it was. It's now working once again. I used Chrome to type this reply on my Mac.
    Ledsteplin likes this.
    03-25-2017 02:00 AM

Similar Threads

  1. Deal: Unlimited Calls, Text and 10GB of 4G LTE data for $20 per month
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 03-24-2017, 02:40 PM
  2. How to edit pictures in Photos for Mac
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 03-24-2017, 12:10 PM
  3. Mobile Site
    By stilltwinston in forum iMore.com News Discussion & Contests
    Replies: 1
    Last Post: 03-24-2017, 11:59 AM
  4. Ticket to Earth Review: A colorful, intelligent, and original strategy RPG you'll love!
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 03-24-2017, 11:10 AM
  5. Replies: 0
    Last Post: 03-24-2017, 08:20 AM
LINK TO POST COPIED TO CLIPBOARD