1. acedzero's Avatar
    Every time I try to send a SMS in the messages app, it tells me the number is not registered with iMessage.. Wasn't that the whole point??

    I have checked all settings on Mac and iPhone and I can't seem to find anything out of place...
    10-16-2014 09:49 PM
  2. thejasonhowell's Avatar
    Only supported starting iOS 8.1.

    We'll have it Monday.


    Sent from my T-Mobile iPhone 5c using Tapatalk
    TurboTiger likes this.
    10-16-2014 09:50 PM
  3. Krist0's Avatar
    thank you man! I was driving crazy because phone calls function perfectly and sms didn't! I couldn't get why!!!
    10-19-2014 08:04 PM
  4. BenitoC's Avatar
    You'll need to go into settings on your iPhone and select which devices you want to allow to use Text Message Forwarding.
    10-20-2014 02:15 PM
  5. HankAZ's Avatar
    To enable "Text Message Forwarding", both (all) devices must be signed into the same iCloud account and connected to the same WiFi network. You set the SMS Message Forwarding from your iPhone:

    1. Go to Settings > Messages
    2. Tap Text Message Forwarding
    3. Turn on forwarding for the computers/tablets that you want to use
    4. Each computer will get a popup with a 6 digit code
    5. Enter that code to activate the Text Message Forwarding on that computer/tablet
    Last edited by HankAZ; 10-20-2014 at 05:29 PM.
    TurboTiger likes this.
    10-20-2014 02:30 PM
  6. koerk's Avatar
    What if my MacBook doesn't show a code after activating at the iPhone? Tried it several times.
    10-20-2014 05:27 PM
  7. HankAZ's Avatar
    What if my MacBook doesn't show a code after activating at the iPhone? Tried it several times.
    You must be logged into the same iCloud account on both devices, as well as the same wifi network.
    10-20-2014 05:29 PM
  8. iEd's Avatar
    SMS is working great for me in Yosemite. Phone calls don't. Same wifi same iCloud account. Late 2007 iMac.
    10-20-2014 11:00 PM
  9. HankAZ's Avatar
    SMS is working great for me in Yosemite. Phone calls don't. Same wifi same iCloud account. Late 2007 iMac.
    For phone calls, you must be logged in to the same iCloud account in FaceTime on both devices.
    10-20-2014 11:06 PM
  10. iEd's Avatar
    For phone calls, you must be logged in to the same iCloud account in FaceTime on both devices.
    Yup I'm logged into same iCloud account on all devices in FaceTime.
    10-20-2014 11:08 PM
  11. HankAZ's Avatar
    Yup I'm logged into same iCloud account on all devices in FaceTime.
    Make sure that on the FaceTime > Preferences > Settings page the box is checked for iPhone Cellular Calls.
    10-20-2014 11:17 PM
  12. iEd's Avatar
    Make sure that on the FaceTime > Preferences > Settings page the box is checked for iPhone Cellular Calls.
    Yup got that checked.
    Any attempts at a out going calls fails. If I attempt to answer a incoming call it fails.

    SMS is like butter. Great to get my group texts on the Mac when it's combo of iPhone and Android people. If I get a group text from 5 people 4 will be IPhone and 1 will be Android. There's always a stray. Lol.
    10-20-2014 11:44 PM
  13. mvbmac's Avatar
    My iPhone (with iOS 8) does not have any such "Text Message Forwarding" button to tap in Message settings. ???
    10-21-2014 02:03 AM
  14. HankAZ's Avatar
    My iPhone (with iOS 8) does not have any such "Text Message Forwarding" button to tap in Message settings. ???
    SMS Forwarding is a feature of iOS 8.1. You have to upgrade to get it.
    10-21-2014 02:22 AM
  15. koerk's Avatar
    You must be logged into the same iCloud account on both devices, as well as the same wifi network.
    I am and my iPhone suggests my MBA when entering the text forwarding menu. But my MBA doesn't show a code when it should be.

    Any ideas? Already rebooted Mac and iPhone. My iPhone isn't Bluetooth connected to my Mac right now like it was yesterday. How can it get its connection back?
    10-21-2014 04:24 AM
  16. iEd's Avatar
    Solved my Mac phone call issue by doing a clean install of Yosemite. Like butter now incoming and outgoing
    10-27-2014 10:31 AM

Similar Threads

  1. Text message search
    By lensterman in forum iPhone 6
    Replies: 4
    Last Post: 01-18-2017, 03:11 AM
  2. Replies: 18
    Last Post: 10-17-2014, 07:42 PM
  3. Replies: 3
    Last Post: 10-16-2014, 10:39 PM
  4. 1Password gets a fresh coat of Yosemite, updated to 5.0
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-16-2014, 09:12 PM
  5. Replies: 0
    Last Post: 10-16-2014, 09:00 PM
LINK TO POST COPIED TO CLIPBOARD