1. jaleelhamid's Avatar
    Just wondering if anyone can help me out with this but I have a 2012 MacBook Pro but how come when I turn it on it always goes to my 2.4ghz network rather than my 5ghz when I have my macbook and AirPort Extreme set to have both networks available?
    10-07-2014 12:06 AM
  2. SeanHRCC's Avatar
    Because it/you assigned the 2.4Ghz channel before the 5Ghz channel when setting up your Macbook's WiFi settings...the fix is pretty easy though. Open network preferences, and then open advanced preferences and remove the 2.4Ghz network from your list of preferred networks. This will make your computer default to the 5Ghz channel...once this is saved, you can later add the 2.4Ghz channel so that it uses it if the 5Ghz channel is ever interrupted and not available.

    Given the OS is still in beta, it is also possible that there's a weird buggy setting in the code that is making your WiFi preferences auto load the more wide reaching of the two channels (2.4Ghz will always have a more broad reach vs. 5Ghzs smaller but more powerful reach). 2.4Ghz channel also has a stronger penetration factor, which could come into play.

    If you have done this before, there is a slight chance that your router is not producing a strong enough 5Ghz channel for your Macbook Pro to use properly, which is causing it to default to the back up 2.4Ghz channel. If this is the case you can try resetting your network fully to see if the problem still exists...if it does, you may need to try some internal setting changes (including channel change and possibly firmware updates). If these things still don't remedy the issue, there is a possibility the router itself is malfunctioning and would need repair/replacement.
    jaleelhamid and Iphonejackson like this.
    10-07-2014 01:03 AM
  3. jaleelhamid's Avatar
    Wow thank you! For sharing! Your post was very helpful ! But with my iphone 6 i had it on the 2.4 first and now I leave it on the 5ghz i shouldn't have any problems with them switching right
    10-07-2014 01:48 AM
  4. Blue Shift's Avatar
    You can also drag the networks in preferred order under Preferences->Network->Advanced. Make sure the 5Ghz network is on top of the list and you should be good to go. But like SeanHRCC said, there are other factors like signal strength that will influence which network you end up joining.
    10-08-2014 09:12 AM

Similar Threads

  1. How to Message Non Ios Users and WIFI confusion??
    By Kittycake in forum iPod & iPod Touch
    Replies: 6
    Last Post: 10-30-2014, 04:56 PM
  2. Replies: 6
    Last Post: 10-08-2014, 10:40 AM
  3. Replies: 1
    Last Post: 10-07-2014, 09:29 AM
  4. if i have a unlimited plan data do i need to have wifi on?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 10-06-2014, 05:36 PM
  5. Replies: 0
    Last Post: 10-06-2014, 03:12 PM
LINK TO POST COPIED TO CLIPBOARD