1. cmajpwc's Avatar
    So I have public beta 3 of Yosemite on my late 2011 Air. It definitely has Bluetooth LE and I'm connected to the same WiFi network. My iPhone 5C just upgraded to iOS last night. However, I can't get handoff or air drop working! Is there anything special I need to set up? Or somewhere in settings that I need to go? I can't find handoff in the general settings tab, and air drop doesn't give me options at the bottom of the finder window.

    I AM aware that they removed the SMS functions from the current beta, did they remove handoff and airdrop functionality as well?
    09-18-2014 11:43 AM
  2. Just_Me_D's Avatar
    "In order for Handoff to work you have to be logged into the same iCloud account on you iPhone, iPad, and/or Mac. That's how Handoff knows those devices all belong to the same person — you. Since your iCloud account (Apple ID) is also used for backup and restore, iMessage and FaceTime, iCloud email and Documents in the Cloud, and a lot more, it's a safe, reliable way to make sure you're really you and your devices are really your devices.....Handoff also requires that your iPhone, iPad, and/or Mac be within close proximity to each other. Devices are automagically paired via Bluetooth LE (Bluetooth 4.0 Low Energy) when they come into range and activities are made available for Handoff for as long as they stay within that range.Enforcing proximity is a good idea and one in keeping with Handoff's person-centric approach. It prevents private websites you're visiting, emails or messages you're composing, or documents you're working on from accidentally getting pulled over to a machine that's logged into your account, but at another location where it's not within your physical control." ~ Rene Ritchie

    Source: Handoff in iOS 8 and OS X Yosemite: Explained | iMore
    09-18-2014 12:50 PM
  3. cmajpwc's Avatar
    I've tried all this. How do I tell if the device is paired via Bluetooth LE? I checked and I have the right Apple ID set up too. I even have it set up to use my Apple ID password as my computer password. What am I missing?

    The Handoff setting in general IS missing still, too. When I search for it, it brings me right to the general tab under preferences, but it isn't there. If I can't use it yet because Apple shut it off until the official release is out, fine, but like I said as far as I know the only thing removed was SMS functionality.
    09-18-2014 07:51 PM
  4. Blue Shift's Avatar
    The Handoff setting in general IS missing still, too. When I search for it, it brings me right to the general tab under preferences, but it isn't there. If I can't use it yet because Apple shut it off until the official release is out, fine, but like I said as far as I know the only thing removed was SMS functionality.
    You want to make sure that Air has Bluetooth LE. As far as I know handoff doesn't show up if you don't have LE.
    09-19-2014 10:40 AM
  5. cmajpwc's Avatar
    It does, it has LEP 0x6, which as far as I am concerned, is LE. Making it even more confusing.
    09-19-2014 05:57 PM
  6. mpbeta's Avatar
    I have the same machine and an iPhone 5s.
    I have the same problem. If you find a solution, let me know.
    09-26-2014 09:12 AM
  7. ckegman's Avatar
    Same on my 2013 imac. have face call and airdrop works but no handoff. Have to wait for beta 4 is what i heard from dev.
    09-26-2014 04:01 PM
  8. Julian Bolster's Avatar
    Same problem. I have iPhone 5S and iPad mini, all on iOS8, Macbook Air mid 2011, running Yosemite Public Beta 4, and I have never been able to find "Handoff" in Yosemite Beta even though the help search tells me it should be there. Bluetooth LMP 0X6, so I think that is sufficient for this to work. Handoff works between iPhone and iPad, but not Yosemite on my macbook air.

    Anyone??
    10-01-2014 08:32 AM
  9. cmajpwc's Avatar
    So I just updated to Beta 4, hoping that Handoff would be in the settings menu this time. Unfortunately, it is not. When I click on system report, not only does the right Bluetooth version show up, but in Yosemite it actually has a new line in which it states whether or not your Mac will support Bluetooth LE. My mid-2011 Macbook Air says yes, it will support Bluetooth LE. I am so confused as to why this doesn't show up then in the settings menu to allow handoff. Hopefully someone knows what's going on and fixes this now or in the public release, or I will be taking my Mac to the Apple store after the public release to have them take a look at it and see if they can figure it out.

    Also, Airdrop is not working either. I can't change any settings, and all it will allow is for Mac to Mac. So there's that, too.
    10-01-2014 03:11 PM
  10. thejasonhowell's Avatar
    FWIW I've never found a setting for Handoff in any beta.

    It just works for me.


    Sent from my T-Mobile iPhone 5c using Tapatalk
    10-11-2014 01:30 PM
  11. cmajpwc's Avatar
    Just updated to Beta 5, no dice. Once the official version gets released, and if its still not there, I'll be heading right down to the Apple Store and seeing what's going on. Everything states that handoff should work with my Mac, but hopefully they'll be a little bit more transparent in their upcoming event.
    10-11-2014 09:36 PM
  12. HankAZ's Avatar
    FWIW I've never found a setting for Handoff in any beta.

    It just works for me.


    Sent from my T-Mobile iPhone 5c using Tapatalk
    Attachment 68082Attachment 68083
    10-11-2014 09:42 PM
  13. Mike Mazza's Avatar
    I had the same problem, and fixed it. Here's what I did. I'm using an iPhone 6 (iOS 8.0.2) and Early 2014 MacBook Air (Yosemite Public Beta 6).

    (1) Turn off bluetooth and handoff on phone and laptop.
    (2) LOG OUT of iCloud on laptop.
    (3) Go through whole process of signing back in.
    (4) Chill out for a while just to be safe.
    (5) Turn bluetooth and handoff on for laptop.
    (6) Turn bluetooth and handoff on for phone.
    (8) Enjoy!

    That fixed my problem, at least. Hope this helps someone else.
    robertk328 likes this.
    10-16-2014 01:44 AM
  14. cmajpwc's Avatar
    Well, I guess the mid-2011 Macbook Air is not supported by handoff . Did the official Yosemite update yesterday, and they added a new line under bluetooth in system report. Apparently, while the Mac DOES support bluetooth LE, it says right below that it doesn't support handoff.

    As long as SMS relay works come Monday, it won't be a deal breaker. I know someone mentioned about swapping out WiFi cards to an AC WiFi card, so maybe I''ll try that (they're not that expensive). Definitely not getting a new Mac over this, though.
    10-17-2014 08:16 AM
  15. SachaDC's Avatar
    Same problem here with RELEASED version of Yosemite and iOS 8.02 on my iPhone6. AirDrop allows me to drop items from the Mac (Retina mid 2012) to my iPhone, but not the other way around. Bluetooth pairing doesn't seem to work. However, when using Instashare the bluetooth icon on my mac turns into "transmitting/paired" mode, and Instashare works like a charm.

    Hopefully iOS 8.1 will fix this and we won't need third-party solutions anymore. After all this is what was promised at the Apple event on October 16th !
    10-18-2014 09:24 AM

Similar Threads

  1. why can't you do email attachments?
    By John Flud in forum iOS 8
    Replies: 5
    Last Post: 10-25-2014, 04:02 AM
  2. Replies: 9
    Last Post: 09-18-2014, 05:08 PM
  3. CNN iPhone app gets a revamped design for iOS 8
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-18-2014, 11:30 AM
  4. Replies: 0
    Last Post: 09-18-2014, 10:00 AM
  5. Spotlight aint working as expected in iOS8
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 09-18-2014, 09:20 AM
LINK TO POST COPIED TO CLIPBOARD