1. donawalt's Avatar
    HI all, longtime iPad and iPhone user, setting up and playing with my first MBP Retina 15"!

    I am trying to get some data out of a Windows networked folder - specifically, USERS\{username}\AppData. I can see the networked computer, I can access many of the folders under C:\USERS\{username}, but not AppData. That C: drive is set for share access by everyone, and I am connecting with the user domain account that has admin privileges on that computer.

    How can I see the AppData folder from my Mac?

    Thanks for your help!
    07-30-2014 03:33 PM
  2. Highrisedrifter's Avatar
    I've never tried to access Appdata from a network location before. Two things spring to mind, both of which you've probably tried.

    1) The Appdata folder is usually hidden by default. Have you enabled show hidden folders in the control panel?
    2) Is the Appdata folder included in the network share?
    07-30-2014 05:54 PM
  3. donawalt's Avatar
    I've never tried to access Appdata from a network location before. Two things spring to mind, both of which you've probably tried.

    1) The Appdata folder is usually hidden by default. Have you enabled show hidden folders in the control panel?
    2) Is the Appdata folder included in the network share?
    1) The Appdata folder is usually hidden by default. Have you enabled show hidden folders in the control panel? YEs - I can see it in Windows whenever I bring up Explorer
    2) Is the Appdata folder included in the network share? Yes - the Share is the C: drive. When I drill down I see other stuff but it is hidden.

    Do you have a Windows computer on your network you can try it with?
    Thanks for the reply!
    07-30-2014 06:14 PM
  4. Highrisedrifter's Avatar
    Yes I'm looking on my Win 7 machine now.

    Most odd, I can't see any other reason that if the C; drive is shared, and it's set to propagate all shares to sub folders as well, and you can see the Appdata folder normally, why it won't share to your Mac.

    Next thing to try:

    Did you use Advanced Share or just Share on the Windows PC? As it's a system folder, Appdata might need an Advanced Share option.

    Go to Advanced Sharing, put a tick in Share this folder when the next window pops up, click permissions at the bottom of the box, click add in the next box. Click Advanced in the next window that pops up and hit the FInd Now button on the right, scroll down to HomeGroupUser$, highlight and click OK., That will close the current window and revert back tot eh previous one where HomeGroupUser$ should be added into the 'Enter The Object Names to Select' box. Highlight it then click OK and it will take you back to the Permissions for Appdata dialogue box. Highlight HomeGroupUser$ and give it full control.

    That should do it. Let us know if it works.
    07-30-2014 06:56 PM
  5. donawalt's Avatar
    Sorry, where is Advanced Sharing (Windows 7 x64)? I see a panel under Control Panel/Network and Sharing Center if I type Advanced sharing in the Start box, if I right click on AppData folder I see "Share with" and the two possibilities are Nobody and Specific People. I don't see anything like the rest of your explanation?

    Thanks!
    07-30-2014 07:05 PM
  6. Highrisedrifter's Avatar
    Sorry, where is Advanced Sharing (Windows 7 x64)? I see a panel under Control Panel/Network and Sharing Center if I type Advanced sharing in the Start box, if I right click on AppData folder I see "Share with" and the two possibilities are Nobody and Specific People. I don't see anything like the rest of your explanation?

    Thanks!
    Navigate to the folder and right click it. Choose Properties, which should be at the bottom of the context menu that pops up upon the right click. This will open another small window. Across the top of that window are some tabs, click the sharing tab, then Advanced Sharing at the bottom, then carry on with the steps above. My apologies for not including that.
    07-30-2014 07:41 PM
  7. donawalt's Avatar
    Thanks, sorry I needed the extra help :-)

    OK, making progress - except I do not have a HomeGroup$ entry in that list. I tried typing it and Check names from theprior screen and it said it was not there. Does it matter I am on a domain (I logged in with my domain user/pw when I connected from the Mac/that account has admin privs on that computer)
    07-30-2014 07:51 PM
  8. Highrisedrifter's Avatar
    You need to be logged in as admin on the windows PC, yes.

    Sorry this is taking so long.

    This is the folder hierarchy you should be at to find it

    07-30-2014 08:06 PM
  9. donawalt's Avatar
    No apology needed I am sorry it is taking so much of your time!

    I am an admin on this computer.

    Here is my picture - no HomeGroupUser$, and I see from yours that I have no HomeUsers either. This is just on a domain.

    Seeing Windows AppData folder-1.jpg
    07-30-2014 08:15 PM
  10. Highrisedrifter's Avatar
    No worries at all. It's never easy doing this stuff over the internet, is it?

    OK, so you're not on a HomeGroup network? Don't know why, I just assumed you were. Looking at your screenie above, is the computer on a work network? It looks like it's locked down using Group Policies?

    Next thing to try. Type computer management into your start menu search bar and open up the application called, funnily enough, Computer Management.

    On the left pane, look for Local Users and Groups and expand the list. Choose Users from teh list below it and see what you get in the middle pane? Does it say HomeGroupUsers$ in that? If so, right click it, choose properties and see if there is a tick in the box marked 'Account Disabled.' If so, untick it and try the steps above again.
    07-30-2014 08:32 PM
  11. donawalt's Avatar
    No, it just has three users, I think a local account I used when the computer was set up, and then the two built in account Admin and Guest.
    07-30-2014 08:36 PM
  12. Highrisedrifter's Avatar
    Ok, so by the looks of it yo are definitely not on a homegroup then. If you were, that would be there.

    If you go to the System menu in Control Panel, what does it say under Workgroup?

    Also under Network and Sharing Center underneath the network depiction at the top should be your active networks. Under HomeGroup on the right, what does it say and under the words 'View Active Networks' it should have a name and the type of network. On mine it says Network 2 and underneath that it says Home Network.
    07-30-2014 08:48 PM
  13. donawalt's Avatar
    Yes, System Menu/Control Panel says domain, and it says Domain Network under the View Active Networks!
    07-30-2014 09:32 PM
  14. Highrisedrifter's Avatar
    Yes, System Menu/Control Panel says domain, and it says Domain Network under the View Active Networks!
    Damn, I was hoping it said something else.

    Well, it definitely looks like Group Policies have been implemented for your domain then, which complicates things further from my perspective as I obviously don't know what policies have been set.

    As you are no doubt aware, a domain is administrated from a central computer, which was my suspicion as soon as I saw your screenshot above.

    If you aren't the IT person for your domain, I would ask them to assist you in your endeavours as I don't think I can do this without having access to your domain and admin computer.

    Apologies, I was so hoping to get this fixed too.
    07-31-2014 08:40 AM
  15. donawalt's Avatar
    OK, thanks. Let me see what I can figure out. Windows computers can see AppData, they are members of the domain though. The MBP is not a member of the doman but can see the domain computers. I suspect that somehow is the issue. I'll post back if we find a solution!
    07-31-2014 08:51 AM

Similar Threads

  1. How To Add HTTP PROXY to Apple TV via Windows 7
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 07-28-2014, 01:19 PM
  2. How to delete folders from the homepage?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 07-26-2014, 08:38 PM
  3. Mac sales keep booming as Windows PC buyers stay away in droves
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 07-22-2014, 06:00 PM
  4. Replies: 1
    Last Post: 07-22-2014, 10:07 AM
  5. Replies: 1
    Last Post: 07-18-2014, 10:00 PM
LINK TO POST COPIED TO CLIPBOARD