1. Simon Abrams's Avatar
    Hey guys - I posted this issue on [redacted], but I thought I'd ask here as well. I have a 2012 MacBook Pro running El Capitan, and my function keys, and the fn key on my wireless keyboard stopped responding several weeks ago. Initially, I thought it was the keyboard, so I bought a new Magic Keyboard, but the issue persisted. I tried switching to the Guest account on my system, but the problem showed up there as well, suggesting that there's a setting or something on the system level that is causing the issue. I then tried restarting in Safe mode, and this time, the keyboard worked fine. I tried resetting the NVRAM and the SMC, but that didn't help. I'm sure there's a preferences file that I can trash that will fix everything - any suggestions? Thanks!
    Last edited by Just_Me_D; 12-24-2015 at 10:49 AM.
    12-24-2015 09:20 AM
  2. Highrisedrifter's Avatar
    Try the following and see what you get


    1. Choose System Preferences from the Apple menu.
    2. From the View menu, choose Keyboard.
    3. Click the Keyboard tab if it is not already selected
    4. Enable "Use all F1, F2, etc. keys as standard function keys."
    12-26-2015 03:43 AM
  3. Simon Abrams's Avatar
    Thanks for that suggestion - that was, of course, the first thing I tried. My problem is way beyond just toggling a setting. I think I might have to reformat/reinstall the OS at this point.
    12-29-2015 04:40 PM

Similar Threads

  1. Functions of Apple Watch?
    By iMore Question in forum Apple Watch
    Replies: 10
    Last Post: 01-14-2016, 08:43 AM
  2. Replies: 2
    Last Post: 12-26-2015, 02:22 AM
  3. Replies: 1
    Last Post: 12-24-2015, 11:53 AM
  4. Why will my backlight not turn off on my iPad6?
    By iMore Question in forum iPad
    Replies: 1
    Last Post: 12-24-2015, 07:59 AM
  5. Replies: 0
    Last Post: 12-23-2015, 11:22 PM
LINK TO POST COPIED TO CLIPBOARD