1. wscotchmer's Avatar
    Good evening.

    I updated to 10.11 on the weekend and everything seems to be working as expected however...

    I was trying to download some software and install it. The software came in the form of a pkg file. After downloading, when I double click on it a window popups up saying "validating file..." but it just sits there. The progress bar never advances and eventually I just give up and close it. I have waited as long as an hour without any advance in the validation. At first I thought it was something with this particular software but it seems to be happening with every pkg file.

    Now I did my research and the software vendors I tried all say that their product works with 10.11. Yes, I have reached out to them for comment but I would be surprised to hear a response. So what gives? Can you not install software from a pkg file in 10.11 (without disabling SIPs)?

    Any insight on this would be greatly appreciated!

    10-05-2015 09:11 PM
  2. wscotchmer's Avatar
    So just a quick update on this. I extracted the pkg file using pkgutil from a command line. Then I examined the package header which says:

    <pkg-info format-version="2" identifier="com.avira.pkg.AviraMacSecurity" version="3.0" overwrite-permissions="false" install-location="/" auth="root">

    Notice the auth="root" at the end there. That suggests to me that this installer requires "root" access which "went away" in 10.11. So even though the vendor says their product works with 10.11, it looks like it won't install unless you disable SIP. It is interesting to note though that there is nothing on their web site about this that I can see and I'm not keep on disabling SIP (even temporarily) to install software at this point.

    Still doesn't make sense why the file validation step would just "hang" indefinitely. It should at least throw an error or something...

    Again, any insights are greatly appreciated.
    10-05-2015 10:53 PM
  3. wscotchmer's Avatar
    Ok, figured this out.

    The installer DOES in fact work. I had to reboot my machine due to another "thing" I was doing and after rebooting I decided to try the installer again and this time it worked. So very odd. The validation step happened so fast it wasn't even visible on the screen.

    So... to anyone else who runs into this, try rebooting and trying again.
    10-05-2015 10:57 PM

Similar Threads

  1. MBPr won't restart after El Capitan update, just hangs
    By Gibbo_GT40 in forum OS X / macOS
    Replies: 38
    Last Post: 02-20-2017, 05:54 PM
  2. song files won't play
    By Chris Cook5 in forum iTunes
    Replies: 1
    Last Post: 10-24-2015, 12:01 PM
  3. Hanging up
    By missy8787 in forum iPhone 6 Plus
    Replies: 6
    Last Post: 10-05-2015, 04:46 AM
  4. DropBox cannot "see" all the pictures in my photo file on my iPad running iOS 9.0.2?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 10-04-2015, 04:55 PM
  5. Photos App - Identify photos without referenced files
    By ptrkllpry in forum Ask a Question
    Replies: 0
    Last Post: 10-02-2015, 08:16 PM