1. Gibbo_GT40's Avatar
    9 times out of 10, restart will hang. all application close and it looks about to restart and nothing. Finder is the only app 'running' but you can't use it or relaunch it. Finder will not relaunch. i can re-open other apps, like Safari and browse the web.

    Only thing for it is to hard power down.

    searched the web and all references to Finder not relaunching point to file permission checks, which you can't do in El Cap but i have used first Aid and that didn't do anything.

    Anybody else seen this? Any Fixes?
    10-02-2015 02:50 AM
  2. Bigeric23's Avatar
    I'm not having this issue.
    10-02-2015 06:51 AM
  3. mckillio's Avatar
    I have a similar issue but it won't get passed the Apple Logo screen, just keeps rebooting.
    10-02-2015 11:39 AM
  4. nerokerr's Avatar
    I'm having this problem on a 2012 non-retina 15" MBP. Exact same symptoms. I've been rebooting using the command line in terminal, which has been working but still seems slow. Have been searching everywhere for others having a similar problem and a fix, but this is the first I've heard of anyone else with the problem.
    10-04-2015 03:26 PM
  5. JaredSilvey's Avatar
    I'm having the exact same issue here. Mid 2014 retina mbp.
    10-05-2015 05:12 PM
  6. nerokerr's Avatar
    I've also posted in the Apple forums, but no luck yet. After some more testing, I've gotten these results...

    If I reboot, shutdown, or logoff from the Apple menu or using Ctl-Opt-Command-Eject, all programs close and the menu bar and desktop icons disappear, but the dock stays. Finder says Application not responding, and it doesn't relaunch. I can open other apps, however. I've been shutting down via command line in Terminal with "sudo reboot".

    I thought I had a breakthrough after running DiskWarrior 5 and repairing, and a successful reboot... but it was a one-off. It's back to how it was again.

    I've tried trashing my com.apple.finder.plist without luck. I've repaired via Disk Utility both in OS and Recovery, and with Disk Warrior. I've shut down all other programs and many background processes before trying to reboot. No luck.

    I made a DiskWarrior boot drive and repaired the disk. No change.

    When I boot into Safe Mode there are no problems.

    Normally my Guest account is turned off. I turned it on, logged in, and logged out without doing anything. This was successful. The next time I logged into the Guest account I opened a Finder window. After this I have the same problem everytime I log in as a Guest.

    I created a second user account. Same problems. However, I now have a User Account icon in my right corner to switcher users. If I use this to go to the Login Window, I can successfully restart and shutdown from there.

    I think it's pointing to an issue with Finder shutting down, but I'm not sure how to trace or repair it.
    10-05-2015 05:35 PM
  7. vrodriguezr's Avatar
    I had same problem, tried everything and nothing worked.

    Had to recover my system using time machine. I have a MBP 13 Early 2015
    10-05-2015 10:35 PM
  8. nerokerr's Avatar
    Did you recover to an El Capitan backup? Or pre-upgrade backup?

    I've done some more testing....

    Several SMC and PRAM/NVRAM resets to no avail.

    I used TinkerTool to reset things back to default to see if that helped anything. It has an option to relaunch Finder from within the program. Tried that, and it hung. Desktop icons gone, couldn't launch a new Finder window, right-clicking on the icon on the dock said it wasn't responding. However, I could shutdown normally from the Apple menu after doing so.

    Quitting Finder from Activity Monitor also allows normal shutdown from the Apple menu.
    10-06-2015 05:46 AM
  9. JPalhinhas's Avatar
    Any news on a fix for this?

    This was an issue already in Beta testing.

    10-07-2015 06:56 PM
  10. nerokerr's Avatar
    Looks like the Reddit thread got as far as any of the others I've posted this issue on... Exact same problem, a handful of people say they have the same, no solution... There's a more active thread on the Apple boards, but no solution to it yet. Found one on the Developers boards as well from a beta, but no reply when I posted to it. Because I'm also having an unrelated issue with not waking from hibernation, I'm about to do a clean install and migration, as this install has been upgraded from a couple versions, and even changed machines.
    10-08-2015 04:35 AM
  11. imtravis's Avatar
    I had issues with my MBPr after upgrading to El Cap, and ended up restoring from a time machine backup pre upgrade, then redid the upgrade, it seems to work fine now.

    Sent from my iPad using Tapatalk
    10-08-2015 07:09 AM
  12. nerokerr's Avatar
    When you say you had "issues", was it this same shutting down issue? Or just other things that were resolved after a restore?
    10-08-2015 09:57 AM
  13. tom_streeter's Avatar
    For what it's worth, I managed to work around this without a restore. To recap (in case I'm missing the point of this thread) I had downloaded the 10.11.1 update and all seemed normal. Until I hit 'restart.' Some windows closed, but no restart. Eventually did a hard shutdown and restart. Rinsed and repeated. Booted to the recovery volume and ran First Aid. No joy. Much cursing. Even tried booting into safe mode. Even less joy.

    Did Yet Another Hard restart and when I got to the login screen I decided to see what happened if, rather than logging in, I just hit 'restart' there. It went directly to "Installing Update" (or whatever the wording is). The install proceeded and there was much rejoicing.

    So what worked for me is not logging in, but restarting from the login screen. Since I have no idea what was actually going on I can't say this will work for anyone else, but it's worth a shot. Quicker than doing a Time Machine restore, anyway.
    10-24-2015 01:19 PM
  14. flyonearth's Avatar
    Quite similar issue on my side (MBP with 10.11.1 - install from 10.9.5 - see below why) :

    Install 10.11.1 :
    First launch after install is OK
    First shutting down is OK
    But on the following reboot, it gets stuck : it reboots automatically very 10-15 seconds... And only a hard reset can stop it !
    The safe mode is even no more possible !

    On yosemite, it was similar but different :
    On the first launch after install, it was getting stuck with black screen, with a "pizza mouse pointer" appearing every 10-15 seconds (no reboot)
    Safe mode works

    On both 10.10 and 10.11, I have tried alt ctrl P R... every possible reset - Also done a clean instal and import from time machine... Same results !

    Then from 10.10 to 10.11, I have win 1 launch...
    In the hope that a new will open infinite launch !!!!

    Any insight to help ? Big thanks !
    10-25-2015 03:19 AM
  15. cosmeticsupport's Avatar
    after downloading 10.11.1 I can't get a restart either. Only way is to hard power down and that doesn't allow the download to install HELP
    10-25-2015 06:55 PM
  16. nerokerr's Avatar
    After several attempts, my solution was a clean install of El Capitan, and migrating my user data (but not Applications!) from a Time Machine backup, and reinstalling software. Migrating the Applications resulted in the same problem, so it's somewhere in there, but waiting half a day for a 700GB migration was easier and less time consuming than trying to track down the exact software causing the problem.
    10-26-2015 07:30 AM
  17. P4G_Apps's Avatar
    Going to the login screen and restarting worked for me too. Still can't do a restart, but at least i can update to 10.11.1.
    10-27-2015 10:11 PM
  18. lespaul58's Avatar
    Hi! This worked for me. In the updates tab of the app store I was previously clicking the "restart" box directly across from the software update. Instead of clicking restart like I had been doing, this time I clicked the box in the upper right hand corner labeled "Install updates" (i think). My machine restarted immediately and installed the update. It took a while to install and then when I was prompted to login it appeared to freeze at about 60% but after 5-10 minutes it went back to what appeared to be the install screen and after another 5-10 minutes it finished installing. I was again prompted to login which I did and everything was perfect. Hope this helps.
    10-29-2015 01:58 PM
  19. SSonnentag's Avatar
    Mine is doing the same thing. I've hard reset a few times with the same results each time.
    10-31-2015 09:04 AM
  20. crashfour's Avatar
    I am having the same issue. When I try to restart or shutdown the top menu bar disappears, the application bar stays and it never shuts down. If I hold the power button down to restart and then unplug the power cable for 15 seconds and then plug it back in and start it up it will let me restart or shutdown only once and goes back to the same issue.
    11-02-2015 11:37 PM
  21. Wildoer's Avatar
    After looking for help here nothing helped me so I searched for answers myself and found a solution.
    When trying to reboot nothing happened. When right clicking the finder symbol in the dock it said Finder couldn't quit and was stuck (I'm on a Swedish OSX but you know what I mean). I didn't know how to quit (not force reboot) Finder but found a way to add a Quit option in the Finder menu. This is my first post here so I was told that I'm not allowed to post links but google "How to create a 'Quit Finder' menu item" or something like that.

    So after adding a Quit option for Finder I quit Finder and pressed Restart in App Store. This worked for me and I now have version 10.11.1 installed. Hope this helps!

    11-08-2015 09:47 AM
  22. Wildoer's Avatar
    Just noticed that when trying to restart my Mac Finder it still doesn't work and when right clicking the Finder symbol in the dock it still says program doesn't answer (in Swedish for med though). BUT the workaround above did make it possible to update!

    How do I report this bug that Finder don't quit when trying to reboot to Apple?
    11-08-2015 09:51 AM
  23. Matt Beauchamp Buck's Avatar
    Hi - I am having the same problem. i I had my SSD replaced (as i thought this was the problem) and it's still happening.

    I first got the problem on Yosemite, just the once, but it was fatal. Now it's followed me to El Capitan.

    Any solves?
    12-26-2015 04:37 PM
  24. alibjorn's Avatar
    Same here. Had it over a month. Use the terminal to shut down or start button. Very annoying!
    01-03-2016 09:17 AM
  25. geovanny raposo's Avatar
    Wildoer's solution worked for me!! I've had the same problems everyone else has in this thread:
    • Not able to shutdown, restart, or logoff
    • All programs quit, except for Finder
    • Finder shows "application not responding"
    • Only option is to force shutdown, but then you can't apply any updates

    I've been wanting to update the OS X to El Capitan 10.11.2 for months now, but my retina macbook pro (mid 2012) would not shutdown properly. So I followed Wildoer's solution.

    I did a google search for "How to create a 'Quit Finder' menu item" and followed the terminal instructions on the wikiHow site. Then I went to Finder and quit the application (you have to do this first because it didn't work for me after initiating the restart). After that, I went to the app store to install updates; everything shutdown quickly, and the loading bar for the installation showed up. I was so happy when I saw that, and the laptop restarted with no problems. The laptop updated to El Capitan 10.11.2.

    Side note: After writing the code in terminal, I did get a error message (I forgot what it said), but the quit option still appeared for me in the Finder menu.
    01-11-2016 06:18 PM
39 12

Similar Threads

  1. Split screen in El Cap?
    By Evilguppy in forum OS X / macOS
    Replies: 5
    Last Post: 10-07-2015, 06:37 AM
  2. Replies: 0
    Last Post: 10-02-2015, 02:35 AM
  3. Replies: 0
    Last Post: 10-01-2015, 06:22 PM
  4. It says I won an iPhone 6 on here?
    By iMore Question in forum iMore.com News Discussion & Contests
    Replies: 1
    Last Post: 10-01-2015, 03:38 PM
  5. Jetpack Joyride speeds to Hill Valley with new Back to the Future update
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 10-01-2015, 01:51 PM