1. Rafagon's Avatar
    I've been experiencing this since before Yosemite. I don't know why it's happening, but it's very irritating.

    Perhaps one of you has experienced this, and even better, perhaps someone knows a work-around.

    Here's an example. I've installed the "Pro Video Formats 2.0.1" update three times. And it's now asking me to install it again. What is happening with these updates? Where are they going? Are they leaving residual files behind since I have to do them multiple times?

    Longtime bug in OS X repeatedly asks me to install the same updates, what should I do?-updates.png

    Any and all help will be appreciated!

    04-24-2015 07:21 PM
  2. HankAZ's Avatar
    I am not experiencing anything like this with app updates. To the best of my knowledge, I have never seen that kind of behavior.

    Have you checked the reviews in the MAS for that app? It might be a good place to check to see if other users are experiencing the same thing. Maybe you could post/update a review in the MAS identifying the issue to see if you get anyone else chiming in with similar experiences.

    My gut reaction would be to delete the app from your Mac and then reinstall the software from the MAS. At the very least, it should install the latest version, not requiring any updates. Additionally, it may clear up whatever is causing this issue. I would suspect that there is some sort of issue with that particular app.
    04-24-2015 07:39 PM
  3. kch50428's Avatar
    Or, it could be the developer had multiple issues that needed fixes, and they really did do 4 updates under one version number...
    04-24-2015 07:47 PM
  4. bucksters's Avatar
    Having the exact same problem with the Pro Video Formats 2.0.1 update.

    System Information is registering the install's, so I'm struggling to figure out why it's repeating.
    04-25-2015 09:42 AM
  5. HankAZ's Avatar
    Having the exact same problem with the Pro Video Formats 2.0.1 update.

    System Information is registering the install's, so I'm struggling to figure out why it's repeating.
    I would strongly suggest that you and the OP both contact the developer for a clue to what's going on. It seems to be an issue with that one app.
    04-25-2015 10:14 AM
  6. bucksters's Avatar
    It's an update from Apple, here is the solution that worked from me from the Apple Discussions Forum:

    1) Move all files from /Library/QuickTime/ to a temp older on desktop
    2) Open AppStore and download/install update
    3) Reboot
    4) Copy any missing files from temp folder on desktop to /Library/QuickTime.
    Rafagon and Mark Block like this.
    04-25-2015 03:12 PM
  7. Rafagon's Avatar
    Thanks for all the help, folks. Bucksters is correct to say that it's an update from Apple. The developer is Apple. I've experienced this with multiple apps — this was just one example. Some indeed are from third parties, but very often it's an update from Apple either to OS X itself or to one of Apple's stock apps.

    Buckster, I will try your suggestion … you're saying it came from the Apple Discussion forum? That's good news then… Hopefully Apple reads those so they are made aware of this issue with OS X App Store.
    04-25-2015 05:39 PM
  8. SprSynJn's Avatar
    I am not sure this is helpful information, but maybe reindexing your hard drive might help?
    Rafagon likes this.
    04-25-2015 07:11 PM
  9. Kevin Harvell's Avatar
    Did you find that fix worked for you? I'm having the same issue and wondering what is going on.

    Also, do you happen to have Final Cut Pro installed? I thought maybe it would have something to do with it "Native import, edit, and share of MFX files with Final Cut Pro X and Motion".
    04-28-2015 03:26 PM
  10. Scatabrain's Avatar
    This worked for me.
    04-28-2015 03:40 PM
  11. Scatabrain's Avatar
    The fix above works. I do also have FCPX, Compressor and Motion.
    04-28-2015 03:41 PM
  12. Rafagon's Avatar
    Reindexing the hard drive (one of the suggestions above) didn't work. I just finished trying Buckster's suggestion, and I'll report back to let you know if that one works.

    *fingers crossed*
    04-29-2015 09:04 PM
  13. Ledsteplin's Avatar
    And welcome back to iMore, Rafagon! Visit often!

    Sent from my ancient but trustworthy iPhone 5. ☮
    04-29-2015 10:26 PM
  14. sger's Avatar
    this is a bug which exists before yosemite!
    05-23-2015 03:03 AM
  15. TheExpat's Avatar
    Wow, Glad I came across this post. I thought I was going nuts...lol I didn't notice this issue until I started upgrading OS's. I went from Snow Leopard , Lion, Mt Lion to Mavericks, to Yosemite, to El Capitan. All heck broke loose with my updates repeating and repeating. I got fed up and deleted EVERYTHING and installed Debian Linux.

    The other day I stated from a clean install of Snow Leopard on an ole 09 Mac Mini which I upgraded to Mt Lion, then Mavericks... I'm seeing the same issue again in Mavericks... Apple updates (not third party that I have noticed) are trying to install repeatedly... I have to hide them once they install so they will quit bugging my to reinstall them.. Isn't Apple QC'ing their OS's? It would appear not... Did Apple hire Microsoft folks to QC the programs... Seems more like that company everyday sad to say... lol...
    01-02-2016 07:00 AM

Similar Threads

  1. Skype app updated with apple watch support
    By Premium1 in forum Apple Watch Apps & Games
    Replies: 7
    Last Post: 04-24-2015, 09:44 PM
  2. How to set up and start you Apple watch
    By miketko in forum Apple Watch
    Replies: 1
    Last Post: 04-24-2015, 07:12 PM
  3. Replies: 2
    Last Post: 04-24-2015, 07:02 PM