1. Fausty82's Avatar
    Since upgrading to Mountain Lion, I have noticed that when I reply to an email. the email address does not always match the email address to which the message was sent.

    I have about 15 email addresses for various things... by way of example, let's identify these email addresses as:

    addr1@domain.com
    addr2@domain,com
    addr3@domain.com
    addr4@domain.com

    If I set Mail up to send mail from addr1@domain.com (Mail/Preference/Composing/Send Messages From ...), all new email that I write defaults to addr1@domain.com. I can change it, based on the need and Mail sends the message from the specified email address.

    However, if I get a message sent to addr2@domain.com, when I click REPLY, the new message screen is populated with the default address (in my case, addr1@domain.com). This is the same regardless of which email address I receive and try to reply from.

    In Lion, the replies ALWAYS defaulted to send the reply from the same address to which the original mail was send (i.e., replies to messages send to addr3@domain.com were always sent from addr3@domain.com).

    Has anybody seen this, or have a solution? It's a pain to have to remember to check/change the FROM address whenever I reply to a message, and this results in a lot of bounced messages...
    08-06-2012 12:25 PM
  2. Just_Me_D's Avatar
    I haven't noticed, but when I return home, I'll fire up my MacBook and see if I can replicate the issue and then get back to you.
    08-06-2012 12:30 PM
  3. kch50428's Avatar
    In Mail, check your Preferences>> Composing tab... in the middle, there's a drop-down to select where mail sends from - check if it's set to one address rather than 'Account of selected mailbox'
    08-06-2012 12:33 PM
  4. Fausty82's Avatar
    In Mail, check your Preferences>> Composing tab... in the middle, there's a drop-down to select where mail sends from - check if it's set to one address rather than 'Account of selected mailbox'
    Thanks, Keith... I've tried the "account of selected mailbox" setting... and it makes no difference...
    08-06-2012 12:42 PM
  5. kch50428's Avatar
    Thanks, Keith... I've tried the "account of selected mailbox" setting... and it makes no difference...
    For me Mail is behaving thusly:

    Clicking a new mail message defaults to the address of the top mailbox listed when your mailbox/folder panel is open on the Mail window and the Inbox folder is expanded showing the individual boxes... one can click & drag those so a preferred one is at the top. Edit: with the compose tab set to "selected box"
    - clicking a specific mailbox in that expanded box/folder list will result in a new mail from that specific box when hitting the 'compose new mail' button...


    When reading an email, clicking reply defaults to the reply coming from the account the message was received in.
    Last edited by kch50428; 08-06-2012 at 01:14 PM.
    08-06-2012 01:07 PM
  6. Fausty82's Avatar
    For me Mail is behaving thusly:

    When reading an email, clicking reply defaults to the reply coming from the account the message was received in.
    Thanks again, Keith... something is wrong here... with the Compose setting set to send from "account of selected mailbox", the response ALWAYS comes from the first mailbox address in the list - whether a new message or a response to any message sent to any address...
    08-06-2012 02:02 PM
  7. Fausty82's Avatar
    Ok, new clue... apparently is works as it should AS LONG AS the message is still sitting in the INBOX. However, if the message that you are replying to has been moved to a different mailbox (e.g., by a rule), the from address once again defaults to the email address associated with the first mailbox listed...

    Dang software bug.
    08-06-2012 02:08 PM
  8. kch50428's Avatar
    Dang software bug.
    Maybe it's not a bug... just one of those lovely non-documented features that accompany software updates
    08-06-2012 02:12 PM
  9. Fausty82's Avatar
    Maybe it's not a bug... just one of those lovely non-documented features that accompany software updates
    We still use that "undocumented feature" schtick in our software design reviews at work... it's not real well received there, either.
    08-06-2012 02:19 PM
  10. Just_Me_D's Avatar
    ......(snipped)...


    When reading an email, clicking reply defaults to the reply coming from the account the message was received in.
    Same here.
    08-06-2012 03:17 PM
  11. Fausty82's Avatar
    I called Apple support about this... and got escalated to a senior support tech in on the Mail product. After explaining my issue, the tech was able to recreate the issue. She is escalating it to the product engineers for investigation and resolution.

    At least I know now that I am not totally going nuts. (no comments. please).
    08-06-2012 11:51 PM
  12. Gordonhbm's Avatar
    Is there any resolution to this problem from Apple yet?
    09-25-2012 05:23 AM
  13. Maarten Hellebrekers's Avatar
    Hi,

    Is there a solution yet for this behavior? it is rather annoying....
    01-13-2013 06:20 AM
  14. Fausty82's Avatar
    Hi,

    Is there a solution yet for this behavior? it is rather annoying....
    No, not yet. There are rumors that it will be fixed in OS X 10.8.3 which is currently in beta testing with developers. Keeping my fingers crossed.
    01-13-2013 12:16 PM
  15. strawbaritulip's Avatar
    I'm having the exact same issues as you are, Keith. I cannot choose my default email account and they can not be dragged to change the order. Also, when replying the message is never sent from the address the message was sent to, unless it's the default account, which the mail app chooses. Also, my rules aren't working properly. Most times, most of the messages just go into my Inbox and I have to select them all and choose "apply rules". It's VERY frustrating!! I used to love this app.
    02-18-2013 01:15 AM
  16. Robert Hancock's Avatar
    Eleven 10.8.3 betas over a 3-month period and STILL no GM release to fix this email accounts bug. Surely it must be soon?
    02-23-2013 04:22 AM
  17. Fausty82's Avatar
    Eleven 10.8.3 betas over a 3-month period and STILL no GM release to fix this email accounts bug. Surely it must be soon?
    I emailed Craig Federighi about this a while back and got a response:

    Hi Fausty82,

    It's not too much to ask. We understand the issue and intend to address it.
    Thanks,

    - craig


    On Oct 31, 2012, at 10:47 AM, Fausty82 wrote:
    Would it be too much to ask to have one of your OS X developers fix the "REPLY TO" bug in OS X Mail (6.2, 1499)? This is causing a lot of grief for a lot of your loyal fans and customers, myself included.


    Thank you for your consideration.
    Unfortunately, he didnt say WHEN they would address it. Its moments like this that I miss Jobs.
    02-23-2013 10:13 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.