1. rich67's Avatar
    OK, as you can see by the screenshot, mac mail shows I have over 300 messages in my Gmail folder... I don't get it. I have all preferences set so that NOTHING gets stored on the server for ANY mail accounts, when I go into that account straight through the web-based GMail, I have nothing in any of my inboxes. How the HECK do I get this stuff to go away or delete these messages where they are stored? I have looked everywhere and I am at a total loss.
    03-26-2012 11:33 AM
  2. Ipheuria's Avatar
    It's been awhile did you figure this out?
    04-14-2012 09:08 PM
  3. rich67's Avatar
    I realized that when I deleted mail on my phone, they were being sent to the important or archive folders on my gmail. This was the count that I kept seeing. So, I tweaked gmails settings and THOUGHT I fixed the issue, but it started up again. It appears I have to go into my gmail regularly to delete the messages in order for this to clear out. I wish there was an easier solution though...
    04-14-2012 09:13 PM
  4. cobra302's Avatar
    I just got my macbook and was wondering the same thing. Are you using your gmail on your iphone as exchange? If you are, when you delete mail it will not truly delete, it archives them. There is no way around this other than to set up your gmail as an imap account on the phone and then lose push. BUT this will allow you to truly delete email. I have created a folder on my exchange called iphone trash. When I delete, I move the email to the trash folder, then I have to go online and delete the contents of the folder thru the gmail website. This is a major pain and because of that I was just deleting. I have over 1600 emails showing in one of my accounts on mac mail. sad.
    05-18-2012 02:12 AM
LINK TO POST COPIED TO CLIPBOARD