1. Fausty82's Avatar
    Just a note to warn you that if you are running the iOS 5 beta and have installed the iTunes 10.5 beta software, you will need to reinstall it after upgrading your Mac to OS X Lion. The iTunes library from 10.5 won't work with 10.3 (the current GA release of iTunes)
    07-20-2011 09:47 PM
  2. phreddyl's Avatar
    What if you installed the beta iTunes but chickened out and didnt install os 5 on your iPhone. Do I still need to reinstall iTunes?
    07-20-2011 10:15 PM
  3. Alli's Avatar
    You only need the iTunes beta if you have the iOS beta.
    07-20-2011 10:15 PM
  4. phreddyl's Avatar
    Ok cool thanks. Completely chickened out with the beta. Didnt want to deal with all the instability issues. Will update downgrade my iTunes back to what is out now? It's installing. Still have 15 min to go.
    07-20-2011 10:22 PM
  5. Fausty82's Avatar
    If you have already gone to 10.5 beta and have converted your iTunes library, you may be stuck. The beta has to update your library to read the stuff... but you get the error message that the iTunes library was created by a newer version of iTunes... to fall back, you must have a backup of your iTunes library or start over... or just go with the beta iTunes... You NEED it for iOS 5 beta, but you can run it without.
    07-20-2011 10:40 PM
  6. phreddyl's Avatar
    Well it is installing 10.4 now. I guess I'll see what happens. All my music is on computer anyway. Am I better off not opening and getting the iTunes 10.5 beta again?
    07-20-2011 10:52 PM
  7. phreddyl's Avatar
    Seems to be ok. All my songs are there. Anything else I should be concerned with?
    07-20-2011 11:00 PM
  8. Fausty82's Avatar
    Seems to be ok. All my songs are there. Anything else I should be concerned with?
    I can't think of a reason... if your stuff is there, you ought to be good to go...
    07-20-2011 11:12 PM
  9. phreddyl's Avatar
    I can't think of a reason... if your stuff is there, you ought to be good to go...
    Thanks. Looks like a few of my songs in the library were duplicated. Not many. Just a few. Deleted the dupes.
    07-20-2011 11:14 PM
  10. Ipheuria's Avatar
    Actually all you have to do is run software update it will find the iTunes 10.4 update for lion and install it over the 10.5 keeping the library and all settings intact. Then after that install install 10.5 back over 10.4 and you're ready to rock. I had this problem and my library is extensive so was happy that it didn't change a thing.
    07-22-2011 08:29 AM
  11. phreddyl's Avatar
    Actually all you have to do is run software update it will find the iTunes 10.4 update for lion and install it over the 10.5 keeping the library and all settings intact. Then after that install install 10.5 back over 10.4 and you're ready to rock. I had this problem and my library is extensive so was happy that it didn't change a thing.
    Yeah I installed the 10.4. I don't have 10.5 anymore. Borrowed flash drive from someone but the 10.4 seems to be working ok.
    07-22-2011 12:48 PM
  12. Garz's Avatar
    I got stuck with right after install but asked on twitter. My twitter buds came through with a answer.
    07-22-2011 12:51 PM
  13. dcgore's Avatar
    I like 10.4 but do have to install .5
    07-22-2011 01:19 PM
LINK TO POST COPIED TO CLIPBOARD