1. iphone5s's Avatar
    So every once and a while I send iMessages to myself from my MacBook Pro to my iPhone. It helps me with distribution of information when I'm in the field. When starting a new message from my MacBook my iPhone number was always available to select right up until I updated to el Capitan. Now I can't see it and my messages are sent from my iCloud account email address by default.

    1.) On both the phone and the MacBook I have *start new messages* from my cell number. and I have had my alternate *send from* iCloud email deselected and deselected to see if the problem lies there.
    2.) I have my contact information properly entered in the address book.
    3.) In iMessage prefs I have both Google and iCloud accounts selected. Both have been alternately stopped and restarted to see if the issue is there.

    I'm stumped, any ideas?
    Last edited by iphone5s; 11-02-2015 at 07:02 AM.
    11-02-2015 06:19 AM
  2. Rob Phillips's Avatar
    Welcome to iMore! I just tried sending a message to myself and had no issue. It came to and from my cell number. When you message other people from your MacBook do the messages send from your cell number? If not, it may be an issue with Continuity (here's how to fix it).
    Other solutions are to use Notes or email yourself instead of using iMessage.
    11-02-2015 07:02 AM
  3. iphone5s's Avatar
    Welcome to iMore! I just tried sending a message to myself and had no issue. It came to and from my cell number. When you message other people from your MacBook do the messages send from your cell number? If not, it may be an issue with Continuity (here's how to fix it).

    Other solutions are to use Notes or email yourself instead of using iMessage.
    Yes they did before this *issue*. Now all my iMessages sent from the MacBook show as sent from my iCloud email account and not the cell number.

    I tried the continuity fix without luck.

    Thanks for the suggestions though. Notes continue to sync fine so I can use that.

    This is more of an inconvenience than an issue I suppose, it's just driving my curiosity and I want to know what has changed in my setup since the update to el Capitan.
    11-02-2015 07:28 AM
  4. Rob Phillips's Avatar
    Yes they did before this *issue*. Now all my iMessages sent from the MacBook show as sent from my iCloud email account and not the cell number.

    I tried the continuity fix without luck.

    Thanks for the suggestions though. Notes continue to sync fine so I can use that.

    This is more of an inconvenience than an issue I suppose, it's just driving my curiosity and I want to know what has changed in my setup since the update to el Capitan.
    I feel your pain! I'm so used to my stuff just working that the smallest things drive me crazy. At least you have a workaround. Maybe someone else will have a solution.
    11-02-2015 08:32 AM
  5. iphone5s's Avatar
    FWIW

    I tried the continuity suggestion on the phone again, and this time when i opened iMessage on the MacBook and created a new message my number showed up for about 4 seconds, and before I could select it as the contact it was gone. That is weird.

    I'm not sure if it makes a difference but thinking about it now I upgraded to el Capitan on or around the same day I upgraded to an IP6s plus.
    11-02-2015 01:17 PM
  6. Rob Phillips's Avatar
    FWIW

    I tried the continuity suggestion on the phone again, and this time when i opened iMessage on the MacBook and created a new message my number showed up for about 4 seconds, and before I could select it as the contact it was gone. That is weird.

    I'm not sure if it makes a difference but thinking about it now I upgraded to el Capitan on or around the same day I upgraded to an IP6s plus.
    I'm not sure if that has anything to do with it or not, but computers sometimes have minds of their own. I have a 6s Plus and I'm running El Capitan on my MacBook Pro with no issues using continuity or iMessage. If the issues persist you could always run restores on one of both devices. It's a lot of work but it's amazing how often that fixes problems.
    11-02-2015 01:36 PM
  7. robertk328's Avatar
    I'm not at home to check the settings but I know there used to be a screen in Settings that let you assign your number to iMessage.

    I did find this help document, hope it makes a difference:

    https://support.apple.com/en-us/HT201349
    11-02-2015 02:08 PM
  8. Rob Phillips's Avatar
    I'm not at home to check the settings but I know there used to be a screen in Settings that let you assign your number to iMessage.

    I did find this help document, hope it makes a difference:

    https://support.apple.com/en-us/HT201349
    From my experience the phone number just shows up in Messages on Mac OS X as long as you're using the same Apple ID as you are in Messages on your iPhone. I don't think I ever had to take any additional steps aside from checking it in settings.
    11-02-2015 04:20 PM
  9. robertk328's Avatar
    Here's what I found to make it work for me.

    On my phone, Settings -> Messages

    Trouble with iMessage, I think.-imessage.png

    Click "Use your Apple ID for iMessage" and fill out any info requested. Then, on my computer I got this. "Do you want to add <your phone number> to iMessage and Facetime".

    Trouble with iMessage, I think.-el_capitan_popup.png

    Select Yes, then fire up Messages and go to Preferences for the following:

    Trouble with iMessage, I think.-el_capitan2.png

    Before doing that my phone number wasn't there, but now it is and I can send from it with no problem.
    11-03-2015 08:13 PM
  10. iphone5s's Avatar
    Thanks robertk328. I've tried all the solutions offered up here, a few times. Still no luck. The [my] cell number shows up now but just for a few seconds then disappears and can't be selected.
    I'll keep at it and report back if I get it resolved.
    11-04-2015 12:17 PM
  11. robertk328's Avatar
    Thanks robertk328. I've tried all the solutions offered up here, a few times. Still no luck. The [my] cell number shows up now but just for a few seconds then disappears and can't be selected.
    I'll keep at it and report back if I get it resolved.
    Maybe try logging out on both devices in iMessage? Then log back in on your phone and then Mac. If still the same, reverse the order?
    11-04-2015 02:01 PM
  12. iphone5s's Avatar
    Well, I fixed it the hard way. I rolled back to Yosemite. Problem solved. The roll back also resolved quite a few other "issues" I had been experiencing with wifi, USB, and sudden shutdown and restarts. Back in business!
    Thanks for everyone's help.
    11-05-2015 02:09 PM
  13. robertk328's Avatar
    Wow that is the hard way but if it works that's what matters. Glad we were able to help even if it was to push you in the opposite direction!
    11-05-2015 06:42 PM

Similar Threads

  1. Replies: 6
    Last Post: 09-15-2016, 07:36 PM
  2. IOS 9.1 - No notification sounds with bluetooth on, why?
    By iMore Question in forum iPhone 6s Plus
    Replies: 8
    Last Post: 11-03-2015, 02:34 PM
  3. Issue with Ford Sync
    By LCW in forum Apple Watch
    Replies: 3
    Last Post: 11-02-2015, 01:03 PM
  4. Why am I not able to send pics on iMessages?
    By iMore Question in forum iMessage
    Replies: 1
    Last Post: 11-02-2015, 05:42 AM
  5. Replies: 1
    Last Post: 11-01-2015, 10:05 PM
LINK TO POST COPIED TO CLIPBOARD