1. MECM's Avatar
    My iPad is about 2 years old. It's never been dropped or anything. I went to go and plug it into my computer today, and it won't connect. Nothing happens. I tried 2 USB cables, same result. I tried plugging it into the wall and it won't charge. I have 60% battery. I uninstalled and reinstalled iTunes. Nothing is working! It's in recovery mode, but iTunes won't recognize it.

    Does anyone know anything else I can try??


    Sent from my iPhone using Tapatalk
    02-24-2013 07:34 PM
  2. Alli's Avatar
    Is there another computer you can try plugging it into?
    02-24-2013 09:48 PM
  3. MECM's Avatar
    I tried different computers, usbs, plugs, etc. my bf's iPad was responding fine to all, so I brought it to apple. They swapped it out for a new refurbished one. Thanks for responding, though!

    Sent from my iPhone using Tapatalk
    02-28-2013 09:35 AM
  4. DikaiaKnight's Avatar
    This happened recently to my mother's original iPad. It charges but extremely slowly but the battery never changes to the charging symbol and it nothing happens when plugged in to the computer. She had said the Apple Store told her it's an issue with the connector and that they could not do anything for her since warranty was over. I am going to try my Apple Store because they tend to be more helpful than hers. Sounds like you have a similar issue.
    05-10-2013 10:52 PM

Similar Threads

  1. NSFetchedResultsController not responding to data updates properly
    By danbretl in forum The Developer's Lounge
    Replies: 1
    Last Post: 05-12-2012, 02:10 AM
  2. iPad not connecting to Verizon LTE
    By Got the Shakes in forum iPad 3
    Replies: 2
    Last Post: 03-21-2012, 12:16 AM
  3. iTunes "Not Responding" when usb iPhone
    By Diff in forum iTunes
    Replies: 3
    Last Post: 02-08-2010, 01:09 PM
  4. Funny Video: Hitler responds to the iPad Tablet
    By markviduk in forum Original iPad
    Replies: 2
    Last Post: 01-30-2010, 11:35 AM
  5. Replies: 3
    Last Post: 02-19-2009, 01:37 PM