1. CharlieBall's Avatar
    I got a 64 gig Wifi only version on release date. I love the iPad.

    But I try to watch youtube videos on it, but everything takes forever to load, I even go to my university's wifi to try to watch videos, despite the fact that the internet over there is amazing, videos still take forever to load.

    Is it because the youtube app automatically tries to steam at 720p or what?

    Any answers to this problem?
    05-03-2010 01:42 AM
  2. VLennert's Avatar
    It works fine on mine. Every thing loads instantly.

    The picture leaves alot to be desired when you make it full screen, though.

    I'm not sure whats causing your issues, just wanted you to know it doesn't effect everyone. Perhaps go into the Genius Bar and have them take a look at it?
    05-03-2010 09:51 AM
  3. CharlieBall's Avatar
    well the thing is, the lower quality videos load up instantly, but I notice the widescreen videos are always the slow loading videos.
    05-03-2010 10:45 AM
  4. ipadbuzzblog's Avatar
    seems to be common, hopefully just a temporary glitch
    05-03-2010 01:57 PM
  5. Mustang5Oh's Avatar
    When I go to YouTube on my WiFi iPad it is also slow as all hell. Netflix and ABC can stream Movies and TV Shows without a pause but YouTube for whatever reason is so slow for me.
    05-03-2010 02:49 PM
  6. Alexamo's Avatar
    Hello guys,
    I am french, living In France and I am having The same troubles. Videos starts then stops. On my ipad but also on my iPhone 3GS with the wifi. With 3G, it works but the video's quality is not the same. I am thinking (and hoping) that it could come from YouTube servers. As you are, I am ont having trouble watching vidos on apple's web page or french vido site.

    Hope somebody Will find an answer...
    05-03-2010 05:40 PM
  7. CharlieBall's Avatar
    Yea like someone said before, Youtube App is hella slow, but ABC app and the netflix one work fine.

    whats up with that?
    05-03-2010 07:26 PM
  8. Alexamo's Avatar
    A few minutes ago, I tried YouTube with my neighbour's provider and it worked perfectly... So I beleive that all my problems come from my provider's router...
    05-03-2010 07:37 PM
  9. west3man's Avatar
    Wow. My YouTube isn't particularly slow, but it sure LOOKS like hell. Not sure why.

    That's both, through the app and through the browser.
    05-03-2010 08:24 PM
  10. west3man's Avatar
    Odd. It got much better, this last time or two. Oh well.
    05-03-2010 08:30 PM
  11. Mustang5Oh's Avatar
    I called AT&T (my Internet provider) and asked about my Internet speed and they had me on the slowest speed when I asked for the fastest available. They fixed the problem and I tried YouTube and it loads fast now. Hopefully it continues to do the same only time will tell.
    05-03-2010 11:01 PM
  12. Alexamo's Avatar
    At home, I have optimal fibre and n wifi. 8+ mbps on my iPad.... But it freeze! And it works fine with my old unbundled ADSL that I still have for a few days...
    I beleive it is a question of router but as Brian says it could also be a question of speed...
    I also hope that Apple will come with an update!
    05-04-2010 06:31 AM
  13. Alexamo's Avatar
    Hi guys,
    I may have found a solution. I changed my provider DNS by statics DNS from opendns.com
    Don't need to pay. Just register for a free account. I am not even sure you need an account...
    Here are the DNS : 208.67.222.222 and 208.67.220.220

    Tell me if it works for you!
    Jakkalope likes this.
    05-04-2010 06:48 PM
  14. steven_butler1986's Avatar
    You'd figure a native app would be optimized. Guess not
    05-15-2010 05:53 PM
  15. Alexamo's Avatar
    I found an interesting article on TUAW. About how to manage dns settings-for-faster-web-browsing
    I can't give you the link cause I haven't posted enough...
    It could help!
    05-16-2010 04:03 PM
  16. Jeremy's Avatar
    When I go to YouTube on my WiFi iPad it is also slow as all hell. Netflix and ABC can stream Movies and TV Shows without a pause but YouTube for whatever reason is so slow for me.
    I just started seeing the same behavior. Makes zero sense to me. Really aggravating.
    06-01-2010 01:37 AM
  17. BriDroid's Avatar
    Could the sporadic downloading speeds be YouTube-specific?
    06-01-2010 01:24 PM
  18. Jeremy's Avatar
    Could the sporadic downloading speeds be YouTube-specific?
    I don't think so. I don't think it has anything to do with download speed honestly. If I can stream 720p videos on my MacBook using the same wifi connection it has to be an iPad specific issue. At least I would think?
    06-01-2010 04:06 PM
  19. jjbusa's Avatar
    I have the same issue with different wifis
    06-12-2010 10:28 AM
  20. MontanaVista's Avatar
    The more I use my iPad and youtube on it, I find it is very slow... Not sure what the problem is, but my blackberry loads videos faster than my iPad. And unfortunately I'm not exaggerating.
    06-14-2010 08:36 PM
  21. west3man's Avatar
    The more I use my iPad and youtube on it, I find it is very slow... Not sure what the problem is, but my blackberry loads videos faster than my iPad. And unfortunately I'm not exaggerating.
    Is this only via 3G?
    Last edited by west3man; 06-15-2010 at 12:26 PM.
    06-14-2010 09:23 PM
  22. MontanaVista's Avatar
    I'd this only via 3G?
    I'm sorry, I didnt specify - my iPad is WiFi only.

    I've tried resetting the router and stuff, no results. Oh well.
    06-15-2010 12:24 PM
  23. Big Dookie's Avatar
    Not that it's much help, but I just wanted to chime in to say that I've been having this same issue. I've especially noticed it while loading in-line youtube videos through Safari, but I've seen it on the app as well. Really frustrating, there's no reason these videos should be loading so slowly.
    06-18-2010 12:28 PM
  24. west3man's Avatar
    Not directly related but...

    I have noticed that my 3G connection seems slower, these days. I can't help wondering if AT&T is doing a bit of throttling - particularly to those of us who are grandfathered into the unlimited plan.
    06-18-2010 03:59 PM
  25. fresh1's Avatar
    Not that it's much help, but I just wanted to chime in to say that I've been having this same issue. I've especially noticed it while loading in-line youtube videos through Safari, but I've seen it on the app as well. Really frustrating, there's no reason these videos should be loading so slowly.
    Same thing here ..
    06-18-2010 04:02 PM
30 12
LINK TO POST COPIED TO CLIPBOARD