1. Chris Cook5's Avatar
    How would you go about getting your iMessages re-synced up with your Mac. I’ve tried signing in and out of iCloud on my Mac but doesn’t work
    04-25-2018 03:31 PM
  2. doogald's Avatar
    How would you go about getting your iMessages re-synced up with your Mac. I’ve tried signing in and out of iCloud on my Mac but doesn’t work
    Apple is supposed to be adding iMessage sync in iCloud at some point with iOS 11.x and High Sierra, but, as of now, it's not available in the stable (non-beta) versions.
    04-25-2018 03:48 PM
  3. Chris Cook5's Avatar
    So there’s no way to reactivate my messages on my Mac as of right now?
    04-25-2018 03:56 PM
  4. Chris Cook5's Avatar
    Sorry if I wasn’t clear, I didn’t have text messaging forwarded. That’s the only thing I don’t like when updating to the newest iOS is it doesn’t leave Some of your settings like they were
    04-25-2018 04:02 PM
  5. doogald's Avatar
    So there’s no way to reactivate my messages on my Mac as of right now?
    Yes, you can. But it will not sync messages down that you've received on other devices. It will have any history you had before you signed back in with your Apple ID, plus any new iMessages that you receive after that point. And, yes, you can activate text messaging forwarding from your iPhone if you want text messages (green bubbles) to be received and sent from the Mac, in addition to iMessages (blue bubbles.) On the iPhone, Settings / Messages / Text Message Forwarding, after you have signed in to iCloud in Messages on the Mac.

    But, like I said, this will not load messages from you've received on your iPhone to the Mac. That will come with iMessage sync when Apple adds that service to iCloud.
    04-25-2018 04:21 PM
  6. Chris Cook5's Avatar
    Now I understand. I turned on the text messaging forwarding and tested it out but it still didn’t work. Do I have to wait a few minutes for it to recognize my Mac
    04-25-2018 04:24 PM
  7. doogald's Avatar
    To be honest, I turned off iMessage on my Mac because I wasn't getting notified of messages on my iPhone when they were received if my Mac was turned on (which is not what I wanted). I can't recall how long it took for text messaging forwarding to become active, though I honestly don't send or receive very many of those. Most of my messages these days are iMessages.
    04-25-2018 04:35 PM
  8. msm0511's Avatar
    Now I understand. I turned on the text messaging forwarding and tested it out but it still didn’t work. Do I have to wait a few minutes for it to recognize my Mac
    When you click on the Messages app on your Mac to open it what happens? One of the more recent updates signed me out so I just had to resign in.
    04-27-2018 08:13 AM
  9. Hendri Hendri's Avatar
    I tried to delete some text messages from my mac imessages, but the text messages on my iphone didn't deleted (I've waited for 2 days, still no change). But when I tried to delete from my iphone, it only took 2 seconds for my text messages on mac to disappear

    anyone know what's the problem is ?

    thx
    07-02-2018 05:02 PM
  10. metllicamilitia's Avatar
    I tried to delete some text messages from my mac imessages, but the text messages on my iphone didn't deleted (I've waited for 2 days, still no change). But when I tried to delete from my iphone, it only took 2 seconds for my text messages on mac to disappear

    anyone know what's the problem is ?

    thx
    Open Messages on your Mac, in the top left corner click on Messages and select Preferences. From there select iMessage and be sure Enable Messages in iCloud is selected. Once you do that, hit sync now.
    07-02-2018 07:56 PM
  11. Hendri Hendri's Avatar
    Open Messages on your Mac, in the top left corner click on Messages and select Preferences. From there select iMessage and be sure Enable Messages in iCloud is selected. Once you do that, hit sync now.
    I’d already did that from the first time I activated icloud messages (otherwise messages deleted from my iphone won’t deleted on my mac right ?)

    And another thing is, I tried to send text messages from my friends number to my phone, and my mac also didn’t received

    It’s strange, I suspect this has something to do with the sync on my mac, but don’t know how to fix it
    07-02-2018 08:44 PM
  12. Lee_Bo's Avatar
    I’d already did that from the first time I activated icloud messages (otherwise messages deleted from my iphone won’t deleted on my mac right ?)

    And another thing is, I tried to send text messages from my friends number to my phone, and my mac also didn’t received

    It’s strange, I suspect this has something to do with the sync on my mac, but don’t know how to fix it
    Go back into Messages settings on your Mac, then preferences, then the Accounts tab. Make sure all the boxes are selected that you want to be reached at under "You can be reached for messages at:".

    I wasn't getting all iMessages on my MBP then realized I only had one of mt emails selected.
    07-03-2018 07:31 AM
  13. Hendri Hendri's Avatar
    Go back into Messages settings on your Mac, then preferences, then the Accounts tab. Make sure all the boxes are selected that you want to be reached at under "You can be reached for messages at:".

    I wasn't getting all iMessages on my MBP then realized I only had one of mt emails selected.
    I’ve done all that selection previously

    One thing I noticed was when I delete my message from iphone, there’re notification stated that it will delete at all my devices as well.

    But there’re no such notification from my mac when deleting messages. Do you have that notification on your mac messages when deleting ?

    To be clear :

    1. My iphone do not use text mesages forwarding to my mac, but with icloud messages feature, I will received the messages on my mac as well right ?
    2. My mac messages seems like don’t sycn (because when I delete my messages from mac, messages on my iphone not deleted as well
    07-03-2018 09:09 PM
  14. doogald's Avatar
    It might be because they are text messages that were sent to the Mac via Settings / Messages / Text Message Forwarding rather than syncing via iCloud. But, this is a great question to ask AppleCare or the Genius Bar to see what they say about it. I don't think that any of us will be able to find the answer.
    07-03-2018 10:01 PM
  15. Hendri Hendri's Avatar
    It might be because they are text messages that were sent to the Mac via Settings / Messages / Text Message Forwarding rather than syncing via iCloud. But, this is a great question to ask AppleCare or the Genius Bar to see what they say about it. I don't think that any of us will be able to find the answer.
    But I thought icloud messages feature included text messages .. hm ...
    07-04-2018 03:21 AM
  16. doogald's Avatar
    But I thought icloud messages feature included text messages .. hm ...
    This is why I think you should call or visit Apple to clarify. From https://support.apple.com/en-us/HT208532 I see this partial quote:

    Messages in iCloud are updated automatically, so you always have the same view everywhere you use iMessage. When you delete a message, photo, or conversation on one device, it’s removed from all of your devices. And since all of your attachments are stored in iCloud, you can save space on your device.
    Notice what I highlighted. It’s a little ambiguous about whether text messages are supported, as that says “iMessage”. Maybe sms messages are supported for copying from iPhone, but because the Mac didn’t *receive* the text message, the deletion from there doesn’t sync. Or maybe it’s a bug. Either way, it’d be interesting to see what Apple says officially if you make a call or visit the Genius Bar about this.
    07-04-2018 05:01 AM
  17. Hendri Hendri's Avatar
    This is why I think you should call or visit Apple to clarify. From https://support.apple.com/en-us/HT208532 I see this partial quote:



    Notice what I highlighted. It’s a little ambiguous about whether text messages are supported, as that says “iMessage”. Maybe sms messages are supported for copying from iPhone, but because the Mac didn’t *receive* the text message, the deletion from there doesn’t sync. Or maybe it’s a bug. Either way, it’d be interesting to see what Apple says officially if you make a call or visit the Genius Bar about this.

    Yup. I've contacted applecare, and the problem solved. And yes, icloud messages included for text messages. So the solution is to uncheck "save history when conversation are closed" on our mac OS (messages - preferences - general), then it will work flawlessly

    thx for your input
    07-04-2018 06:39 AM
  18. doogald's Avatar
    Excellent, thanks for the follow up, too. I’m away from my Mac for a few weeks but will check that setting myself when I get back home.
    07-04-2018 02:13 PM
  19. doogald's Avatar
    Yup. I've contacted applecare, and the problem solved. And yes, icloud messages included for text messages. So the solution is to uncheck "save history when conversation are closed" on our mac OS (messages - preferences - general), then it will work flawlessly
    Excellent, thanks for the follow up, too. I’m away from my Mac for a few weeks but will check that setting myself when I get back home.
    It was unchecked, which it must be by default (I recently installed MacOS from scratch without restoring from a backup). So that's one reason I wasn't seeing the same issue you were.
    07-16-2018 10:57 AM

Similar Threads

  1. Comic: Dear Apple, True Charity Would Be Making iMessage For Android
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 04-24-2018, 08:10 AM
  2. How to fix iMessage and FaceTime activation issues on macOS
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 04-16-2018, 08:10 AM
  3. Replies: 24
    Last Post: 04-08-2018, 07:20 AM
  4. Replies: 3
    Last Post: 04-05-2018, 01:06 PM
  5. iMessage Delete Extra Step
    By Al Paca in forum iOS 11
    Replies: 7
    Last Post: 04-01-2018, 11:52 AM
LINK TO POST COPIED TO CLIPBOARD