1. Remik Szul's Avatar
    Hi Guys,

    Looking for a little help. I have a MacBook Pro 13" Early 2011. It's the 2.7 I7 and originally had 4GB of ram.
    I bought a 8GB Corsair kit (1333mhz) with apple branding on box, and upgraded the ram myself.

    Right away I started getting intermediate graphics glitches when using both the laptop and 27" cinema display at the same time. It's like a quick screen scramble for a brief second and than it goes back to normal. I assumed I got a bad ram kit, and returned it to the store and got a Patriot 8gb kit. Same problem.

    It only happens when I use both Cinema & Laptop at the same time. If I close the laptop the cinema display stops glitching.
    No glitches if I just use the laptop solo.
    It happens more often or more frequently when under heavy load (using flash etc).

    If I put the 4GB stock kit in, problem solved but laptop is very slow compared to 8gb kit.

    Fresh format of Yosemite 10.10.3 - No changes.

    Any suggestions? Bad Graphics Card? 2 Bad kits of Ram? Something else.

    Thanks IMORE.
    06-27-2015 01:24 PM
  2. Just_Me_D's Avatar
    Can you adjust the refresh rate of the Cinema Display?
    06-27-2015 01:28 PM
  3. Remik Szul's Avatar
    No, it doesn't let me change anything in display settings.
    06-27-2015 01:37 PM

Similar Threads

  1. Replies: 4
    Last Post: 06-28-2015, 04:37 PM
  2. Why am I unable to update my favorite app?
    By iMore Question in forum Ask a Question
    Replies: 4
    Last Post: 06-28-2015, 08:21 AM
  3. Apple ID incorrect after restoring from DFU
    By chiratsu in forum iPhone 6
    Replies: 1
    Last Post: 06-27-2015, 01:07 AM
  4. Replies: 2
    Last Post: 06-26-2015, 03:48 PM
  5. Why don't I have any apps after the Jailbreak?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 06-26-2015, 03:14 PM
LINK TO POST COPIED TO CLIPBOARD