1. smhism's Avatar
    I have an early 2011 MBPro 13". The battery died while I was at work, so when I got home I plugged it in, waited for the login screen to come up so I could do my usual facebook and browse before bed. Well, it came up fine, but as it was waking from its deep slumber, something happened, and the display became degraded and now there's a lovely green tint to everything. From what I found online in other venues, it's likely the gpu and logic board needs replacing. however, airplay mirroring via apple tv works perfectly. Anyone with any insight into this before I drive two hours to the nearest certified Mac dealer/repair? I've reinstalled Mavericks just in case and no change. I've also installed gfxstatus, an app that allows to differentiate which graphics processor is being used (integrated or discrete) and that changes nothing as well.
    01-23-2014 03:43 AM
  2. kch50428's Avatar
    I think you found the answer already in your investigation....
    01-23-2014 08:07 AM
  3. smhism's Avatar
    Yeah, I was hoping for any other possibilities. It seems odd to me that a corrupted gpu wouldn't be able to display a 13" display correctly, but would display perfectly on a 26" tv... and if i have to replace the logic board, it might be worth it to go ahead and upgrade to a new mbp. there goes my tax refund....
    01-24-2014 09:01 AM
  4. Peter Cohen's Avatar
    IIRC, AirPlay uses technology on the Intel chip rather than the GPU in order to work. Assuming that's the case, it isn't entirely surprising you'd be able to AirPlay video mirror without issue while a local screen would look wonky.
    01-24-2014 05:19 PM
  5. smhism's Avatar
    Thanks, Peter! That actually makes sense (though I believe I read somewhere the reason older macbook/pros wouldn't work w/ airplay was due to their gpu not being up to par). I'll just have to take it in to the repair shop next chance I get, which will be in over a month...
    01-27-2014 07:01 PM
  6. smhism's Avatar
    So a little update. I admitted defeat with trying to figure out what was going on with my MB Pro, and hadn't any plans to travel the hour and a half+ to take it to a repair place. So it sat on the floor beside my bed for about a month (I shared my bf's during the meantime, or used my Mini). Anyway, I started vacation, went to watch something on the apple tv, and figured instead of getting the mini out of the living room, I'd just fire up the Pro since airplay still worked. The battery was dead, of course, so I plugged in the charger, waited about a minute, and it came right on. AND IT WORKS! No more green tint to the screen. Images are just as clear as when I purchased it. I have no idea what was wrong with it, or why it's now working without issues, but it is!
    04-01-2014 03:14 PM
  7. rohitstrategy's Avatar
    Dont worry its only ur LVDS cable which is need to be replaced it will cost u only like 15-20$
    I had the same problem ........
    09-10-2014 07:31 AM
  8. tedgen87's Avatar
    So a little update. I admitted defeat with trying to figure out what was going on with my MB Pro, and hadn't any plans to travel the hour and a half+ to take it to a repair place. So it sat on the floor beside my bed for about a month (I shared my bf's during the meantime, or used my Mini). Anyway, I started vacation, went to watch something on the apple tv, and figured instead of getting the mini out of the living room, I'd just fire up the Pro since airplay still worked. The battery was dead, of course, so I plugged in the charger, waited about a minute, and it came right on. AND IT WORKS! No more green tint to the screen. Images are just as clear as when I purchased it. I have no idea what was wrong with it, or why it's now working without issues, but it is!
    11-11-2016 12:16 PM
  9. tedgen87's Avatar
    Hello.. I know it's been a long while since you posted this, but did the green screen ever come back.?.. sounds like I have the same issue with my early 2011 Mbp.. it had a green tint to everything for a bout a few weeks.. then one day I recharged the battery and booted it up and it was perfect and has been for about a week or so.. any advice or insight would b greatly appreciated. Thank you
    11-11-2016 12:20 PM
  10. louisemcnulty8's Avatar
    Hi,
    I was wondering do you still have any issues with yours? I got a green tint on my MacBook pro a couple of days ago after a while of being on it goes but it has come back. If you do have you brought it in for repair?

    Thanks
    01-10-2017 12:50 PM

Similar Threads

  1. 4.8" screen for the next iPhone?? *rumor*
    By Premium1 in forum iPhone 6
    Replies: 59
    Last Post: 03-24-2014, 08:12 PM
  2. Replies: 7
    Last Post: 01-25-2014, 12:34 AM
  3. Replies: 1
    Last Post: 01-23-2014, 10:17 AM
  4. How do I turn off google talk on (Chat/IM) on my 4S
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-23-2014, 08:37 AM
  5. MacBreak Weekly 386: The Path to Madness
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-22-2014, 10:10 PM
LINK TO POST COPIED TO CLIPBOARD