1. Speedygi's Avatar


    After about two years use it has started to show some considerable lag, and just using Chrome and nothing else it runs terribly slowly.

    This happened after installing Mavericks a few weeks ago, which could be or not be the problem.

    Anyone willing to give some thoughts on the issue?

    Sent from my GT-I9505 using Tapatalk
    01-12-2014 05:30 PM
  2. warcraftWidow's Avatar
    Chrome seems to have slowed down recently. Try Safari or Firefox.
    01-12-2014 05:42 PM
  3. Speedygi's Avatar
    Okay

    Sent from my GT-I9505 using Tapatalk
    01-12-2014 06:10 PM
  4. Speedygi's Avatar
    I will give it a try and see how it goes..

    Sent from my GT-I9505 using Tapatalk
    01-12-2014 06:10 PM
  5. Peter Cohen's Avatar
    Have you opened Activity Monitor (in the Utilities menu) to see what processes are active? Wondering if something's gobbling up cycles in the background.
    Speedygi likes this.
    01-13-2014 12:55 PM
  6. Speedygi's Avatar
    Have you opened Activity Monitor (in the Utilities menu) to see what processes are active? Wondering if something's gobbling up cycles in the background.
    That's what I need to do.. Okay, will check and see what comes up.

    Sent from my GT-I9505 using Tapatalk
    01-13-2014 08:51 PM

Similar Threads

  1. Replies: 21
    Last Post: 01-14-2014, 03:32 PM
  2. AppStore no longer searches on ipad air any ideas
    By iMore Question in forum Ask a Question
    Replies: 6
    Last Post: 01-12-2014, 07:27 PM
  3. change email associate with appleid on iphone
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 01-12-2014, 04:32 PM
  4. #CESlive: Get the perfect gear case with MyCaseBuilder
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-12-2014, 10:40 AM
  5. #CESLive: Expanding iPhone Photography with Olloclip
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-12-2014, 10:10 AM
LINK TO POST COPIED TO CLIPBOARD