1. applefanboi's Avatar
    So I have a late 2011 Macbook Pro 17" running OS X Mavericks.

    Lately, I have been having an issue and I was wondering if anyone else has been having anything similar. My battery icon will change from it's normal status to a battery with an "x," as if the battery doesn't exist. I don't think my battery should be failing yet, though that is a possibility.

    I've also not tried disconnecting/reconnecting the battery to see if that helps. The problem seems to correct itself and is only sporadic. Next February will mark 2 years having the computer. I've not noticed any unusual battery drain when I'm running on battery power, matter of fact, it's still very excellent.
    11-23-2013 11:45 AM
  2. jsntrenkler's Avatar
    Have you tried removing the battery and cleaning the contacts? Check to see if there is dust or debris near the connection pins.
    11-24-2013 02:22 AM
  3. applefanboi's Avatar
    Thanks everyone! I tried disconnecting the battery, cleaned the connector and so far this issue has not happened again. Glad to know that it wasn't a bug with the OS.
    01-11-2014 06:04 PM

Similar Threads

  1. Mavericks reload
    By eastbayrae in forum MacBook Air
    Replies: 15
    Last Post: 11-24-2013, 12:34 PM
LINK TO POST COPIED TO CLIPBOARD