1. grunt0300's Avatar
    O.K. this may sound crazy, but all of the accent marks for my keyboard are gone. when i hold down the "o" key, i used to get eight options for accents above the letter, seven for the "e" key, five for the "u", etc. My wife has the exact same MacBook Pro, OS X 10.7.5 as i do. I assumed that it was a setting, so i rechecked her settings against mine, and what i looked at was exactly the same. What am i overlooking? Any help would be greatly appreciated. Thanks
    01-19-2013 03:20 PM
  2. Alli's Avatar
    I remember when I first got my Mac that was something I went looking for (on Windows it's a language/region setting), because I switch languages regularly and need my accent marks. There was no setting on the Mac - it just does it.

    If you've somehow accidentally disabled it, try this:
    → Open up your terminal
    → Enter the following command (no quotes): "defaults write -g ApplePressAndHoldEnabled -bool true"
    → Restart your computer. Bummer, I know. The press-and-hold functionality is immediately disabled, but you can't hold down a key until you fully reboot.
    01-19-2013 03:46 PM
  3. grunt0300's Avatar
    I'll try this although i've never used "terminal". After i type in that sentence to terminal, is there something else that i have to do, in order for terminal to receive the command?
    01-19-2013 04:07 PM
  4. Fausty82's Avatar
    I'll try this although i've never used "terminal". After i type in that sentence to terminal, is there something else that i have to do, in order for terminal to receive the command?
    just press [enter/return]
    01-19-2013 04:29 PM
  5. grunt0300's Avatar
    Nope. Tried it three times, and no go. Thanks for the help.
    01-19-2013 04:30 PM
  6. Fausty82's Avatar
    Nope. Tried it three times, and no go. Thanks for the help.
    Interesting... I had turned mine off some time back... but I just tried it and it worked perfectly, even without rebooting. Here's an article on the subject, but the command is exactly as Alli said:

    Disable the Character Accent Menu and Enable Key Repeat in Mac OS X Lion
    01-19-2013 04:43 PM
  7. grunt0300's Avatar
    Interesting... I had turned mine off some time back... but I just tried it and it worked perfectly, even without rebooting. Here's an article on the subject, but the command is exactly as Alli said:

    Disable the Character Accent Menu and Enable Key Repeat in Mac OS X Lion
    Is it possible that there's another explanation. Maybe i'm typing it in wrong. I'll try again.
    01-19-2013 06:23 PM
  8. Fausty82's Avatar
    Is it possible that there's another explanation. Maybe i'm typing it in wrong. I'll try again.
    You can copy/paste into the terminal window... What version of OS X are you running? Mountain Lion? Lion? Snow Leopard? Leopard?
    01-19-2013 06:42 PM
  9. grunt0300's Avatar
    You can copy/paste into the terminal window... What version of OS X are you running? Mountain Lion? Lion? Snow Leopard? Leopard?
    Lion. Could it be a setting in "system preferences"?
    01-19-2013 07:06 PM
  10. Fausty82's Avatar
    Lion. Could it be a setting in "system preferences"?
    It "should be" IMHO, but unfortunately, it is not.

    Actually, there is a 3rd party tweak from

    http://tweaksapp.com/

    that might help. I’ve been running the Mountain Lion version of the tweak since Mountain Lion was released. There’s a setting for enabling/disabling the repeating key...
    01-19-2013 07:08 PM
  11. grunt0300's Avatar
    It "should be" IMHO, but unfortunately, it is not.

    Actually, there is a 3rd party tweak from

    Developer Fredrik Wiker - Mountain Tweaks and Lion Tweaks

    that might help. I’ve been running the Mountain Lion version of the tweak since Mountain Lion was released. There’s a setting for enabling/disabling the repeating key...
    No go. Cannot get the character accent menu to work, no matter what i try. Looks like a trip to the Apple Store. Thanks for your help.
    01-19-2013 08:02 PM
  12. grunt0300's Avatar
    It was there all the time!!! I had switched web browsers from Safari, to Firefox. Safari supports the character accent menu, and Firefox doesn't.
    Fausty82 and Alli like this.
    01-20-2013 12:17 AM
  13. Fausty82's Avatar
    It was there all the time!!! I had switched web browsers from Safari, to Firefox. Safari supports the character accent menu, and Firefox doesn't.
    I love a happy ending.
    grunt0300 likes this.
    01-20-2013 04:16 AM
  14. grunt0300's Avatar
    Character accent menu also works with Google Chrome, but i'm undecided whether to use it for my browser, or stay with Safari. I've gotten used to Netvibes for my homepage, and it's a great substitute for iGoogle.

    Thanks again to you and Alli for your help.
    01-20-2013 09:34 AM
  15. Alli's Avatar
    In the immortal words of JustMe'D, glad I could help. Have a great day!
    Fausty82 and grunt0300 like this.
    01-20-2013 10:43 AM
  16. grunt0300's Avatar
    Like the new avatar Alli.:
    01-20-2013 11:58 AM
  17. Alli's Avatar
    Thanks! My hair is really coming in fast. I'm hoping that by the end of March I'll have good hair, walk without assistance, and be 100% cancer free!
    01-20-2013 05:03 PM
  18. Fausty82's Avatar
    Thanks! My hair is really coming in fast. I'm hoping that by the end of March I'll have good hair, walk without assistance, and be 100% cancer free!
    We’re with you on that, Alli!
    grunt0300 likes this.
    01-20-2013 05:48 PM

Similar Threads

  1. iPhone icons and Glass Keyboards
    By inertialnav in forum iPhone 4
    Replies: 7
    Last Post: 07-02-2008, 01:35 AM
  2. Keyboard review
    By t4l in forum iPhone 4
    Replies: 37
    Last Post: 07-07-2007, 10:17 PM
  3. iPhone Keyboard Introduction Video
    By archie in forum iPhone 4
    Replies: 31
    Last Post: 06-29-2007, 01:44 PM
  4. iphone onscreen keyboard sucks?
    By schnoid in forum iPhone 4
    Replies: 5
    Last Post: 06-09-2007, 01:11 PM
  5. Replies: 46
    Last Post: 01-21-2007, 09:14 AM
LINK TO POST COPIED TO CLIPBOARD