Late 2009 is no go for 10.10.3?

Printable View