1. Dustin Cichosz's Avatar
    iwidgets and groovylock widgets have a 7 hr time difference from what my actual time is and the time on my status bar. I uninstalled all tweaks and ran cleaner pro with no change. The weather portion of themes such as stripe is accurate. I'm running out of ideas. I tried going into ifile and correcting but can't find the line that controls the time zone. Al the minutes are correct just not hour. I have the latest untethered jaibreak update and running iOS 8.4
    07-08-2015 01:51 PM
  2. kch50428's Avatar
    Try contacting the authors of the widgets for guidance.
    07-08-2015 03:14 PM
  3. Dustin Cichosz's Avatar
    That's the weird part. It's any widget tweak. Iwidget, groovylock, cydget. When I open command terminal and type "date" it gives me the incorrect date.
    07-09-2015 09:53 AM
  4. Jeremy Williams3's Avatar
    That's the weird part. It's any widget tweak. Iwidget, groovylock, cydget. When I open command terminal and type "date" it gives me the incorrect date.
    07-09-2015 09:37 PM
  5. Jeremy Williams3's Avatar
    Hey man if you ever find a solution can you please let me know.. I'm having the same problem, it's really frustrating
    07-09-2015 09:39 PM
  6. 3cit's Avatar
    So your system clock like the one in the status bar is correct, but terminal app shows you an incorrect time?

    When using html themes, (cydget, groovylock,etc) you often times need to edit a few of the files to your liking.
    Often times the files you need to edit have a tutorial right in the file itself.

    For example you might need to change the temp code from "c" to "f" depending On wether or not You use Celsius or Fahrenheit. Or "12" to "24" depending on if you want to use a 12 hour clock (am/pm) or a 24 he clock...
    These files are almost always located in the folder of the theme you are using which is usually a sub folder of the tweak you are using to apply the theme...
    (var/mobile/documents/lockhtml/theme)...
    You can use ifile or filza in device to change the settings you need to change.

    Also, some of these themes need an app called mylocation. Which I don't think is on the default repos anymore...
    07-10-2015 10:29 AM
  7. Jeremy Williams3's Avatar
    It's not certain widgets or groovy lock themes it's all of them. I"ve been searching around & many others are having the same problem. Idk if it's a glitch in the new jailbreak or what. Even my location is correct on the widgets but not my time. I get what you're saying but since is every single one I try, it has to be something bigger than making manual changes. It's so frustrating 😩😢
    07-10-2015 01:08 PM
  8. 3cit's Avatar
    What ones are you trying? I have both groovy lock and lockhtml, I can install and see if I can see something.
    07-11-2015 12:27 AM
  9. Jeremy Williams3's Avatar
    Thanks I would really appreciate it. Like I said I've tried numerous ones but my current groovylock theme is shibui & the iwidget I'm trying to use is Flexy. Once again I appreciate the help 😃 . iOS 8.4
    07-11-2015 01:55 AM
  10. 3cit's Avatar
    Thanks I would really appreciate it. Like I said I've tried numerous ones but my current groovylock theme is shibui & the iwidget I'm trying to use is Flexy. Once again I appreciate the help 😃 . iOS 8.4
    When you open terminal, and you type "date" you get the wrong time?
    Like what date do you get?

    Also have you tried turning off automatically set date and time, and just doing it manually?
    I have no issue with the either theme
    But my terminal shows correct date
    07-12-2015 04:05 AM
  11. Jeremy Williams3's Avatar
    Thanks for all your help I really appreciate it. It seems I found a fix so I'll state what I did for anyone that wants to use this post as a reference for the future.

    I went into Ifile ... Var/ db/ localtime ... I erased the entire local time page.. Even though the information seemed to be correct. I then reinstalled my widget & resprung. After that I had to go into settings & manually fix the time again. Then I was good to go. Hope this helps
    07-16-2015 01:35 PM
  12. 3cit's Avatar
    Thanks for all your help I really appreciate it. It seems I found a fix so I'll state what I did for anyone that wants to use this post as a reference for the future.

    I went into Ifile ... Var/ db/ localtime ... I erased the entire local time page.. Even though the information seemed to be correct. I then reinstalled my widget & resprung. After that I had to go into settings & manually fix the time again. Then I was good to go. Hope this helps
    Nice.
    In settings did you allow it to set time automatically? Or did you do it manually?
    07-17-2015 12:28 AM
  13. Jeremy Williams3's Avatar
    I did it manually.. If I set it to automatic both widget & status bar time mess up ... Guess my next step is finding a fix for that. At least all my times are correct manually for now
    07-17-2015 01:33 AM
  14. dhouston25's Avatar
    You have a corrupted shortcut in your timezone folder. If you haven't fixed this yet, let me know.
    07-17-2015 09:02 AM
  15. Jeremy Williams3's Avatar
    No.. I'm not sure how to fix it, any help will be appreciated. TIA
    07-17-2015 10:52 AM
  16. Dustin Cichosz's Avatar
    I all but gave up on this. Exciting to see movement on this issue. I have not used iwidget or groovylock since this post in hopes of an update or fix. Very strange issue
    07-17-2015 11:32 AM
  17. Jeremy Williams3's Avatar
    Well Dustin if you do what I did above its guaranteed to work. You'll just have to keep the time on manual. I'll keep you updated on any further progress though. Good luck !
    07-17-2015 12:21 PM
  18. Dustin Cichosz's Avatar
    Here's the bananas part. I went to var/db/timezone/local time and it's empty. Before I went in I changed my time from auto to manually.
    07-17-2015 01:38 PM
  19. bmccormack11's Avatar
    Thanks for all your help I really appreciate it. It seems I found a fix so I'll state what I did for anyone that wants to use this post as a reference for the future.

    I went into Ifile ... Var/ db/ localtime ... I erased the entire local time page.. Even though the information seemed to be correct. I then reinstalled my widget & resprung. After that I had to go into settings & manually fix the time again. Then I was good to go. Hope this helps
    I had the same issue where any clock widget had the wrong time. Followed your steps and it works. The only problem now is if I go back to automatic time then my iphone time is wrong. Do you know of any way to get that back?
    07-17-2015 01:53 PM
  20. Jeremy Williams3's Avatar
    Not yet, I'm having the same problem unfortunately.. I was so happy to have my phone looking normal again I didn't care. But now even my Instagram & Facebook times are off. Not that important but it's the principle. Damn thing can't seem to get right. I'll keep looking for a fix & will keep you all updated. Really trying to avoid a restore but like I said I'll keep everyone updated
    07-17-2015 03:40 PM
  21. xeroendo's Avatar
    I did the fix you suggested and found that my iMessage also stopped working. Did you notice this by any chance? I didn't delete anything, just renamed it, so I renamed it back to what it was and everything is working now but the widgets are wrong again.
    07-18-2015 12:59 AM
  22. Dustin Cichosz's Avatar
    Trade one thing for another. It did work but f.lux is now all bananas and I have dif time stamps for different functions throughout. Looks like a good ok restore is in order. Good thing it takes 8 secs to jailbreak.
    07-18-2015 09:19 AM
  23. Jeremy Williams3's Avatar
    Hey guys I feel absolutely horrible for giving problems to your phone. I myself had problems with time stamps and imessage as well. So i did a restore. and used the newest jailbreak beta to rejailbreak. everything seems to be working fine now, including widgets and timestamps. I did have a problem with Imessage so i signed into cloud and rebooted. For now everythings fine like I said, but I'm going to refrain from giving any further advice or suggestions. Good luck !!
    07-18-2015 02:32 PM
  24. Dustin Cichosz's Avatar
    No worries my dude. I did the exact same thing you did. Running like a champ now. It must have been installing a tweak and removing it or the order of installing them. Whatever it was it was strange and it looks like there's still no solution outside of restoring.
    Jeremy Williams3 likes this.
    07-19-2015 10:06 AM
  25. bmccormack11's Avatar
    Hey guys I feel absolutely horrible for giving problems to your phone. I myself had problems with time stamps and imessage as well. So i did a restore. and used the newest jailbreak beta to rejailbreak. everything seems to be working fine now, including widgets and timestamps. I did have a problem with Imessage so i signed into cloud and rebooted. For now everythings fine like I said, but I'm going to refrain from giving any further advice or suggestions. Good luck !!
    My iMessage wasn't working so I finally decided to restore my phone last night and rejailbroke it using the updated Taig 2.4.3 (I used 2.2 the day it came out for my first jailbreak on ios 8.4). I still had to downgrade my iTunes to 12.0.1 to get it to work though. But now all the widget clocks work fine. And my iMessage works again!! Looks like doing a restore and rejailbreak is the only option.
    07-21-2015 04:05 PM
35 12

Similar Threads

  1. What does core time ips synced mean in my diagnostics and data info mean?
    By iMore Question in forum General Apple News & Discussion
    Replies: 8
    Last Post: 02-23-2017, 07:26 PM
  2. What do i do if the timestamp on my messages if wrong?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 07-08-2015, 08:58 AM
  3. Apple-Made Playlists Showing in My Music?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 07-07-2015, 04:44 PM
  4. Replies: 1
    Last Post: 07-06-2015, 01:35 PM
  5. My phone shows no signs of life, how can I revive it?
    By iMore Question in forum General Apple News & Discussion
    Replies: 4
    Last Post: 07-06-2015, 12:59 PM
LINK TO POST COPIED TO CLIPBOARD