1. jbraney's Avatar
    Hello, I am currently setting up a GreenPois0n - jailbroken iPod Touch 2G MC model with IOS 4.2.1 installed for my friend. I have installed the FreeDi Youtube Downloader, which works great on my 3G with 5.1.1, but on his iPod it constantly crashes. On Cydia, it says that is supports 4.2.1, but every time I click on the icon, it starts for a brief second, then flashes a white screen, then goes back to the home page. I have re-installed several times, rebooted, resprung, everything. The Cydia tweaks and apps installed are:

    -Activator

    -AirBlue Sharing

    -Five Icon Dock

    -iFile

    -MewSeek (I believe that this app has the same problem, but it isn't as important to us as FreeDi Youtube Downloader.

    -PandoraSkips

    -SBSettings

    -HiPStore

    -Springtomize

    I hope that this helps, and please let me know if there is anything else I can answer for you!
    10-21-2014 10:38 PM
  2. Just_Me_D's Avatar
    Are you still having issues with this problem or have you got your iPod working correctly? Please give us an update, at your convenience. Thanks...
    10-23-2014 12:42 PM
  3. jbraney's Avatar
    I have still not gotten it working yet. I have tried several other youtube downloading apps as well, such as youtuber, youtubed, protube, yourtube, and others I don't remember the name to. None of them, even the ones claiming to work on 4.2.1, will work. The stand-alone apps crash instantly on load, like FREEdi youtube downloader did, and the ones that modify the default youtube, such as yourtube (I tried 1, 2, and 3 btw), download videos fine. The problem comes when I try to play the video. It gives an error saying the video couldn't be played.

    Funny enough, my 5.1.1 3rd generation iPod has the same issue, except it says something like couldn't connect to the servers, even though I am trying to watch a downloaded video offline. Importing doesn't work either, for the same reason.

    Anyways, I am getting desperate now. The only thing I could think of that could work to my knowledge, is if someone could give me a working link to the DEB file for an older version that is confirmed to work with the iPod Touch 2nd Generation MC Model with firmware version 4.2.1.

    Please let me know anything you can think of!
    10-23-2014 04:48 PM
  4. jbraney's Avatar
    Alright, I was just able to get yourtube 3 to work due to a recent update, and am still trying to work out the import feature. This iPod is slow, and never has more than 30mb of RAM, which means anytime I try to do too much at once, it crashes. I am trying to delete stuff that might slow things down. One thing I am doing, is turning all springtomize options off, and next I think I will turn off the multitasking option. That is not an option normally, and I bet it hogs a lot of cpu.
    10-23-2014 05:32 PM
  5. jbraney's Avatar
    Alright. I got yourtube 3 to work, but the importer does not work. I would like to have it, but I can live without it. However, I could use help on another issue. I am starting a new thread for this separate issue called "Music won't play in music library PLEASE HELP!" in the "Ask a Question" Forum.
    10-23-2014 08:42 PM

Similar Threads

  1. 5th Gen iPod Touch & AND SMS Relay
    By Rolandh in forum iOS 8
    Replies: 2
    Last Post: 10-22-2014, 02:30 AM
  2. iPhone 4 - Activation Error - Please Help
    By Marc Geraghty in forum iPhone 4
    Replies: 3
    Last Post: 10-21-2014, 07:10 PM
  3. You can now open iTunes Connect for iPhone and iPad with Touch ID
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-21-2014, 02:51 PM
  4. How can I my iPad 2 to connect to my home?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 10-21-2014, 02:47 PM
  5. Continuity Keypad helps you make calls from your Mac
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-21-2014, 12:12 PM
LINK TO POST COPIED TO CLIPBOARD