1. yonkastone's Avatar
    I'm having trouble with any of the buttons that come up at the bottom of the screen when receiving a call (or the emergency call button when the phone is locked). whenever these buttons pop up (whether it be emergency call or when i get a call while doing something on my phone) they don't work. Even if I slide up where you can respond w/a text message it still doesnt work (although the button to respond w/a text works fine). I have a 4s on jailbroken 6.1.2. All the other buttons work fine and i can slide to answer without an issue. Ive disabled all my winterboard themes and I even tried when in safe mode and still nothing. Any suggestions as to what else I can look into? Sorry if this is the wrong forum (my phone is jailbroken and i'm assuming it has something to do with it), please feel free to move it if necessary. TIA

    Call Answer Button doesn't work-ytlx.jpg
    06-15-2013 05:31 PM
  2. Jaguarr40's Avatar
    You are in the right forum and there may be an issue that you might just need to hard reset your phone by holding down the home and power button. Your phone may be just stuck in a loop and may need to have it's cache cleared, Try this first and see if everything returns to normal. it usually clears things up. Give it a try.
    06-15-2013 08:48 PM
  3. yonkastone's Avatar
    tried that a couple of times and still no luck
    06-16-2013 02:06 AM
  4. yonkastone's Avatar
    If I restore factory defaults on my phone will it:

    1) Remove the jailbreak (so I can see if the buttons work and jailbreak again)
    2) Keep it at 6.1.2 since that's what's on my phone or will it automatically update it to 6.1.3?
    06-18-2013 10:03 AM
  5. Laelipoo's Avatar
    Do not hit "erase all contents and settings" you'll boot loop. Your best bet is to uninstall mobile substrate from cydia. This will uninstall all tweaks. See if the buttons work. If so, there is a conflict. If they do not, you may need to restore.
    yonkastone likes this.
    06-18-2013 11:23 AM
  6. yonkastone's Avatar
    Do not hit "erase all contents and settings" you'll boot loop. Your best bet is to uninstall mobile substrate from cydia. This will uninstall all tweaks. See if the buttons work. If so, there is a conflict. If they do not, you may need to restore.
    ok i'll try that, thanks. if i uninstall mobile substrate will all my other tweaks stay on the phone but are just basically disabled? just want to make sure i don't need to make note/backups of what i have. also, if/when i reinstall mobile substrate will everything pick up from where it left off or will i need to activate tweaks and whatnot again. Sorry if the questions are basic, just want to make sure i know what to expect so i don't panic that i lost everything :P
    06-18-2013 11:41 AM
  7. Laelipoo's Avatar
    It will uninstall everything. So yes, make a backup.

    You may have to redo your settings; you may not. It depends on the tweak. I would make a list of your settings too.
    06-18-2013 08:01 PM
  8. yonkastone's Avatar
    Ok cool, I'll back everything up and give it a shot. Assuming it doesn't work and I have to unjailbreak and rejailbreak is there an FAQ or something on how to do that? I just want to be 100% I don't mess it up and force myself to have to install 6.1.3.
    06-18-2013 08:04 PM
  9. Laelipoo's Avatar
    ... You would have to restore to 6.1.3, that is the only other option.

    That's why I am really hoping it's a tweak compatibility issue.

    Actually, before you uninstall it, boot into safe mode. Turn off your phone, hold volume up button, turn phone back on.

    ​Does it work?
    06-18-2013 08:08 PM
  10. yonkastone's Avatar
    Just tried it, didn't work in safe mode. However, compared to my wifes jailed iphone 4, it looks like something isn't aligned properly. Any idea what folder(s) those files are saved in? I'm thinking if I could somehow find the original files and overwrite what's on my phone it may work... I'll upload a screen shot shortly
    06-18-2013 08:35 PM
  11. Laelipoo's Avatar
    Due to the differences in the 4 and the 4S software-wise, I wouldn't recommend copying files over. It never seems to end well. You should still try uninstalling mobile substrate to definitely rule out a tweak, but it seems like a file went bad somewhere, and the only true solution for that is a restore.
    yonkastone likes this.
    06-18-2013 08:38 PM
  12. yonkastone's Avatar
    I wouldn't copy from the 4 to the 4s but if I could get the original png files from a 4s I would give that a try. Thank you so much for all your help though, greatly appreciated!
    Attached Thumbnails Call Answer Button doesn't work-image.jpg  
    06-18-2013 09:07 PM
  13. yonkastone's Avatar
    i think i figured out my problem. do you know the file name for this background box? I believe the image file is located in root/system/library/coreservices/springboard.app

    if you find it can you let me know the file name and image size?

    Call Answer Button doesn't work-2013-06-18-22.21.58.png
    06-18-2013 10:28 PM
  14. Laelipoo's Avatar
    I want to say it's WellLock@2x.png or something to that extent.
    yonkastone likes this.
    06-19-2013 08:09 AM
  15. yonkastone's Avatar
    I figured it out. It was a 3 pictures in the com.apple.TelephonyUI directory that I accidentally renamed. I must have thought i was in a theme folder trying to get rid of those black lines but somehow ended up in the main folder and renamed the wrong ones. Once I changed those back to the original file name and resprung it was back to normal.

    Thank you so much for your help, had it not been for you I would've either given up long ago and felt with it or tried to take care of it myself and been forced to upgrade to 6.1.3. And be deleting mobile substrate I was able to clean up the tweaks I don't use/need anymore
    06-19-2013 08:31 AM
  16. Laelipoo's Avatar
    Awesome! I am glad you're up and running again. You are most welcome and have a good day.
    06-19-2013 11:22 AM

Similar Threads

  1. Replies: 4
    Last Post: 03-17-2011, 11:43 AM
  2. Power button doesn't work :(
    By brina042 in forum iPhone 4
    Replies: 5
    Last Post: 02-08-2011, 12:08 PM
  3. Volume Down button doesn't work
    By Dieter Bohn in forum iPhone 4
    Replies: 8
    Last Post: 03-29-2010, 07:23 PM
  4. Jailbreak doesn't work anymore
    By bond2k in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 04-21-2009, 08:41 PM
  5. Safari doesn't work anymore
    By shutter in forum iPhone 4
    Replies: 1
    Last Post: 02-13-2009, 08:00 AM
LINK TO POST COPIED TO CLIPBOARD