1. foxesinsoxes's Avatar
    hi, just wondering if i go through and manually delete my jailbreak tweaks will that fix what is possibly wrong with my phone or do i need to get into dfu and restore?

    basically when i plug my phone into my laptop its "usb not recognized" have been into the device manager and just has an exclamation mark next to it, doesnt matter what usb port its plugged into. when i was installing tweaks i wasnt doing one at a time and checking for compatibility issues so im not sure which tweak caused this problem. so...just wondering if i can delete the tweaks one by one and once i delete the tweak, will my phone then be fixed?

    any help or insight would be appreciated. if i can fix things withOUT restoring, that would be ideal. thanks in advance
    04-07-2013 01:44 AM
  2. Sharma15's Avatar
    Boot your phone into safe mode before removing any tweaks. Shut off the phone and hold volume up button as it starts up to boot into safe mode. Then try plugging it in and seeing if the computer recognizes it. If it does, one of your tweaks is causing the issue. I would install SBSettings and use the mobile substrate option to disable each tweak one by one and seeing which tweak causes the issue.
    04-07-2013 02:13 AM
  3. foxesinsoxes's Avatar
    so i did that and its still the same thing, usb not recognized...

    its gotta be one of the tweaks though? nothing else has changed, like on my laptop. and the cord still works when i plug it into the wall? and also everything else that i plug into my usb ports work just fine

    ive tried going through and deleting all of itunes manually, step by step and reinstalling and all of that....so its looking like ill have to either uninstall tweaks or dfu and restore. so like i was asking, will deleting one by one fix the issue or do i have to restore???
    04-07-2013 05:23 PM
  4. natasftw's Avatar
    If the problem happened in safe mode, deleting tweaks won't solve it :/

    When you plug it into your computer, is it charging when you look solely at the phone? The computer is failing to recognize it as a known type of device. This doesn't always mean its not receiving power. The wall outlet won't be trying to decipher what type of device you have. That actually provides very limited troubleshooting information :/

    Which phone do you have? I haven't tried with the newer phones, but I've used redsnow to kick a device out of dfu mode before. I'd imagine it would work on newer phones too. Seething you might try is putting the phone into dfu and see if the laptop recognizes it at that point. With the issues you've listed to this point, it's not a certainty dfu would allow the connection.
    04-07-2013 06:26 PM
  5. foxesinsoxes's Avatar
    when i plug into laptop it doesnt charge. charges at wall just fine.

    iphone 5, 32gig, 6.1.2

    it just does "usb not recognized" all day long....gonna see if maybe getting it into dfu mode will work...i just wanna make sure that ill be able to restore from a backup. i should be able to, right? its not gonna make me go to 6.1.3 is it?? i would like to keep my jailbreak lol

    it did this once before where it did usb not recognized and i restored through dfu and it was fine...till now. and i havent been into cydia in a long time and i tried to go in there and its telling me too many packages or something and wont even load so even if i wanted to i couldnt delete things one by one...at least thats what im thinking. just tried to do that a little bit ago. im letting my phone charge b.c it was super low then i plan to just restore. unless....unless i have other options but at this point i dont think i do. plus im super sick of dealing with this lol just like to get it over with
    04-07-2013 07:44 PM
  6. natasftw's Avatar
    Backups are just photo/video, texts, and settings. Restoring with it without a backup is an equivalent task for what you want.

    If you restore, it will be to 6.1.3. There's currently no other alternative. If you saved your shsh blobs, it may eventually become an option.

    Try a full reboot and go back into cydia. See if the loading problem persists. If you want to maintain the jailbreak, you'll want to at least try removing tweaks prior to a restore.

    If the reboot doesn't work, try again in safe mode.

    If all it says is "loading packages" just wait. It's reading the available packages from the sources you have installed. That can take a while sometimes :/
    04-07-2013 08:02 PM
  7. foxesinsoxes's Avatar

    sorry, im just sort of freaking out here.

    i started going through one by one, deleting packages and sources (which brings up a question but hold on...) and i was plugging in usb after every delete, right? well finally im just like screw this, this isnt gonna work and im gonna be stuck with no jailbreak, no anything...and i was getting really upset. well finally i stopped plugging in but was still writing down each thing i deleted. anyways, the last things i deleted were 3g unrestrictor, activator and then i also got rid of the inanelyi repo

    could a repo somehow install something bad? i cant imagine activator did something and 3g unrestrictor i know was working while i was able to plug in..

    oh and also, i deleted a repo before i checked to see if i had any packages from that repo. does that mean that anything that was from that repo was also deleted??? do i need to reinstall that repo and then will i get my packages back? or.....im just sorta confused there. hope it makes sense what im asking....

    anyways, phone is now plugged into laptop and working..after deleting about most of my tweaks. guess ill just have to go reinstall, one by one. ugh...oh well, its better than losing my jailbreak!
    04-07-2013 10:41 PM
  8. natasftw's Avatar
    The easiest question in all of that is about what deleting the repo does. It just prevents you from being alerted to future updates. The current versions will remain on your phone untouched.

    The repo SHOULD just be a list until you opt to install a package. There's an easy way to troubleshoot this. Add the repo, check for your issue. If it surfaces, it is likely to be the cause. If it surfaces later and removing the repo fixes the issue, it's also likely that's your cause.

    So now, reading the last sentence I'll trust you're glad you didn't just take the frustrated restore option?
    04-08-2013 12:18 PM
  9. ja2ed's Avatar
    I have a question for anyone that could answer. Is deleting every file in "/var/mobile/Library/Caches" this folder is safe? I am trying to get my phone as clean as possible and I think I have done the right procedure. At the same time this guy in this other forum is telling me it's safe to do this. I just want to confirm this or not before screwing up something I think is fixed.
    04-10-2013 05:16 PM
  10. 3cit's Avatar
    have you tried reinstalling the driver for the iphone.
    i dont think its a phone issue at all.
    i think its a computer issue.
    i think somehow one of your drivers for the iphone is messed up.
    so next time you plug it in and you get the not supported issue, go to device manager, find your exclamation point and roll it back, or repair it, or reinstall it.
    04-10-2013 08:25 PM

Similar Threads

  1. Restoring from an iCloud backup after jailbreaking an iDevice as new
    By eprisencc in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 6
    Last Post: 09-02-2014, 10:41 PM
  2. Deleting Jailbreak application
    By tucklo in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 5
    Last Post: 10-20-2009, 11:06 AM
  3. jailbreak illegal!? What now: RESTORE??
    By jaguar11 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 11
    Last Post: 08-30-2009, 01:53 AM
  4. Cool jailbreak tweaks/obscure apps?
    By tulliver in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 8
    Last Post: 07-21-2009, 01:12 PM
  5. Deleting Jailbreak Apps
    By jhauser3 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 5
    Last Post: 12-01-2008, 01:32 PM