1. Tony Yeo's Avatar
    hello all,

    i got problem on my ipad 3 after jailbreak i got problem after i try my siri
    it would restart / change to safe mode after i ask siri to laucnh app
    like siri launch facebook or siri launch ifile
    it just turn out a apple logo then have said exit safe mode?
    after exit and try again it turn out jam or lagging totally not respond
    until few minutes then normal again

    so what the problem i facing here?
    can it be solved???
    hopefully solved without losing data
    05-25-2013 12:17 AM
  2. natasftw's Avatar
    Ok, I fixed my siri and can report she is now opening all of my apps no problem.

    First you need to go into iFile and find these 2 files
    /var/mobile/Library/Caches/com.apple.LaunchServices-045.csstore
    /var/mobile/Library/Caches/com.apple.mobile.installation.plist

    Once you find them don't delete them just in case
    change them to
    /var/mobile/Library/Caches/com.apple.LaunchServices-045.csstore.bak
    /var/mobile/Library/Caches/com.apple.mobile.installation.plist.bak

    This basically renders them invisible, you can go and delete them later, always good to keep a backup

    Once you have changed the name back out to Springboard and do a full reboot.
    Upon reboot you will notice all your stock apps are there and your installed cydia apps but NO appstore apps.
    DONT PANIC

    Just sit back and chill as iOS will slowly rebuild your apps on the springboard. I have over 300 apps on mine so it took a couple of minutes.
    Once all your apps are showing give Siri a test.. Should work perfect.

    Then go back into iFile and removed the files you changed to .bak

    Done.. lemmie know how you go
    05-25-2013 12:43 PM
  3. ridiculocity's Avatar
    Get rid of Assistant Extensions if you have it installed also.

    The method I mentioned which was just reposted for you by natasftw (thanks) does work as also today both my minis stopped opening apps. Fixed them both within minutes removing those files in ifile
    05-25-2013 01:41 PM
  4. m_thoroughbred's Avatar
    I can't find those files in ifile. What can I do?
    06-06-2013 08:14 PM
  5. m_thoroughbred's Avatar
    Nevermind I found it. Thx
    06-06-2013 08:30 PM
  6. Chuck Norri5's Avatar
    Rediculocity:

    I can't find these 2 files:

    /var/mobile/Library/Caches/com.apple.LaunchServices-045.csstore
    /var/mobile/Library/Caches/com.apple.mobile.installation.plist

    Well, actually, I can't find LaunchServices. What happened?
    06-14-2013 01:17 AM
  7. skiales's Avatar
    so I don't know what part of "JUST IN CASE" I didn't understand even though I did append the two files with (.BAK) nothing happened so I went in to safe mode and got rid of them again (NOTHING HAPPENED) well I was dumb enough to delete the first file and figured it sure is suppose to work...! RIGHT
    NOPE I NEED A GOOD KICK TO THE HEAD wel after a reboot as you mentioned all of my {OK DONT MAKE FUN OF ME BUT HERE GOES} all of my 742 apps disappeared but they appear to be taking up space somewhere is there somehow to force them to show because its show I've taken up 28 GB but there not appearing. I should also ask if turning the "sync my apps" in the settings for itunes is ENABLED and if that makes a difference or not...?
    I also know someone here mentioned it took a while for there 300 apps to reappear but its been 24 hours and no luck ....! The only hope I have is knowing somewhere theres 28 GB worth of space still taken up ....! Any input would be greatly appreciated and learnet from if you could HELP...! THANKS in advance for even bothering to read this
    10-17-2013 07:52 AM
  8. natasftw's Avatar
    You deleted the list the phone uses to populate the apps on screen. That's why they said to use the .bak so you could easily regain it.

    Is it safe to assume you've tried another reboot?
    10-17-2013 11:04 AM
  9. AmpedPotato's Avatar
    Try deleting the two files again and reboot. Give it time before taking more troubleshooting steps.


    Sent from my iPhone 4S using Tapatalk
    10-17-2013 01:07 PM
  10. skiales's Avatar
    "NOT WITTINGLY" AS NSA sh*&t head james clapper would say but you and I know theres two and one of them is me.....! fml end of rant

    Yes I am afraid my stupid ego of "OH THIS WILL DEF work" got the best me it was on the third time that it hadn't populated which I deleted them and rebooted. Now with respect to "rebooting" initially I did by opening SBSETTINGS and click on the power button then reboot which failed to make them disappear at this point I still had the files in ".bak" extensions on them which then I ignorantly and deservedly deleted the .bak ones and then proceeded reboot which at this time I held top button till "slide to power" appeared which after I felt great I'll just hang tight (due to number of APP a little while longer) which is when I decided that. The extent of the stupidity which I made could't even bear to feel bad for my self ... The whole timing of me deciding to be get SIRI working on my iphone 5 was really pathetic but I'm hoping something good will come out of this somewhere so I was thinking how would find the dependencies with respect to the two files as one of them is a prefrence list to maybe force or rebuild something in order to unmask them since my phone still shows 28GB of space still taken up...
    I feel like I'm desensitized as much I would like to admit that I could rebuild the lost data from scratch but i know i cant, and just go iLEXRAT on it but I much rather leave that as a NUKE option if possible (or would it not make a difference since all the cydia apps are still visible )...!

    Once again I humbly thank you for any insight and again Feel appropriate to appreciate the time spent on reading my reply thanks
    10-18-2013 09:14 AM
  11. skiales's Avatar
    I just hope I haven't offended any body but my last rant was extremely derelict to say the least. I just needed to clarify that. Yes @natasftw I have rebooted a few times and still no luck. You mentioned earlier /var/mobile/Library/Caches/com.apple.LaunchServices-045.csstore & com.apple.mobile.installation.plist are both lists which the phone using for populating the apps on the screen. Which explains why they are still taking up space on my phone just no image to represent them is that correct..? And if so is there a script or command line code which I can evoke to repopulate the caches from scratch with out any sort reinstalling anything...?

    I am still curios to the answer of role of those two particular cache files and would luv to be schooled on.... HOWEVER this resolved
    my issue for any of those hopefully not many " cognizant ignorant persons" who DID NOT ABIDE by the directions CONCISELY stated
    thanks again

    ^^Simply removing appsync will not fix the issue.
    If you are scared off long command lines,an easier fix would be..
    1.Apply the fix provided by evad3rs from Cydia
    Reboot
    2.uninstall Appsync

    3.Delete
    a)com.apple.mobile.installation.plist AND b)com.apple.LaunchServices- 045.csstore
    (Both Files are located in var/mobile/library/caches)
    Use either ifile(from your phone) or ifunbox(from your Mac,I am not sure about Windows,but should work)
    Reboot.
    4.Then reinstall appsync

    Now,both appsync and the weather app should work.
    P.S-If you have things like Vshare or pp installed,remove them too in the first step.
    Last edited by skiales; 10-21-2013 at 10:21 AM. Reason: FOUND THE RESOLUTION
    10-21-2013 09:36 AM
  12. pezcore350's Avatar
    Did this, and it worked! Thanks!

    Also, I didn't have the launchservices file (just the other one) and I do have appsync and it does not interfere with this fix.

    iOS 6.1.2 iPhone 5. Thanks again!
    10-26-2013 11:36 AM
  13. Sheboz's Avatar
    I only registered to thank you!
    01-03-2014 08:03 AM
  14. wildog426's Avatar
    I couldn't find these files with iFile on my jail broken iPod Touch 5, ios 7.0.4. Here's how I fixed it:

    1. Download iLex R.A.T. and MobileTerminal from Cydia

    2. Open MobileTerminal and type "rat" then return

    3. A list of options appear. Choose option 7, clearing cache iOS then return

    4. Reboot iPod
    02-09-2014 01:45 PM
  15. LexingtonPro's Avatar
    Just another huge fan.
    Registered to say thanks!
    BTW I didn't have the "Assistant" app installed on mine, so it's probably more than one bad app.
    02-15-2014 09:32 AM
  16. superipad99's Avatar
    Thank you very much this finally fixes my jailbroken version of siri though i had no problems with my appstore apps. Thankyou thankyou thankyou
    ridiculocity likes this.
    03-16-2014 02:20 PM
  17. pedromadeira's Avatar
    Thanks allot! A recover ios 3 times...and afer install all my sources of cydia...good bye Siri...
    Thanks!
    09-07-2014 06:41 PM
42 12

Similar Threads

  1. cydia problem after jailbreak 3.0 on iphone 3g
    By francoo in forum iPhone 3G Forum
    Replies: 3
    Last Post: 07-11-2009, 12:33 AM
  2. No Luck on Jailbreak
    By Sir_William in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 12-27-2008, 07:35 PM
  3. Newbie Question about ATT service on JailBreak
    By jayman30 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 6
    Last Post: 11-18-2008, 03:32 PM
  4. itunes problems on my iPhone
    By William Rollings in forum iTunes
    Replies: 0
    Last Post: 11-17-2008, 04:13 AM
  5. Used Iphone 3g - advice on jailbreak and dataplan
    By mart1969 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 8
    Last Post: 11-09-2008, 11:45 AM
LINK TO POST COPIED TO CLIPBOARD