1. mkoch227's Avatar
    While using my car kit on iOS 5.1.1 jailbroken, my TomTom Car Kit (External GPS) worked flawlessly. When I upgraded to 6.1 (not jailbroken), I could still use the gps perfectly fine. However, after installing the evasi0n jailbreak, my GPS no longer "locks" onto a signal - I cannot get directions at any time. To make sure it did not have anything to do with a cydia package, I restored my device, rejailbreaked, and tested the GPS - no go.

    Does anyone know of a fix for this?
    02-06-2013 02:38 PM
  2. 3cit's Avatar
    While using my car kit on iOS 5.1.1 jailbroken, my TomTom Car Kit (External GPS) worked flawlessly. When I upgraded to 6.1 (not jailbroken), I could still use the gps perfectly fine. However, after installing the evasi0n jailbreak, my GPS no longer "locks" onto a signal - I cannot get directions at any time. To make sure it did not have anything to do with a cydia package, I restored my device, rejailbreaked, and tested the GPS - no go.

    Does anyone know of a fix for this?
    you think the jailbreak broke your gps? or the application?
    02-06-2013 02:56 PM
  3. kch50428's Avatar
    Try turning Location Services off... reboot the phone, then turn Location Services on again.
    02-06-2013 03:03 PM
  4. mkoch227's Avatar
    @3cit: The jailbreak "broke" the actual GPS receiver. Instead of the dot moving down the street in a fluid manner ("driving mode"), it jumps from spot to spot instead (almost like it's losing and reconnecting to the GPS satellites continuously). This effect is present on any navigation app (Apple Maps, Google Maps, TomTom, Navigon, etc)

    @kch50428: I will try turning the procedure you posted shortly, and will respond with my results later tonight (11PM EST), as I will be at work from 4p-11p. We'll see if my GPS can navigate me or not
    02-06-2013 03:07 PM
  5. 3cit's Avatar
    @3cit: The jailbreak "broke" the actual GPS receiver. Instead of the dot moving down the street in a fluid manner ("driving mode"), it jumps from spot to spot instead (almost like it's losing and reconnecting to the GPS satellites continuously). This effect is present on any navigation app (Apple Maps, Google Maps, TomTom, Navigon, etc)

    @kch50428: I will try turning the procedure you posted shortly, and will respond with my results later tonight (11PM EST), as I will be at work from 4p-11p. We'll see if my GPS can navigate me or not
    so its not just the one application, when i said gps. thats what i meant, like the entire phones gps system...

    what tweaks have you installed? becuase i havent heard yet of any others having the same gps situation. probably a conflict with the set of tweaks you have installed
    02-06-2013 04:23 PM
  6. mkoch227's Avatar
    @kch50428: Attempting the procedure you provided unfortunately did not work.

    @3cit: this is a clean jailbreak, with no tweaks installed (except anything evasi0n may have installed).

    let me clarify that this is an iPod Touch using the TomTom External GPS (hence why there is no GPS in the iPod Touch (4th Generation)). If I try to find my location outside of a WiFi zone, here is what I receive:

    TomTom Car Kit and iOS 6.1 Untethered JB-photo.png
    (however, the app is allowed to request my location, according to location services (location services = on, GPS Nav 2 = on)

    If I am connected to WiFi, it will find my location, and then as I drive the dot will jump around wherever it goes.
    02-06-2013 10:30 PM
  7. Mr_Angry's Avatar
    Hi there,

    I too am having GPS issues. I'm using an iphone 4s on 6.1.1 (10B145) with Tom Tom car kit tool, Tom Tom car kit mount and UK & Ireland 1.13.

    I can only get a GPS signal when parked.


    Since upgrading from 5.1.1 to 6.1 and subsequently 6.1.1 once moving speed does not change, I eventually (after a few feet / metres) lose GPS and get the "Poor GPS" "Waiting on GPS signal" messages.

    All other GPS apps (Google maps, City maps to go, GPS kit) are working exactly as expected.

    I've tried multiple uninstalls / reinstalls of the app but with no success. I'm having the exact same issue on my 3gs running 6.1 (10B141)

    Any help would be greatly appreciated folks.
    Last edited by Mr_Angry; 02-14-2013 at 01:25 PM.
    02-14-2013 01:14 PM
  8. mkoch227's Avatar
    I have actually realized that this issue with my iPod Touch 4G on iOS 6.1 occurs on not just on a jailbreak, but on the stock iOS. I have now downgraded back to iOS 5.1.1, waiting for a fix.
    02-14-2013 01:22 PM

Similar Threads

  1. iPhone 4 doesn't work with TomTom Car Kit
    By TonyD in forum iPhone 4
    Replies: 11
    Last Post: 06-25-2010, 02:23 PM
  2. TomTom car kit question
    By outsidein13 in forum Accessories
    Replies: 0
    Last Post: 01-07-2010, 08:06 PM
  3. TomTom car kit
    By cjvitek in forum iPhone Apps & Games
    Replies: 18
    Last Post: 11-12-2009, 11:28 PM
  4. TomTom car kit price point
    By ryanlberg in forum Accessories
    Replies: 12
    Last Post: 11-12-2009, 11:27 PM
  5. tomtom car kit
    By Ticman in forum iPhone Apps & Games
    Replies: 2
    Last Post: 10-02-2009, 05:22 PM
LINK TO POST COPIED TO CLIPBOARD