1. sameer kapoor's Avatar
    I am a satisfied jailbreaker on MiPhone* 4 untethered 5.0.1. Earlier I was on tethered 6.0.1 , as I spend daily 6-7 hrs on pc so tethered jailbreak was no issue for me regarding rebooting. The main issue was the compatibility of themes , apps and tweaks with 6.0.1 . I think it was due to lack of an untethered ios 6 jailbreak . Now it is available by the grace of evad3rs but I don't find an single reason to upgrade to ios 6 again . so, I need advice of senior members that should I upgrade or not ? Thanks in advance.




    * before jb its iPhone after jb its MiPhone
    02-06-2013 09:50 AM
  2. chadec's Avatar
    I am keeping my phone on 5.1.1 since I know that is a very stable jb. However my test phone and iPad are updated and jb on 6.1 with only a few quirks, and I've not seen all the tweaks/utilities as updated to work with 6 yet. I would recommend holding off just a little longer for the tweaks to stabilize if youve got just the one iDevice.
    02-06-2013 09:57 AM
  3. Laelipoo's Avatar
    I would say yes, for the simple fact that apps are starting to require 5.1.1 or greater to run. It's much easier to just upgrade to 6.x now and untether than try to get to 5.1.1.
    02-06-2013 09:58 AM
  4. chadec's Avatar
    And immediate conflict, choose wisely. Haha


    Though the point of 5.1.1 becoming a new baseline (and near impossible to get to at this point) is a valid one
    02-06-2013 09:59 AM
  5. BLiNK's Avatar
    Yes.. No.
    02-06-2013 10:00 AM
  6. natasftw's Avatar
    You're on the 4, so it's not a HUGE deal. The bootrom exploit means you'll always be able to jump around between different iOS versions without needing the Apple signatures.

    As Laelipoo mentioned, developers tend to spend less time worrying about backwards compatibility the longer a new iOS is out. The less they worry, the less you'll be able to get new apps or updates to ones you already do have. There's no need to be in a rush, but unless you're looking for very specific jailbroken apps that aren't updated there's no real reason to hang back either.

    Simply, do what you want. Neither decision logically dwarfs the other.
    02-06-2013 10:26 AM
  7. sameer kapoor's Avatar
    Thanks to all for advice , so I have decided to stay with my present jb 5.0.1 as till now everything is compatible with it and its flawless . I have decided to check this forum untill there are no complaints regarding ios 6 compatibility or I should upgrade to ios 6.1 only after the release of ios 7 .
    02-06-2013 09:17 PM
  8. iDonev's Avatar
    If you decide to stay on iOS 5 for a while, make sure you save your SHSH blobs!!
    Apple is already releasing iOS 6.1.1 to developers, so the lifespan of 6.1 is rapidly closing!
    02-07-2013 07:00 PM

Similar Threads

  1. To upgrade or not
    By jeffw78 in forum iPhone 4
    Replies: 8
    Last Post: 02-06-2011, 12:00 PM
  2. Should I Wait or Not?
    By Naughty_Ottsel in forum Original iPad
    Replies: 13
    Last Post: 10-10-2010, 02:48 PM
  3. Upgrade or not...
    By SHEDGES in forum iPhone 4
    Replies: 0
    Last Post: 11-17-2009, 04:19 PM
  4. The ? is to upgrade or not???
    By ddclark94 in forum iPhone 4
    Replies: 6
    Last Post: 09-11-2009, 05:41 PM
  5. Upgrade or Not OS 3.0
    By Dazlin2 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 7
    Last Post: 07-20-2009, 06:13 AM
LINK TO POST COPIED TO CLIPBOARD