1. nathanajah's Avatar
    Hi, I'm an ipod touch 4g user, just updated to iOS 6.0.1.

    I want to jailbreak the device using redsn0w 0.9.15b3, but when I run it, it shows the message "Couldn't load Mobiledevice.dll (error 126)". It doesn't even recognize my ipod when I booted into DFU! (my old redsn0w, 0.9.10b5c can detect it though, but it doesn't support iOS 6.0.1, does it?)

    After some googling, I found out that there's many mobiledevice.dll error, but most of the time it's error 127, not error 126. I tried the solutions online (compatibility mode, run as administrator, copying mobiledevice.dll to redsn0w folder), but nothing seems to work yet.

    Any idea how to fix it?
    01-28-2013 10:25 AM
  2. iDonev's Avatar
    Assuming you run a Windows PC, try using sn0wbreeze instead.
    01-28-2013 11:20 AM
  3. 3cit's Avatar
    Update to the latest iTunes. It will update and resolve all driver issues
    01-28-2013 12:23 PM
  4. nathanajah's Avatar
    I think my iTunes is the latest version. I tried sn0wbreeze, but I got error 3194 when trying to use the ipsw.
    01-30-2013 08:15 AM
  5. iDonev's Avatar
    Update your hosts file and enter DFU mode to get rid of error 3194.
    01-30-2013 08:21 AM
  6. nathanajah's Avatar
    I finally opted to wait for evasi0n instead, which worked.
    Thanks anyway
    02-05-2013 04:38 AM

Similar Threads

  1. Redsn0w Error!!
    By 1982ollie in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 22
    Last Post: 06-12-2014, 08:42 AM
  2. Replies: 2
    Last Post: 10-26-2012, 01:49 PM
  3. error 1004 when trying to load apps
    By piyates in forum iPad 2
    Replies: 1
    Last Post: 07-02-2011, 01:02 PM
  4. Replies: 10
    Last Post: 07-05-2008, 01:49 PM
  5. An unexpected error has occurred (1602).
    By nmprofessional in forum iPhone 4
    Replies: 0
    Last Post: 02-28-2008, 05:10 PM
LINK TO POST COPIED TO CLIPBOARD