1. rayjeremyyy's Avatar
    Well, this is my first post in iMore forum as i decided to get involved in here... Anyways don't be too rude guys hahaha

    Okay so i am using iPhone 4S since its launch back on January, but today i noticed that Siri won't find any location nearby and she said 'unable to find your current location'
    I live in Indonesia, way too far from US, and i'm on iOS 5.0.1, so i bought International Locations for Siri from Cydia.
    It works like a charm until today Siri stopped working on finding locations such as malls, or restaurants.
    So, i tried to reinstall the package and respring the iPhone, and had no luck. I also have tried to turn off Siri and turn it on again. I was desperate enough until at one point i decided to restore it. But i remembered that Apple had stopped signing iOS 5.0.1, and 5.1.1. So i basically can't get to the same iOS if i restore or upgrade to 5.1.1.

    The solution is simple, but there is no such thing in Google. So i experimented twice and tested the solution with my brother's iPhone with the same problem
    Go to Settings --> Location Services --> Siri, turn that off and turn back on. As easy as that!
    I was amazed at first. But it might not fix the problem if you live outside US and without International Locations.

    Anyway glad if i helped you
    If there are post(s) that told you the same as i did please let me know
    12-22-2012 10:02 AM
  2. 3cit's Avatar
    Thank you. Information for life there!
    12-22-2012 10:53 PM
  3. John Yester's Avatar
    Location services will have to be always turned on for anything GPS to work.
    12-22-2012 11:57 PM
  4. iDonev's Avatar
    On my iPad when I search for locations with Siri I get prompted to turn on Location Services... If I had to guess, International Locations has broken this dialog.
    [FIX] Siri unable to get current location-image.jpg
    12-23-2012 10:26 AM
  5. 3cit's Avatar
    I think apple wants you all to come to the good old U.S.ofA
    12-23-2012 03:26 PM

Similar Threads

  1. Replies: 4
    Last Post: 11-06-2011, 02:44 PM
  2. [Fix] Siri Cant Connect to the Network
    By khanlala in forum Siri
    Replies: 7
    Last Post: 10-19-2011, 08:18 AM
  3. "libxml2-lib" and "sqlite3-lib" unable to locate
    By dakilla191 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 0
    Last Post: 07-03-2011, 06:17 AM
  4. Unable to get Touch to work in UITextView
    By sicga in forum The Developer's Lounge
    Replies: 1
    Last Post: 01-20-2010, 09:57 PM
  5. Unable to locate Keyvib app within cydia.
    By TrueCrimeNY in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 7
    Last Post: 09-10-2009, 12:34 AM