1. Ace2213's Avatar
    iPhone 3G, running iOS 4.2.1 (spoofed as 4.3.1) + redd00r, unlocked using ultrasn0w. Cydia version 1.1.8; reinstalled with no use.

    I can't remember if this issue was present when I first received the phone, but I know it was made apparent to me when I started installing DEB packages (mostly via Cyder 2 but also from Cydia itself). The phone was running iOS 4.1 when I first got it, that's all I know. I had to restore it and do everything again myself from scratch because I don't even know who jailbroke it to begin with so I can't rely on them in case anything went wrong. Anyhow, the first manifestation of the problem occurred when I first tried to remove certain apps/tweaks. Cydia listed a whole bunch to be removed when I only wanted to remove one or two of them. I said yes and it removed all of them. The second time this happened it didn't work, I realized it's because (after I unlocked it with ultrasn0w) there was a qued upgrade to be made, and I had no internet access at the time. However when I tried to perform the upgrade in the presence of fully-functional wifi, it wouldn't work. And the "by-the-way" installations and removals now required with the upgrade keep increasing in number. Cydia Upgrade problems-img_0002.png When I try to upgrade I receive a screen-full of "Host Unreachable" and "Cached Failure" errors then it loads and the bottom button says Return to Cydia, as if nothing had happened, and nothing did.

    A likely cause for this problem is the fact that I'm currently living in Syria. However I have Tor installed and am confident that it works perfectly fine due to the fact that I used it to activate WhatsApp and Viber, both presumably blocked here in Syria. My Tor SBS toggle is always on, and all my internet activity is rerouted through it. Could it be that Cydia traffic doesn't go through proxy servers ? Because I have received 403 errors when Cydia is updating at launch, Cydia Upgrade problems-img_0001.png which is something you get used to when you've lived here over a year.

    Sorry I don't have a screenshot of a failed upgrade attempt, but you get the gist lol Any solutions or hints at solutions would be very appreciated!
    Last edited by Ace2213; 12-16-2012 at 04:45 AM. Reason: Added Cydia version and that I've tried reinstalling it.
    12-16-2012 04:43 AM
  2. rdiddy_25's Avatar
    Just means that u have some old or dead repo's installed and Cydia can't update/contact them, hence the unreachable errors u are receiving. U can delete the old repos and Cydia should load faster. Also try updating apps/tweaks individually rather than at the same time. Will go a lot smoother
    12-22-2012 08:48 PM
  3. Ace2213's Avatar
    That's the point, it won't let me! ANYTHING I try to do (installing, removing, upgarding) brings me back to this page, listing all of these tweaks that are qued (not by me) either for removal or installation/upgrade. I solved the problem by performing a restore and rejailbreak and everything (after my system partition got overloaded due to the inability to remove tweaks and my lack of patience when it comes to installing new ones that caused the device to stop turning on all together), but after that, every time I restored from an iTunes backup, the problem was back. Not only that, but installing tweaks via iFile became impossible because I started receiving "Superior user privileges required" with no way of working around it. I restored it several times with everything going fine until I restore from an iTunes backup, so I skipped that step and used my phone anew. So far so good, except for ultrasn0w no longer working for some reason.
    12-23-2012 03:56 AM
  4. 3cit's Avatar
    Ok so you are running iOS 4.2.1 on a 3G?
    And you are jailbroken?
    So right now you're in a good state.
    Try ultrasnow fixer for your current ultra snow issue.
    Also good job on the restore as new choice. Sometimes you just need to start over.
    12-23-2012 02:23 PM
  5. Ace2213's Avatar
    Yes, but spoofing the firmware version as 4.3.2 for installing apps. I'm in a perfect state as far as my iPhone being a fully functional iPod touch (with one exception, the Cydia bug is back. Apparently it's linked to certain packages that cannot be updated from Syria due to whatever BS they decide to chalk it up to, and the 403 errors they bring back are the most likely cause for my Cydia issues.

    As for ultrasn0w fixer, I thought that was only for newer iOS versions (5+) ? I didn't know there was an older version for my phone. In fact, just now I tried re-upgrading the baseband back to iPad, hoping it would solve the issue (though I have unlocked this same device, on the same firmware more than once, after downgrading from iPad bb, before it stopped working) but that doesn't seem to have done the trick either. I guess I need to fully restore & jailbreak in order to upgrade the bb. I'll just look for an ultrasn0w fixer version for my phone. Thanks for the suggestion!

    P.S, while we're on the topic of old vs. new versions, I've read that the newer versions of ultrasn0w have long dropped support for 3G, which made me iffy about installing anything over 1.2.5. So assuming this works (eventually), since Cydia updates all packages by default and there seems no work-around for that, wouldn't the upgrade of ultrasn0w relock my phone ? Because I have tried uninstalling/turning off the ultrasn0w substrate before and lost network access, but never really checked to see if it still works after the Cyda upgrade simply because the upgrade has yet to be completed successfully lol
    12-24-2012 06:20 AM
  6. 3cit's Avatar
    i have no experience with unlocking or ultra snow, excpet what ive accidently read...
    however, there is no way this phone is locked into a contract so is it possible to get the phone factory unlocked from the original service provider? which would help immensely with anything you are trying... also, on a selfish note, how are you spoofing the firmware of the device? just a plist eidt or something? cuz that wouldnt really affect anything systemwide, just let you try (and fail, or have severe consequences) to install apps and tweaks that arent abel to run on your phone...
    so you need to go to unspoof, then go to cydia and remove mobile substrate (effectively wiping cydia clean) then reinstall mobile substrate so that you can install only the tweaks that are made for your firmware.
    you shouldnt install tweaks that you "cant" install, just by tricking cydia into thinkn ing you are in fact on a later firmware.
    12-24-2012 06:58 PM
  7. Ace2213's Avatar
    Yes, I just edited the plist file. And don't worry, it's not as simple as that. First of all, I don't install substrates this way, I know better. I only install official IPA apps that are for 4.3. But even then, it doesn't always work. Using iTunes or iFunBox, I get errors saying the apps aren't compatible with my device. iFunBox even takes it a step further and tells me WHY it's not compatible, by listing its hardware as well as software requirements. For example, Angry Birds Seasons cannot be installed on my phone because it requires OpenGL hardware acceleration (which I'm assuming only came with 4/4S+). I spoof my firmware to allow apps that CAN work on my device to be installed because as I'm sure you know, Apple does take keen measures to ensure consumers update their hardware device every 6 months to a year. So by restricting apps to newer firmware that cannot be installed on older devices, as well as restricting firmware to newer devices in itself, they're not losing anything, they're just tricking the consumer into buying newer devices. They even say that 3GS could have supported Siri, but they sat on it purposefully, for the aforementioned reason.

    I've considered getting an official factory unlock, but due to the fact that I bought this phone 3 years ago second-hand, I'm not entirely sure whether all its dues are payed or not. But it's worth checking into nevertheless.

    Update: My baseband, 5.15, apparently isn't supported by ultrasn0w. So my options were either to fully wipe the phone to upgrade to an iPad baseband, or try to downgrade the baseband, which is obviously a much butter option, but it would only work if my bootloader is 5.8. Apparently iPhone 3G's are typically either 5.8 or 5.9, yet for some ungodly reason, mine is 6.02, according to FuzzyBand xD so I'm guna look around regarding that, and if I don't get anywhere and get totally desperate I'll have to restore, rejailbreak and upgrade to an iPad baseband.
    12-25-2012 03:30 AM
  8. Ace2213's Avatar
    I was right. Upgraded bb to iPad then back down to 5.13 and installed ultrasn0w, all was great until Cydia updated ultrasn0w. My signal was instantly lost -.- I guess I'll have to keep reinstalling the older version after every time I use Cydia. Thanks to all those that helped!
    01-02-2013 06:00 AM

Similar Threads

  1. Problem with cydia upgrades
    By Bashy in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 06-03-2010, 10:20 AM
  2. Issues with latest Cydia upgrade?
    By Massie in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 31
    Last Post: 05-13-2010, 06:35 PM
  3. Cydia refresh problem
    By jxj988 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 6
    Last Post: 04-17-2010, 02:31 PM
  4. Apple SMS (cydia app.) problem. Help?
    By ILBandit in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 03-11-2009, 09:33 PM
  5. Cydia upgrade issues
    By icyau in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 02-25-2009, 02:22 PM