1. janthe6th's Avatar
    What should I do to fix it? Now I just need to get my Tmobile service back and I dont really care what ios version it has.

    Thank you

    background: i'm trying to run the phone with a tmobile sim. i have tried lots of things to get the phone to recognize the sim but no go.
    and my firmware is 6.15.00, and i have old bootrom (i think)
    Last edited by janthe6th; 12-10-2012 at 04:29 AM.
    12-10-2012 03:50 AM
  2. iDonev's Avatar
    Being hacktivated and unlocked are two separate things. If you really are on iOS 6.0 (not 6.0.1), just go to Cydia and grab ultrasn0w.
    If you turn out to be on 6.0.1, go to google and search for ultrasn0w fixer for 6.0.1. Install that and then ultrasn0w itself.
    If the phone is locked to AT&T consider spending $5-$10 and getting it officially unlocked so you wouldn't go through all this hassle again.
    12-11-2012 01:56 AM
  3. janthe6th's Avatar

    i actually paid someone on ebay to unlock it for me. but after he said it's unlocked, no matter what i do, i cant still get it to recognize my Tmobile sim. My iphone says 6.0.1 actually. I tried the fixer and then ultrasnow but still doesnt work.

    Here is what i did:
    1: redsnow jailbreak with 6.0 ... when it's done i'm in the recovery mode loop so i tried recovery fix but it hang and i cant get to DFU mode
    2. itunes clean restore to 6.0.1 b/c i thought i would just need to purchase the unlock online
    3. while waiting for the unlock i tried redsnow again with 6.0 and it worked but i cant activate b/c i dont have a ATT sim
    4. downloaded iSpirit and deleted Setup.app to bypass activation and I can get into the phone fine
    5. unlock came but still "No service" no matter how many time I jailbreak using Redsnow. (one weird thing is even tho i point to 6.0 and successfully jb, the phone keeps saying 6.0.1)

    couple things i remember i did somewhere during the process: recovery fix...just boot...ultrasnow fixer -> ultrasnow.

    Now i'm only using the phone with wifi and no service still. I think the phone is already unlocked b/c the guy has reputation and many ppl have done it before me.

    Thank you for any help
    Last edited by janthe6th; 12-12-2012 at 05:39 PM.
    12-12-2012 04:39 PM
  4. vietalogy's Avatar
    Did you restore the phone after the seller confirmed that its unlocked? Also google sim lock status and input your imei and see if the phone is unlocked.

    via Tapatalk
    12-12-2012 05:44 PM
  5. janthe6th's Avatar
    i checked with google as you said and the phone is unlocked. at this point what should i do? i've done some readings and seems like i should downgrade base band or something? my base band is 6.15.00

    EDIT: it works now! i followed the instruction to downgrad BB and that fixed it
    Last edited by janthe6th; 12-13-2012 at 01:02 AM.
    12-13-2012 12:21 AM

Similar Threads

  1. iPhone 3GS: No signal but my 3G is fine
    By twindecks in forum iPhone 3GS Forum
    Replies: 0
    Last Post: 09-23-2010, 08:05 AM
  2. 3G with ios 4.0 jailbreak can't restore phone? Stuck 2/3
    By jonbeattie in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 07-18-2010, 08:30 AM
  3. my 3gs gets crazy when i use the power charger
    By zonico3000 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 9
    Last Post: 02-12-2010, 06:12 AM
  4. 3gs is faster when plug into outlet
    By jcampbell1070 in forum iPhone 4
    Replies: 0
    Last Post: 09-13-2009, 09:49 AM
  5. My iPhone 3G is real glitchy, Apple didn't care to replace it.
    By iLoveiPhones in forum iPhone 3G Forum
    Replies: 8
    Last Post: 07-31-2008, 06:27 AM