1. mooo25's Avatar
    I just jailbroke my iPhone 4 6.0 a couple nights ago. It worked just fine, and i used redsn0w 0.9.13dev4 and then used terminal on my mac to use SSH to install Cydia, since this version of redsn0w doenst come with Cydia. I was installing apps and themes etc, but then i thought my phone locked up, so i did the reboot, holding the power button and the home button until the apple logo popped up. It restarted and then non of the jailbreak apps worked. I realized later on that i need to do a tether boot, and that is why nothing was working, most likely...

    Anyway, me thinking that i needed to do everything all over again, i restored my phone and backed it up over iCloud. All my apps downloaded and everything was peachy, but when i went to jailbreak the phone this time, it didnt work properly. I jailbroke it with the same redsn0w edition, but when i had to install Cydia via SSH, this is what popped up:

    ssh: connect to host 192.168.0.14 port 22: Connection refused

    idk why it is doing this, i have been looking for a couple days trying to find a solution. I have restored my iphone over and over again and re-jailbreaking it, i have tried to SSH through other computers, no luck their either. I check the IP addresses to make sure it was right, and it was. I opened up the necessary ports on my router. Idk what else to do. I hope that someone here can help me, because it is really pissing me off, and i dont know why it worked the first time, but didnt work the second or third or forth, etc.
    10-06-2012 09:48 PM
  2. iDonev's Avatar
    Have you tied jailbreaking before restoring from iCloud?
    Try doing in the "Welcome Setup" right after you choose a wifi network.
    10-07-2012 01:56 AM
  3. mooo25's Avatar
    Tried it, and it still didnt work. Same exact problem. The SSH wouldnt work.
    10-07-2012 06:43 PM
  4. daf1892's Avatar
    Might seem obvious and stupid, but did you tether reboot it after jailbreaking the phone before trying to install Cydia

    I ask as I forgot that step first time round lol :o
    10-08-2012 11:14 AM
  5. 3cit's Avatar
    its also possible that your router assigned your "new" (you restored it, remember) iphone a different ip address... are you sure your using the correct address?

    another thing, not sure its relevant, is that when i was using winSCP wirelessly, for no particular reason my iphone 4 wouldnt connect at all, then minutes later everything would be great..., since then ive switched to programs like ifunbox that allows terminal through a wired connection.
    10-08-2012 11:27 AM
  6. mooo25's Avatar
    I did do a tethered boot after every attempt to jailbreak. I also checked the ip address every single time to make sure it was right every time.
    10-08-2012 11:49 AM

Similar Threads

  1. iPhone will not update to 4.2.8 (Jailbroken)
    By ScoobyDoo27 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 05-17-2011, 10:07 PM
  2. iPhone will not work with Pre Paid sim?
    By Britishbrendan in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 01-05-2010, 04:34 PM
  3. iphone will not connect to milb audio
    By bill98117 in forum iPhone 4
    Replies: 0
    Last Post: 09-10-2009, 04:53 AM
  4. iphone will not dial out
    By SRN in forum iPhone 4
    Replies: 1
    Last Post: 03-08-2009, 09:38 PM
  5. need help with iphone, its not working! ):
    By prexybabe in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 2
    Last Post: 03-07-2009, 10:12 PM
LINK TO POST COPIED TO CLIPBOARD