1. JLoven's Avatar
    I recently did a jailbreak on my Iphone 3g. I used Redsn0w 0.9.14b1 with 4.21 firmware the first time, and redsn0w 0.9.14b2 the next time. I am currently running on 6.15.00 and everything is good except all I have going for me is the Edge network. I have went to Cydia and downloaded Ultrasn0w as well. I've tried a couple of tricks such as switching off my 3g and turning it back on, resetting the Network, I tried to jailbreak again as well. I also have tried using the SBSettings to fix the issue and still no luck. I even went as far as trying the downgrade from the Ipad baseband and all that did was showed a blank area in my firmware description and then I couldn't connect to anything. Therefore, i ended up having to reinstall the ipad baseband. I feel like I'm running out of options. PLEASE HELP!!! I HATE IT BEING SLOW!!!
    07-29-2012 12:28 AM
  2. Tony the Tiger's Avatar
    Are you unlocked on T-Mobile? You do realize that their 3G isn't compatible with iPhones.
    JLoven likes this.
    07-29-2012 02:09 AM
  3. JLoven's Avatar
    I am unlocked and on the tmobile network. So in that case, I will not be able to receive any 3g speeds unless connected to wifi?

    EDIT
    I just did a little more research and figured that out for myself. Thanks for the info and for any one else wandering about this, here is a link that will give you some hope.
    T-Mobile Turns on iPhone-Compatible Network at WWDC | News & Opinion | PCMag.com
    Last edited by JLoven; 07-29-2012 at 03:04 AM.
    07-29-2012 02:57 AM
LINK TO POST COPIED TO CLIPBOARD