1. Butler007's Avatar
    Hi there,
    I was using ifile today to change the icons of some of my apps which hadn't sorted themselves out automatically when I installed the theme Desu Retina when suddenly these squares appeared on the springboard.
    I can't find the .PNG file in ifile to allow me to delete them and I can't really figure out what caused them either. Even more weirdly to me is that they are all attached to the app to their right, not the one right next to them on the left! So if i move one app, the square will always go with it.
    I'd really apreciate it if anyone can tell me how to get rid of them! I'm running the tethered redsn0w jailbreak of ios 5.1
    Thanks
    Last edited by Butler007; 04-11-2012 at 11:40 AM. Reason: Extra information
    04-11-2012 11:28 AM
  2. Ipheuria's Avatar
    It looks to me like you may have messed something up in the file. iFile is really powerful and you can mess your phone up royally so you have to be more careful. When you are changing actual files on the device always make sure you have a copy of the file so if anything goes wrong you can put it back to how it was originally. You can use iExplorer to easily navigate the file structure of your iPhone and export files to your computer as a backup. The next thing to know is that you must get the filenames of the graphic files exactly correct even the case. So Test.png is not the same as Test.PNG I learned this the hard way. So go in and look for the files you replaced and make sure the naming is correct. The next thing is if there are icons that didn't change with a theme create the icons in the theme don't mess with the originals on the phone. This will prevent you from having to do restores etc. You can also try removing all your themes and see if these boxes are a part of the theme or a part of some messed up OS files.
    04-11-2012 04:37 PM
  3. Butler007's Avatar
    I kept all the original files and left them in their original folders (I just but Base_ in front of the file names so that I knew which was which). I was really careful copying file names because I knew that it wouldn't work if I got the name wring so I'm quite confident that I didn't make any mistakes here, and if I had, would that cause something like the squares I'm seeing? Or would it just prevent me from doing what I was trying to do? A lot of the naming was correct in the theme folder but still wouldn't work, even after rebooting and respringing.
    I made sure I backed everything up using iBackup before I played around and once the squares appeared, I restored to my latest backup, but it somehow didn't revert the change. I have also tried removing and re-installing the theme that I was editing and that made no difference either, so I really don't know what to do about it! Thank you for the help though, do you have any more suggestions?
    04-11-2012 04:55 PM
LINK TO POST COPIED TO CLIPBOARD