1. scott11's Avatar
    I am somewhat new to jailbreak and I made a mistake. I added some of the "bad" repositories to try out a few apps. While browsing the apps I saw "my profiles" I had remembered reading about this app before my jailbreak and decided to install it. I did not read the details, and it turns out it does not work on 5.0.1 which is what I am running. Needless to say the app did not work once installed.

    I have tried to remove the app via cydia, but it gives me errors each time. What is worse is now it is stuck in my queue, and errors every time i try and install a new app.

    The errors are:
    subprocess pre-removal script returned error exit status 139

    Sub-process /usr/bin/dpkg returned an error code (1)

    Any ideas on how to fix this? Other than the inablity to use cydia to install an app, the phone and the other apps work fine.

    thanks.
    03-28-2012 12:21 PM
  2. BLiNK's Avatar
    this is exactly why i always set myself up as 'Developer' in my Cydia settings [Cydia>Manage>Settings>Developer]

    after looking into the other files that are downloaded with MyProfiles it appears you may have only removed One of many

    first: you need ot set yourself up as Developer in Cyida to be able to see the "other" files [Cydia>Manage>Settings>Developer] once that is done then look for the following files in your packages and delete:

    IntelliShared

    IntelliShared Lib 4.X

    MyProfiles (this is the one you more than likely deleted already)

    OpenSSL (this one may not need to be removed since there are other apps/tweaks that rely on it. hold off on it)

    hope this helps!
    03-28-2012 01:48 PM
  3. scott11's Avatar
    I had actually already removed the 2 inteilli shared files, it is the myprofiles file that will not remove. I have not touched the open ssl.

    Is there a way to manually remove via ssh or another tool? Anyway to get it out of my queue? I dont care if it sits on the phone, I just dont want it to error out every time I try and install or update an app.


    Dont know if this will make a difference in the solution, but the app is from the sinful repo, which now appears to be no working (at least on my phone)

    Looking around online, seems like ppl have similar issues removing MyWi. Have seen various suggestions- I dont have ifile, but do have ssh.

    Could try the apt-get remove from ssh, but a bit worried about what that might do. Any ideas?





    EDIT SOLVED--

    Found this:
    FTP into your phone with WinSCP, iFunBox etc
    - Goto /private/var/lib/dpkg/info and delete the following two files...
    --- com.sinfuliphone.myprofiles.postinst
    --- com.sinfuliphone.myprofiles.prerm

    I then removed it via cydia and it seems to be gone.

    Thanks for the help
    Last edited by scott11; 03-28-2012 at 03:30 PM.
    03-28-2012 02:16 PM
  4. BLiNK's Avatar
    glad you got it sorted. also, i have to give you props for stepping up your game in the troubleshooting. most people would have given up and restored or just dealt with it
    03-28-2012 04:12 PM
  5. 3cit's Avatar
    My profiles can work now on 5.0... It's like a tweak to a tweak method if you decide that you need it....
    03-28-2012 07:00 PM
  6. scott11's Avatar
    i would be interested in hearing about how to get it to work. Cant seem to find another app that will do what I want
    03-31-2012 07:21 PM
LINK TO POST COPIED TO CLIPBOARD