1. cheleb's Avatar
    Hello-
    I am somewhat new at updating my iphone to the newest IOS. I had an older iphone and could always find a video or something that walked me through it step by step, but just so unsure now that I have my 3gs. So what I have is a 3gs unlocked/jailbroken on 4.3.2 it did hare the 06.15.00 baseband when I got it. Ive had NO issues with the phone, but so would love to get it updated. Ive just been scared and unsure with so many different things stated out there about bootroms etc I have backed up my iphone in itunes and also used Tinyumberella to save my current blobs. Just want to assure I am following what is right for me to get the right update.

    Can anyone be of help to me in a sure bet way to get my phone updated to the 5.0 IOS, for my particular situation? Thank you SO MUCH in advance for any help you can give me.
    Thank you!
    03-12-2012 02:44 PM
  2. Gixxer07's Avatar
    You only need to make one post in the appropriate forum.
    03-12-2012 02:58 PM
  3. cheleb's Avatar
    Oh ok, I just was not sure which one is the right forum as it pertains to both. Sorry about that..

    thank you
    03-12-2012 03:02 PM
  4. Massie's Avatar
    You should be able to use these instructions: Preserve iPhone 4, 3GS Baseband on iOS 5 Sn0wBreeze [Windows] | iJailbreak.com

    The big thing for you is that you can ONLY restore using a CUSTOM firmware because of the ipad baseband. iTunes will not allow you to update or restore to a normal firmware. The above guide uses 5.0 as an example, but if I were you I'd simply use the 5.1 ipsw (the steps will be the same) which will mean you don't have to worry about SHSH blobs, because Apple is currently signing 5.1.

    Good luck!
    cheleb likes this.
    03-12-2012 03:38 PM
  5. Gixxer07's Avatar
    It's ok everyone does it at some point for the most part. Was just informing you, no harm intended
    03-12-2012 03:41 PM
  6. cheleb's Avatar
    Hi Massie-
    first of all THANK YOU for your input and direction.. I thought that the 5.1 is a tethered? If it is not, do you know where I can find the custom file for that? In the link you provided it gives the links for the 5.0.1. Again thank you..

    And Gixxer07, thank you for guiding a newbie, I do appreicate it.
    03-12-2012 04:06 PM
  7. Massie's Avatar
    5.1 is tethered for most, but if you have an old bootrom 3GS you'll be untethered. Look into that to see what kind of 3GS you have. Otherwise, yes, you could go to 5.0.1 for untethered IF you have SHSH blobs saved for 5.0.1.
    03-12-2012 04:30 PM
  8. cheleb's Avatar
    Sorry I am trying to follow. I am currently on 4.3.2, so can't have 5.0.1 blobs saved until I have upgraded to the 5.0.1. So because of that you are saying that I now can't update my ios until they come out with a untethered 5.1 update? I have a new bootrom.... Thank you
    03-12-2012 04:50 PM
  9. cheleb's Avatar
    This just got a lot more confusing... *sigh*.....
    03-12-2012 05:18 PM
  10. Massie's Avatar
    No, you can still have blobs saveddid you have Cydia saving them? Run TinyUmbrella and see what you have.

    (Blobs are saved based on what Apple is signing, NOT based on what you have installed.)
    03-12-2012 05:49 PM
  11. cheleb's Avatar
    Well I just did the backup of shsh last night in tiny umbrella. I know apple stopped signing 5.0.1 a few days back. When I'm in Cydia tho, at the top of the homepage, it shows Shsh IOS 4.1, 4.3.3, 4.3.4, 4.3.5, 5.0.1. So not sure if that is helpful or not... Any further thoughts! Thank you!!
    03-12-2012 06:34 PM
  12. cheleb's Avatar
    Hi again.. I just had a minute to go back into tinyumrella and forgot to check the box to request the shsh files. Once I did all of them including the 5.0.1 is now showing in there. So am I correct in thinking it is ok for me to do the update per the link to the article for the 5.0.1 update? And this article is good for the new bootrom 3gs on 06.15.00 correct?
    Thanks again for all of your help and insight...
    03-12-2012 08:03 PM
  13. cheleb's Avatar
    Also.. I wanted to assure that the custom files (as explained in the article) are in fact designed to preserve the baseband? Or if I needed to check something in redsnow or something to assure the BB is preserved (with it being the 06.15.00). Thank you...and sorry for all the questions.
    03-12-2012 08:06 PM
  14. Massie's Avatar
    Sweet! If you have the 5.0.1 SHSH, you should be good to go! Just remember: custom ipsw only, preserve iPad baseband, and read a few walkthroughs first. And no 5.1!
    03-12-2012 08:12 PM
  15. Massie's Avatar
    I don't do unlocks so do some more research but I believe you'll need to check Extras/Custom ipsw if using redsn0w. See more here: How to Get the iOS 5.0.1 Untethered Jailbreak Using RedSn0w

    I think the result will have "no_BB" in the file name.
    cheleb likes this.
    03-12-2012 08:18 PM
  16. cheleb's Avatar
    I don't do unlocks so do some more research but I believe you'll need to check Extras/Custom ipsw if using redsn0w. See more here: How to Get the iOS 5.0.1 Untethered Jailbreak Using RedSn0w

    I think the result will have "no_BB" in the file name.
    Ok, don't mean to sound dumb... but I liked this most current link you sent using redsnow. I think I found that one prior to the other one you sent to me. But you are right it does not specify what to do for the unlock (or does that happen when it is jailbroken). I think I may be confusing myself, but want to be clear before I move forward...
    03-12-2012 08:29 PM
  17. Massie's Avatar
    The unlock would come after...what are you using now? Ultrasn0w?
    03-12-2012 08:32 PM
  18. Massie's Avatar
    Hopefully this last link will clear it up: How to Unlock iOS 5.0.1 With UltraSn0w

    Basically:
    -update w/preserved bb
    -jb
    -install ultrasn0w to unlock
    cheleb likes this.
    03-12-2012 08:40 PM
  19. cheleb's Avatar
    The unlock would come after...what are you using now? Ultrasn0w?
    It was unlocked when I got the phone, but I believe so. And that is what has to be in the sources area of cydia right, for the unlock?
    03-12-2012 08:40 PM
  20. cheleb's Avatar
    Hopefully this last link will clear it up: How to Unlock iOS 5.0.1 With UltraSn0w

    Basically:
    -update w/preserved bb
    -jb
    -install ultrasn0w to unlock
    Thank you! I am going to go for it soon. I can't thank you enough for all of your support and help. I hope nothing will go wrong and I can report back to you that all was a success~

    THANK YOU!!!
    03-12-2012 09:04 PM
  21. Massie's Avatar
    Happy to help. My guess is that if you run into anything tricky it will be during the restore process (maybe with pwned DFU or something like that)...if you get any errors or anything don't panic; it can probably be sorted out. Good luck!
    03-12-2012 10:22 PM
  22. cheleb's Avatar
    Happy to help. My guess is that if you run into anything tricky it will be during the restore process (maybe with pwned DFU or something like that)...if you get any errors or anything don't panic; it can probably be sorted out. Good luck!
    Well in trying to do it with redsnow, did not work. Got an error 13.. something error stating the iphone could not be restored. SO, I am now trying to go with your original article link using snowbreeze. Hope it will work... Thank you for your comforting words of not panicing! I don't know why doing this scares me so much even though I am extremely OCD and follow and read the directions over several times with each step... I will be in touch..
    03-12-2012 11:12 PM
  23. cheleb's Avatar
    Well in trying to do it with redsnow, did not work. Got an error 13.. something error stating the iphone could not be restored. SO, I am now trying to go with your original article link using snowbreeze. Hope it will work... Thank you for your comforting words of not panicing! I don't know why doing this scares me so much even though I am extremely OCD and follow and read the directions over several times with each step... I will be in touch..
    Nope got the same error... it is actually error 3194. I am at a loss right now how to figure this out as to why it is giving this error...
    03-12-2012 11:39 PM
  24. Massie's Avatar
    Sorry you're running into issues. Another idea: have you tried using iFaith? I know another forum member here just used it to downgrade from 5.1 to 5.0.1, so it has definitely worked for him.

    I think that error code is related to Apple not signing the firmware you're using. It's too bad we weren't doing this a week ago...I'll dig for some more info.
    03-13-2012 12:07 AM
  25. Massie's Avatar
    Also...were you in pwned DFU when trying to use redsn0w?
    03-13-2012 12:13 AM
38 12
LINK TO POST COPIED TO CLIPBOARD