Trade in and save big📱:Get an iPhone 11 for free
  1. superryan14's Avatar
    Hello, I've had my ipod touch 3g for about 3 months now and recently jailbroke it using redsnow. then a couple of days ago I went to put music on it and itunes says this "iTunes cannot read the contents of the iPod "iPod". Go to the Summary tab in the iPod preferences and click Restore to restore this iPod to factory settings."

    Then I go ahead and hit restore and it sticks on "Preparing Ipod for restore" (About 5 minutes or so) Then it give me another error box that says The iPod "iPod" Could not be restored. An unknown error occured (1604). after I hit ok, it gets stuck in recovery mode.

    After all that I have to plug it back in and open redsnow again and do the recovery fix. But I still can't add music or anything onto it through itunes I get the first error I said about before. If anyone could help me fix this. Have the ipod jailbroken or not. As long as i'm able to put music and other things on it that would be fine.

    I've tried different USB ports, restarted my computer multiple times, Made a new account on the same computer and tried it on a different computer that didn't even have itunes on it to begin with so I don't know if there is any other solutions for this.

    Thanks if you help
    Last edited by superryan14; 03-04-2012 at 07:01 AM.
    03-04-2012 04:45 AM
  2. Massie's Avatar
    03-04-2012 09:26 AM