1. thestud54's Avatar
    Anyone have any troubles trying to restore to stock iOS 5.0.1 on their iPhone 4s after jailbreaking. I have downloaded the IPSW file direct but keep getting stuck on "Verify Restore With Apple" which is eventually timing out to a 1602 error. Very frustrating as all I want to do is be back to stock firmware.

    Any help out there? I havent seen any other threads or helpful google links to solve this. Thanks in advance.
    01-24-2012 10:59 PM
  2. eduardoayala's Avatar
    Same problem here. I get error 1602 when attempting to restore while in DFU mode, and error 21 when in recovery mode...
    Any suggestions?
    01-26-2012 08:18 PM
  3. jordic's Avatar
    Exactly same problem..
    I have 5.0.1 - 9A405 and I have applied Absinthe JB.
    Because of the after uninstalling an application named biteSMS, problem occured. While booting, loading swirl pop up and spin infinite.

    I tried to restore my iPhone. But it gives errors below :
    in DFU Mode - iPhone could not be restored. An unknown error occurred (1602).
    in Recovery Mode - iPhone could not be restored. An unknown error occurred (21).

    I have tried both 9A405_Restore.ipsw & 9A406_Restore.ipsw
    Last edited by jordic; 01-27-2012 at 02:59 PM.
    01-27-2012 02:19 PM
  4. saynt j's Avatar
    I tried to restore to unjailbreak... but it didn't work.

    If you're willing... connect to itunes, hold Power and Home until the Apple appears... then release the Power key and hold home until iTunes tells you that the phone is in recovery mode and must be restored. Then reload your firmware.

    This will reset everything.... FYI. But, I was able to restore almost everything from the cloud and itunes.
    01-27-2012 02:23 PM
  5. jordic's Avatar
    I have already restore my iPhone to my computer but when i try to return back from my pc, it is not working.

    Now i have a dead iPhone 4s
    01-27-2012 03:10 PM
  6. jordic's Avatar
    My problem is solved. It is about TinyUnbrella Application.
    It changes my hosts file on my computer.
    Thats the reason why iTunes can not complete verify process.

    So changing the Hosts file (for win : C:\Windows\System32\drivers\etc\hosts) to the original one will solve my problem.
    oqmalik likes this.
    01-28-2012 10:47 AM
  7. StaticFX's Avatar
    i just had to restore...

    i was working on a theme and deleted the wrong cache files... all my apps disappeared. could not seem to get them back. so, i clicked restore, had it restore from icloud (which was a few more days old) - and now i am re-jailbreaking.

    No issues.
    01-30-2012 02:30 PM
LINK TO POST COPIED TO CLIPBOARD