1. rich67's Avatar
    I installed SB Settings and messed around with some of the features, namely hiding some of the stock icons (I hid Youtube, weather and stocks). I didn't care for the interface, so I uninstalled SB Settings and the Activator via Cydia. I noted the hidden icons were now placed in random places on my screen, so I put them back to where they were. Upon respring, the icons vanished again...hmmm. So then I went to my texts, and noted that the contact names were gone! So only the phone numbers I had sent texts to were showing up...grrrrr! I guess I shouldn't have installed it, considering I was already using intelliscreen, but live and learn.
    I have several questions:
    1) If the issues continue, what is the safest way for me to restore my phone? Will I have to restore to normal, re-jailbreak, then add all my Cydia purchases again?
    2) Am I missing some file that was installed by SB Settings that needs to be removed?
    3) I am using AptBackup, and have regularly backed up my apps. Is there a better system that would aid /facilitate in the restore of jailbroken apps if I had to restore?
    4) I have re-booted the phone a couple times, and the issue seems to have cleared up, but the icons I hid with SB are still not visible...no big deal,lol, but if I wanted them back, where on earth would I find them now? I am guessing I may have to re-install SB, and then toggle them back on, then uninstall again...
    Thanks in advance..
    01-23-2012 11:53 AM
  2. Allyson Kazmucha's Avatar
    I installed SB Settings and messed around with some of the features, namely hiding some of the stock icons (I hid Youtube, weather and stocks). I didn't care for the interface, so I uninstalled SB Settings and the Activator via Cydia. I noted the hidden icons were now placed in random places on my screen, so I put them back to where they were. Upon respring, the icons vanished again...hmmm. So then I went to my texts, and noted that the contact names were gone! So only the phone numbers I had sent texts to were showing up...grrrrr! I guess I shouldn't have installed it, considering I was already using intelliscreen, but live and learn.
    I have several questions:
    1) If the issues continue, what is the safest way for me to restore my phone? Will I have to restore to normal, re-jailbreak, then add all my Cydia purchases again?
    2) Am I missing some file that was installed by SB Settings that needs to be removed?
    3) I am using AptBackup, and have regularly backed up my apps. Is there a better system that would aid /facilitate in the restore of jailbroken apps if I had to restore?
    4) I have re-booted the phone a couple times, and the issue seems to have cleared up, but the icons I hid with SB are still not visible...no big deal,lol, but if I wanted them back, where on earth would I find them now? I am guessing I may have to re-install SB, and then toggle them back on, then uninstall again...
    Thanks in advance..
    Hey Rich,

    I don't think the issue you are having is directly related to SBSettings - blank icons and icons jumping out of folders or disappearing seems to be an issue since iOS 5.x and jailbreak.

    As far as them disappearing altogether, that could be due to the hidden icons. I'd suggest re-installing SBSettings and unhiding all icons before uninstalling it. SBSettings shouldn't be giving you issues though. I have intelliscreenX and SBSettings both installed. I have SBSettings sitting in the top shelf above the toggles for ISX and haven't had any issues.

    It may be fighting with another app you have installed. I'd evaluate what packages you have installed and make sure ones that perform similar functions aren't fighting each other for delegation.
    01-23-2012 04:38 PM
  3. rich67's Avatar
    OK, thank you! I'm going to re-install SB. I realized that the contacts that disappeared or weren't recognized were doing so because I had Emoji in them..lol. I deleted the Emoji and then re-edited them back in and all is well now. Let u know how it works out...
    01-23-2012 05:14 PM
  4. rich67's Avatar
    OK that did it. I re-installed, then selected the hidden folders again and they are now back where they should be. Phew. Thought I was going to have to restore everything...wasn't looking forward to it! Thanks for the info!
    01-23-2012 05:24 PM
  5. Allyson Kazmucha's Avatar
    Glad it worked!
    01-23-2012 08:56 PM
LINK TO POST COPIED TO CLIPBOARD