1. sebicatana's Avatar
    Hello everyone!
    I posted something similar a month ago but cant seem to find the thread anymore. So, here it goes: my friend moved from Canada to Europe with her brand new Iphone 4 running 4.3.5 on baseband 04.10.01. Now she wants to upgrade and unlock the Iphone so that she could use it there. What to do? I have been researching all over the internet and I cant seem to find the steps required.

    all that I know is that 4.3.5 only has a tethered JB so thats not going to work for her; also how should I go about doing all this?
    any suggestions?
    Thank you for your help
    01-20-2012 10:20 AM
LINK TO POST COPIED TO CLIPBOARD