1. joshuawo's Avatar
    Is there a trick to updating a jailbroken iPad on 4.3.3 to 5.0.1? Keep getting an error This device isnt eligible for the requested build
    12-27-2011 05:25 PM
  2. Garz's Avatar
    Is there a trick to updating a jailbroken iPad on 4.3.3 to 5.0.1? Keep getting an error This device isnt eligible for the requested build
    Did you try to restore or DFU mode then restore?
    12-27-2011 06:26 PM
  3. joshuawo's Avatar
    Hi Garz,

    Thanks for the quick reply.

    I tried both a regular restore and a restore from DFU mode, but both got stuck after trying to verify the iPad and I got the same "This device isn't eligible for the requested build" error.

    Any other suggestions would be greatly appreciated!
    12-27-2011 11:26 PM
  4. 3cit's Avatar
    Are you using newest redsnow?? Sounds like maybe not...
    12-28-2011 12:05 AM
  5. iDonev's Avatar
    Try using pwned DFU mode. Get iReb from ih8sn0w.com.
    12-28-2011 10:33 AM
  6. gamecockrph's Avatar
    Are you using tiny umbrella with a saves SHSH blob? If so you may need to go under advanced and uncheck set hosts to cydia on exit so you can have a clean Apple restore. You also can google the error code and see how to comment out a line in the command terminal that is creating the loop. Hope that helps.
    12-29-2011 09:53 AM
  7. derk's Avatar
    Here are some things to possibly try:
    1)Make sure you are using latest iTunes.
    2)Also, make sure TinyUmbrella isn't running. (It will block out the Apple servers from verifying upgrade)
    3)Also, make sure you aren't running any firewall software so that iTunes won't be able to contact Apple servers for verifying.
    4)Also, try using another USB port as you could have a USB port issue.
    5)Also, try using another machine (Mac or Win) if you can to run the DFU restore.
    6)Check your hosts file (if on Windows) to see if it's modified so that you can't connect to Apple servers for verifying.
    12-29-2011 02:05 PM
LINK TO POST COPIED TO CLIPBOARD