1. Jiglet's Avatar
    My jailbroken (Verizon) iPhone 4 randomly stopped working the other day - I can't get it to start up.

    When I plug it into the computer, iTunes says "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes." So it seems that it's in DFU mode.

    I never backed up any of my SHSH blobs. I'm not concerned with keeping the jailbreak at this point - I just don't want to lose my contacts/photos. I'm fine with upgrading to iOS 5 if it'll get my phone working again.

    I tried to upgrade through iTunes (via restore) and was told that "an unknown error occurred (28)".

    I've tried restoring on both the computer that the iPhone syncs with (OSX) and on a 64 bit Windows machine (via shift+restore) - no luck with either.

    Can someone point me in the right direction here? I am hesitant to take the phone to an Apple Store because I've heard that jailbreaking voids the warranty. Any help would be much appreciated - thanks!
    10-25-2011 03:11 PM
  2. 10001110101's Avatar
    Have you tried to re-boot only through redsn0w?
    Jiglet likes this.
    10-25-2011 03:39 PM
  3. Allyson Kazmucha's Avatar
    Try booting just via Redsn0w. If that doesn't work, you may want to download TinyUmbrella and tick "Start TSS server" - then see if the phone will restore. (or try TinyUmbrella to kick or fix recovery mode).

    You can also try editing host files manually if iTunes gives you errors. Sometimes that is the issue with jailbroken devices. Here is a link to a tutorial we have on manually editing host files for iTunes errors...

    How to Manually edit host files to fix iTunes restore errors
    Jiglet likes this.
    10-25-2011 03:48 PM
  4. Jiglet's Avatar
    Try booting just via Redsn0w. If that doesn't work, you may want to download TinyUmbrella and tick "Start TSS server" - then see if the phone will restore. (or try TinyUmbrella to kick or fix recovery mode).
    Okay, so I tried "Just boot" in redsn0w. It shows Identifying, waiting for iPhoneVZW4, exploiting with limera1n, then the screen lights up white, then the white disappears (but the screen is still illuminated) and redsn0w says "no identifying data fetched". So I take it that didn't work.

    With Tiny Umbrella, did you mean to start the TSS Server, and then attempt to restore the phone through iTunes? I've already tried Tiny Umbrella for Fix Recovery btw, no luck.

    Thanks for your help thus far, I appreciate it!
    10-25-2011 04:06 PM
  5. Jiglet's Avatar
    You can also try editing host files manually if iTunes gives you errors. Sometimes that is the issue with jailbroken devices. Here is a link to a tutorial we have on manually editing host files for iTunes errors...
    I've also tried editing my hosts file (per that tutorial you provided) and now I'm getting an "device isn't eligible for the requested build" error when I try to restore.
    10-25-2011 04:20 PM
  6. OlegWasHere's Avatar
    When you boot with redsnow did it go into dfu mode? As in hold power the. Power and home then home?
    10-25-2011 04:24 PM
  7. Jiglet's Avatar
    When you boot with redsnow did it go into dfu mode? As in hold power the. Power and home then home?
    I'm pretty sure (but not positive) that my phone is already in DFU mode. How can I be sure? The screen is blank. When I hold power+home, the phone seems to disconnect and then reconnect in iTunes (as in, it makes the disconnect noise, then disappears from the list of devices in iTunes, then makes the reconnect noise).
    10-25-2011 06:46 PM
  8. Allyson Kazmucha's Avatar
    I've also tried editing my hosts file (per that tutorial you provided) and now I'm getting an "device isn't eligible for the requested build" error when I try to restore.
    Now we are getting somewhere! I had that error too. Now try either restoring WITH the TU TSS server running or edit the host file to delete the Cydia server. One of those two scenarios "normally" resulted in a successful recovery for me for the requested build error.
    11-02-2011 12:24 AM
  9. OlegWasHere's Avatar
    I'm pretty sure (but not positive) that my phone is already in DFU mode. How can I be sure? The screen is blank. When I hold power+home, the phone seems to disconnect and then reconnect in iTunes (as in, it makes the disconnect noise, then disappears from the list of devices in iTunes, then makes the reconnect noise).
    Are you on windows or Mac?
    I'm not sure if you can actually tell(at least I can't) but I make sure it's off at least for a few seconds

    I start up redsnow(which closes iTunes) then hold the power and home button then as it goes black hit next on redsnow after just reboot and follow the timings on the screen and works every time for me

    Now if only new England got power back I wouldn't have to drive to McDonald's when my phone resets itself
    11-02-2011 07:53 AM
  10. luvesuga's Avatar
    I know this post is old, but was a solution found? I'm having the same problem with a 3GS.
    12-27-2011 07:08 AM
  11. jailbreakmatrix's Avatar
    diff you try a different mac ?
    12-27-2011 11:35 AM
  12. Allyson Kazmucha's Avatar
    I know this post is old, but was a solution found? I'm having the same problem with a 3GS.
    Have you tried the steps listed above? If so, try restoring with a different computer. Sounds weird but it works sometimes and I'm not quite sure why. It's one of those weird unicorn fixes no one really knows why it works, it just does.
    12-28-2011 09:55 PM
LINK TO POST COPIED TO CLIPBOARD