1. MustangLife's Avatar
    Hey all. I just downgraded my iphone4 4.3.5 to 4.3.3 with custom ipsw file from iclarified. Went through the whole process. And when complete I had to use fixrecovery to exit dfu mode. After a few minutes of some coding on my iphone 4 it through the phone in recovery mode. So I'm not sure what the next step is...

    1. Was I successful at downgrading ?
    2. Phone was exited out of DFU mode into recovery, whats next?
    3. I planned on jailbreakme but I can use snowbreeze if its easier to do since phone is in recovery mode?

    Someone just point me in the right direction
    PS ITunes of course says phone needs to be restored.

    Thanks
    Josh

    To add. I've tried a few other things. Been jailbreaking since summer 2009 and haven't had so many problems jailbreaking like I have on my first IP4. Used ireb to get the phone from recovery to to dfu mode to try the install of the new 4.3.3 file. Actually have 2 different files I've tried. I've also added a text in the host file that causes 3194 error in itunes.

    I don't know if this helps or means anything or not. But this is a brand new iphone4 on 4.3.5 with no blobs saved in Cydia and trying to downgrade to 4.3.3 and jailbreak 1 way or another.

    Now I after about 4 hours straight of google research, etc. I just need to know can I downgrade this new iphone4 on 4.3.5 to 4.3.3 and jailbreak it either with snowbreeze or jailbreakme. Or do I need to just stick with the 4.3.5 tethered jailbreak. If I can actually downgrade this phone with no blobs saved point me to a tutorial with troubleshooting. Because I'm far past the regular iclarified, etc. I'm having to use irecovery to get the phone out of dfu mode and ireb to get the phone from recovery to dfu to try it again. So I'm so stressed.
    Last edited by MustangLife; 10-02-2011 at 06:37 PM.
    10-02-2011 04:21 PM
  2. MustangLife's Avatar
    Folks I really need help. I've been without my phone for 6 or 7 hours now and I'm out of town on my pc i took with me. Phone is still in recovery mode. I'm at the point I'm just trying to restore the phone through Itunes normally. First few tries it quit pretty quick. 3rd try went through the restoring process for about 5 minutes before it quit. Same 3194 error. I have all security settings off. Updated and reinstalled Itunes. Rebooted PC 3 or 4 times. Plugged and unplugged phone. Tried Ireb and fixrecovery. I can't do anything nor do I have any idea what to do. Over 2 years of jailbreaking I was bound to have a hardtime sooner or later. Guess those are the odds. But now I just want to get the phone working again on 4.3.5 and maybe try tethered redsnow JB. But someone surely has an idea or something I can do.

    Josh

    PS - On last restore attempt. The phone got to around 75-80% finished according to the loading bar under the apple logo and than through a error 3004. So I'm guessing the error 3194 I've gotten rid of. But still no progress
    Last edited by MustangLife; 10-02-2011 at 08:48 PM.
    10-02-2011 08:30 PM
  3. Massie's Avatar
    First off: you'll never get it to downgrade without saved SHSH. Best bet is what you're trying to do--restore normally in iTunes to 4.3.5. If you haven't done it yet, go back and make sure your hosts file is as it should be (you don't need to add anything to restore in iTunes so remove anything you put in there before) and if you used Tiny Umbrella along the way go into the Advanced settings and make sure the "set hosts to Cydia on exit" option is UNchecked. After that, reboot everything, open iTunes, plug in and try to restore again.

    One last thing that shouldn't matter but may be worth doing is downloading a fresh 4.3.5 ipsw from iClarified in case you're having connectivity issues during the restore process...with a downloaded version, you can then use Shift+Restore and point iTunes at your downloaded ipsw. It will be getting the same file, but it may go smoother/quicker since it's not downloading it as part of the restore process. Good luck!
    10-02-2011 09:57 PM
  4. MustangLife's Avatar
    Yeh I gave up about 7 hours ago on the tiny umbrella and downgrading, etc. Been trying a restore ever since. I've had "set hosts to Cydia on exit" unchecked after research.

    Host files are below and the last 2 lines are below. These are the last 2 lines in my girlfriends pc also thats never had tinyumbrella on it.

    #74.208.105.171 gs.apple.com
    74.208.10.249 gs.apple.com

    I tried restoring on another pc account with a itunes that my phone has never seen. And the phone went through a 80 minute restore and went through the whole process like it was going to work and than it just finished and stayed in recovery mode( itunes logo with a usb cable ) I will download a 4.3.5 file and see if that helps.

    But other than to download a fresh 4.3.5 ipsw and using that to restore. I've done everything you mentioned. Thats why I'm scared.

    I just don't want to go through another 80 minute restore process (which is crazy, doesn't seem normal) again with no luck.

    The last message Itunes gave me was "Iphone software update server could not be contacted or is temporarily unavailable,etc etc" This was prior restore attempt before the 80 minute itunes trying to restore process.

    I will post back soon
    Last edited by MustangLife; 10-02-2011 at 11:21 PM.
    10-02-2011 11:19 PM
  5. MustangLife's Avatar
    I do have a saved Shsh of my 4.3.5. Don't know if that helps or not. Or if it can be useful.
    10-02-2011 11:23 PM
  6. MustangLife's Avatar
    Problem fixed after i took your advice and downloaded a 4.3.5 ipsw file and used that for the restore instead of Apple downloading it. Your rock Massie, thanks for the help. I have no idea why itunes couldnt restore my phone without me downloading 4.3.5 myself and using it.
    10-03-2011 12:32 AM
  7. Massie's Avatar
    Great, glad it worked out!
    10-03-2011 01:21 AM
LINK TO POST COPIED TO CLIPBOARD