1. ntjoe1's Avatar
    First off, I want to apologize for the newb questions I am about to ask. I am a current WebOS user (frankenPre 2 on Sprint) and with HP's remarkable efforts on the platform, am now waiting for Sprint's iPhone.

    I was given a water damaged 3gs a week or so ago which had been damaged back in December and promptly put up. It powered right up when plugged in and was on 3.1.2, although I didn't use it much. After transplanting the screen to a friends phone that was broken, I ordered a new screen and it worked fine. I decided it would be cool to use as an iPod touch to get familiar with iOS, plus I take classes with University of Phoenix and LOVE the app. I had to upgrade the phone to 4.0 or greater to use the app, so I tried to upgrade and jailbreak (Redsnow) to 4.1 after reading about the baseband (05.11.07-6.4_M3S2). I admit it was not a smooth process but once done, it would reboot after 3-5 minutes on its own. I also noticed the battery drain was significant. It would even reboot when attempting to sync music with iTunes if the sync took long and hit the 3-5 minute mark. I tried to restore with iTunes (shift-click) and could not take it to 4.3.5 (many different error codes - I'd say almost all of them at one point and time or another). I would do it with 4.1, however from time to time it would get stuck in recovery and I had to use TinyUmbrella several times to kick it out. Even a non-jb restore with 4.1 would produce the same rebooting.

    I used search here and other sites and wasnt too worried it I messed it up since it was free. I then began to notice the battery didn't seem to be charging during all this despite showing charging. I assumed the reboot and charging issues may be the charging port (which did show pink on the water indicator) so ordered another off eBay and replaced. After this, I got the black/blank screen most of the time or the flashing apple logo. Tonight I played more with it and finally got it back to a clean 4.1 from iTunes. It also showed 32% charged. I had an old ATT sim that was used through Go-Phone on an old 2G I had shortly a few years ago so it actually registered it with iTunes and I can play with it unjailbroken. The card is not activated, so I have only used wifi (between my 2-3 minute reboots). I have it in airplane mode with wifi on, have tried it with wifi off, disabled push, and so forth and it still does the 3-5 minute reboot.

    I included a copy of the log from TinyUmbrella to show the rebooting.

    I can only assume at this point its hardware related. Any ideas? I am not too familiar with all of the processes for iOS so please be patient with me and any newb questions I have. Any help would be greatly appreciated!
    09-26-2011 04:09 AM
  2. ntjoe1's Avatar
    Another interesting tidbit...I turned it off (red slide to shut down) at 30% charge. When I turned it on about 30 minutes later, it was at 20%.....wow! Them it did its 3 minute reboot and now says 46%.
    09-26-2011 04:16 AM
  3. ntjoe1's Avatar
    Well solved it. It was the battery. Replacement came in today, and it has been on for 25 minutes so far with no issues and is charging normally.
    10-03-2011 10:38 AM
  4. Peligro911's Avatar
    I was gonna say the reboots are normally the battery glad u got it fixed !
    10-03-2011 11:32 AM
LINK TO POST COPIED TO CLIPBOARD